summaryrefslogtreecommitdiff
path: root/app-misc/timew
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-13 12:31:46 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-13 12:31:46 +0100
commit6fcdccbe589d724b6c268b49f66414e40eb0d807 (patch)
treeb0b74ac37d41e5d22a5a758517b215d1829cdb67 /app-misc/timew
parent3ea54510168a7ed4271b85f7292beca67346bfe9 (diff)
gentoo auto-resync : 13:09:2024 - 12:31:45
Diffstat (limited to 'app-misc/timew')
-rw-r--r--app-misc/timew/Manifest2
-rw-r--r--app-misc/timew/timew-1.7.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index e1d4c3cfe213..72bbe83b3a19 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1,3 +1,5 @@
DIST timew-1.4.3.tar.gz 3188726 BLAKE2B ded92b2ba801023e7f6bc59c0fc17ce069c8279ee92f39280c50dabec0a2425b8612f73edf7842abdbb0b21772244eda325512070c091f32d17ff69cfcd844fa SHA512 89c98ad19d3a5ab5d4e02819d79e553cca4e93da99ec02bbf845b96b421cd084f6786de160e90c97854b50da49448472e9a4c7d23e75c8a93ecd67dda768b24a
+DIST timew-1.7.1.tar.gz 3102854 BLAKE2B e3ae527a5405bf27e92619f9cc02046646a8ef60ae721c1ad66e30560c9a8535e6e71388c7ea2eeb84b6b5bb8d7ce4845b77e6a36a54869e5f80021232a924ed SHA512 f28f6c47cc05d8055cc3fae9e96d1936554c685090a40f8af1995e5357947cb9bdfab0ec091f68693a566a876e06eda502de074900f7368a913e85d7e4cf87f1
EBUILD timew-1.4.3-r1.ebuild 1014 BLAKE2B 3659c14dbb3831a1fea1e7676974568ad4ddeb47ec5dc7fc1152909072fb4f4fcff9febaa47e558487980c3541f48e8ba91a7b30f9a4e28e5d388f416508cba4 SHA512 b5dd8d62efd3e65ab7649f007cecdd506cb8c15b1be9d142968bb4801c0cfa441a0407bea1cdc771c797396ca815a8e11ba874821897580e4a61538e0dc37237
+EBUILD timew-1.7.1.ebuild 1113 BLAKE2B 1014cc0fc0011c7aba6bec0848789842f101e8607516ed871f9b719a8e48d79ec8a806ecacb35988f585f454394ed30c857ec69bd38d3815c9067fd4cac9ab6e SHA512 c96e08593804790d81828cc0c3f18d1284209dd1053b9c4195270eb48ed97f40dd84e3cb94ebb39a43ec09775e66bce2f9807132bab3d12a56434be51641b62b
MISC metadata.xml 708 BLAKE2B 3b8781f0aad86446298f0bff09bc9be053865a114227341cbde00586dc678401ceb8ee7a20e6b03dd23c14dda678c882b18174f9d38fc0fa0d2a7260898ae0e6 SHA512 294c6b699e084282feaf9b1409dd12c8cd7aff0757dba80efcb261d68d4e29449a1f708628a6c80ceac819640144fa6a019f869bbe6fef7390d1353f97c8b86f
diff --git a/app-misc/timew/timew-1.7.1.ebuild b/app-misc/timew/timew-1.7.1.ebuild
new file mode 100644
index 000000000000..c8e55e30359c
--- /dev/null
+++ b/app-misc/timew/timew-1.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake shell-completion
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://timewarrior.net"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+src_configure() {
+ local mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${WORKDIR}"/"${P}"_build || die
+
+ eninja test
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc -r ext
+ docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
+
+ doman doc/man1/*.1
+ doman doc/man7/*.7
+ newbashcomp completion/timew-completion.bash timew
+ dofishcomp completion/timew.fish
+}
+
+pkg_postinst() {
+ elog "To integrate timewarrior with taskwarrior, issue the following commands:"
+ elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
+ elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
+ elog "see https://timewarrior.net/docs/taskwarrior/"
+}