summaryrefslogtreecommitdiff
path: root/app-misc/tmuxp/tmuxp-1.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-16 20:31:05 +0100
commitae99f3df3fb5c7ebb085d4a198c1854a4c9a1bee (patch)
tree63845e7d405c04516103b1cee33911cea9a63b0e /app-misc/tmuxp/tmuxp-1.13.0.ebuild
parent2cb26483945211e812d7a0351ae472a676cd9592 (diff)
gentoo auto-resync : 16:08:2022 - 20:31:05
Diffstat (limited to 'app-misc/tmuxp/tmuxp-1.13.0.ebuild')
-rw-r--r--app-misc/tmuxp/tmuxp-1.13.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.13.0.ebuild b/app-misc/tmuxp/tmuxp-1.13.0.ebuild
new file mode 100644
index 000000000000..688f6ab2ea69
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.13.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ >=dev-python/kaptan-0.5.10[${PYTHON_USEDEP}]
+ =dev-python/libtmux-0.14*[${PYTHON_USEDEP}]
+ >=dev-python/click-8.0[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ dev-python/pathspec[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/tmuxp-1.7.2-tests.patch"
+ "${FILESDIR}/tmuxp-1.9.2-tests.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest
+}