summaryrefslogtreecommitdiff
path: root/app-misc/tmuxp/tmuxp-1.30.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-12 04:40:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-12 04:40:07 +0100
commit5d5e56d92268c2b9b6ccc38eeaa3516ce9b1e8fd (patch)
tree587e467a631661f0e4786a584d79db3a9eeab5d7 /app-misc/tmuxp/tmuxp-1.30.1.ebuild
parentf8399e5cf87087ab3b9f8b1ed2955c0bd5469a9b (diff)
gentoo auto-resync : 12:09:2023 - 04:40:07
Diffstat (limited to 'app-misc/tmuxp/tmuxp-1.30.1.ebuild')
-rw-r--r--app-misc/tmuxp/tmuxp-1.30.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/tmuxp/tmuxp-1.30.1.ebuild b/app-misc/tmuxp/tmuxp-1.30.1.ebuild
new file mode 100644
index 000000000000..85ceb04035b4
--- /dev/null
+++ b/app-misc/tmuxp/tmuxp-1.30.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=poetry
+inherit distutils-r1
+
+DESCRIPTION="tmux session manager. built on libtmux"
+HOMEPAGE="https://tmuxp.git-pull.com"
+SRC_URI="https://github.com/tmux-python/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+ =dev-python/libtmux-0.23.2*[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.3.9[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ >=dev-python/pytest-rerunfailures-4.2[${PYTHON_USEDEP}]
+ >=dev-python/tomli-1.1.0[${PYTHON_USEDEP}]
+ !dev-python/flaky
+ )
+"
+
+EPYTEST_DESELECT=(
+ # test doesn't get along with sandbox
+ "tests/cli/test_load.py::test_load_zsh_autotitle_warning"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ SHELL="/bin/bash" epytest tests
+}