summaryrefslogtreecommitdiff
path: root/app-misc/trash-cli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-09 12:02:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-09 12:02:14 +0000
commit0fd62365fc104d7e6d5f3ef67800df09225a4019 (patch)
tree163b4a5055e07325ae1dc4f9bbbc2021ca1b6afa /app-misc/trash-cli
parent442eaf1780a48ddbd7a39f5a3f34d959c3c6d27e (diff)
gentoo auto-resync : 09:03:2023 - 12:02:14
Diffstat (limited to 'app-misc/trash-cli')
-rw-r--r--app-misc/trash-cli/Manifest2
-rw-r--r--app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index 60f19a43f63e..b855c44613fc 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1,5 +1,7 @@
DIST trash-cli-0.22.8.21.tar.gz 79315 BLAKE2B a4b0f3072d9a9091b90bec13e3a8208c58638f7dd054a788ba0126f8c803748c837dbf183513ca87a775d4efbed9e926603b2b3839f9f499963b774f59f06cd5 SHA512 9c8a40cd92c070dfcadfe2a4871c16a3cfc066568f0e079e11ff80aff53777335f1fec42245846bba04866a55ba9d11a2493950ccdcefcd7d98825508eb6ab6b
DIST trash-cli-0.22.8.27.tar.gz 80344 BLAKE2B 309a1c429b6e052d622f5cd0f4eb211e1dcf8f5fcbe0834d359cd568527843e6a3c4cd1d61f1d1102b6e7f5b7a55fdde396b2500ca94f9410111705cdbff339b SHA512 909a521f40e2252012ed9ebafe8baff50cd2f743c9ab49df0abb41ecc177e551bde07289505f37e8dc86a0d20cdc8b521c35dd2383d17d4f9e962aa431368fe8
+DIST trash-cli-0.23.2.13.2.gh.tar.gz 104006 BLAKE2B c4187faff6618c54be3fcda2fca799d16ff614e5db2a47912aa796d72385bac8dab188977f635372372eae3f6e7d0faaea9405ac93edcd06962f6ffc2bd4694d SHA512 3894d852c01f5e3096bc5bf95220c35cfaa28e2fa555716983ad8203ce7d2206127394cdfbf3f08f0922abdbbfdb4f1a6c1db3fb0bcbda9d936612a2c7d6a7e8
EBUILD trash-cli-0.22.8.21.ebuild 631 BLAKE2B 8a9a549f9e1ff702c0b1e37cc3a9cefc212de732a0a9a32c5ac72593556d7f4dfe73a7acc9cb6103da36e1e73aa7be9f1dc5ca94db2b0c9bf14d2a833861f551 SHA512 4b83f84e8560635f148a89f07e3ce28d22b3067cccc93581b73b4a3067b458408f959c62b206ac311153deb33c2c1a9bf68b3bba9aaf9fd9ec515adf99454077
EBUILD trash-cli-0.22.8.27.ebuild 631 BLAKE2B 8a9a549f9e1ff702c0b1e37cc3a9cefc212de732a0a9a32c5ac72593556d7f4dfe73a7acc9cb6103da36e1e73aa7be9f1dc5ca94db2b0c9bf14d2a833861f551 SHA512 4b83f84e8560635f148a89f07e3ce28d22b3067cccc93581b73b4a3067b458408f959c62b206ac311153deb33c2c1a9bf68b3bba9aaf9fd9ec515adf99454077
+EBUILD trash-cli-0.23.2.13.2.ebuild 792 BLAKE2B db9e606cea3aae9c06e5ced929db12f89ed1fdaf972cbd5e45ffb744fa9ab0b026a335ba83bc43368a9cf1ea033d63b8a4727b6cebe2dbd3ebd00813d8ca42e6 SHA512 866073a6aec02f092bc5e68044e64088e6d299435a3921750973864038783cd8112b871fc998395d4305ac80981e8f2708eb90de73fcf04a6b172ac370c4a528
MISC metadata.xml 1095 BLAKE2B 47ecff4dfa92c0750b4743988d715e828ce8a8d07140df5eec50ad41f0f1aae22efcdf7c7f743c5f6a58c572da9faa8fae4017fde65909e1f8e2ea3b4750b40e SHA512 b935e7c812982d7aabc6cbbcf39ae62404f04f2c8e6055adfdb710bf9502da907b61806425d270b87c14206e7e4caf3e3baea6ab8f86f0b16b9cf3171954b652
diff --git a/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild b/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
new file mode 100644
index 000000000000..3a02be5291bf
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="
+ https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}