summaryrefslogtreecommitdiff
path: root/app-misc/wcd/wcd-6.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-misc/wcd/wcd-6.0.2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-misc/wcd/wcd-6.0.2.ebuild')
-rw-r--r--app-misc/wcd/wcd-6.0.2.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/app-misc/wcd/wcd-6.0.2.ebuild b/app-misc/wcd/wcd-6.0.2.ebuild
index a5b1dabb2ee3..13c99ef9436a 100644
--- a/app-misc/wcd/wcd-6.0.2.ebuild
+++ b/app-misc/wcd/wcd-6.0.2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Wherever Change Directory"
HOMEPAGE="http://waterlan.home.xs4all.nl/#WCD_ANCHOR"
@@ -11,14 +11,16 @@ SRC_URI="http://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 arm x86 ~amd64-linux ~x86-linux"
IUSE="nls unicode"
CDEPEND="
sys-libs/ncurses:0=[unicode?]
- unicode? ( dev-libs/libunistring )"
+ unicode? ( dev-libs/libunistring:= )"
DEPEND="${CDEPEND}
- app-text/ghostscript-gpl"
+ app-text/ghostscript-gpl
+ virtual/pkgconfig
+"
RDEPEND="${CDEPEND}"
S="${WORKDIR}/${P}/src"
@@ -26,7 +28,7 @@ S="${WORKDIR}/${P}/src"
src_prepare() {
eapply -p2 "${FILESDIR}"/${PN}-6.0.2-gentoo.patch
eapply_user
- tc-export CC
+ tc-export CC PKG_CONFIG
}
src_compile() {