summaryrefslogtreecommitdiff
path: root/app-misc/workrave
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /app-misc/workrave
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'app-misc/workrave')
-rw-r--r--app-misc/workrave/Manifest2
-rw-r--r--app-misc/workrave/workrave-1.10.20.ebuild106
2 files changed, 108 insertions, 0 deletions
diff --git a/app-misc/workrave/Manifest b/app-misc/workrave/Manifest
index e8a991ff9cd6..c26ff60ae904 100644
--- a/app-misc/workrave/Manifest
+++ b/app-misc/workrave/Manifest
@@ -1,4 +1,6 @@
AUX workrave-1.10.6-automagic-gstreamer.patch 881 BLAKE2B 9d74d1d51d1f351659b6ce237eb174b193e0dd8f4c1387cc8e5e2e787bc329c86249cd8d06e85c7a101c7edb8c51ae3e94c2dcc3ad565fb0c5699350981138f0 SHA512 87b9ee4847a8d3ed7afd479b0eb67864f328991c76c3525837e8fb31df299dfc5be43ab35c884a75a40f756d1a3b929c6a415448f88cbe726a2088e8cafeb290
DIST workrave-1.10.16.tar.gz 6375438 BLAKE2B 35d78a133b275e1c0adc8c21ceb91412f38667b9dde2ed9e08a8b01cde7b4d35780d317057d000bfa39ae0d5da4639f2e2252b1812acd66a3b81f7c1d1995dfb SHA512 f768c46a5b7dfbaca2984fabff92e64d5fd14f3b4e4d018f5a1cf46a87fbf7ec7fbaec9b660e899f7064a93338224d159b75052ed8e532ecaf507d2f249732f2
+DIST workrave-1.10.20.tar.gz 6377941 BLAKE2B 00f573c05ddacd61d50d80a4079d161b18e7e52606cf502f359cf51c4b64407c978fa944e79314146baea62fe77212fa623d54706c62e23fd1ca17cbf25db409 SHA512 fc8d98aa560946f00ee30be0c28648245a425cd3fddeba8fbdd61fb89d107cc8085d5c4d8a326c739b394e6baada2b28cf98ce9ccaf85dca6bfaa1ae78d4ce56
EBUILD workrave-1.10.16.ebuild 2788 BLAKE2B ec945fe3e90ef1e8d99ff5dd52533ee33b4f2d01c33444ece2fbafc1a1b6cb225bd22c5c8f1f17aa0eabd7a654e7372a6aef42691ee531d4d88279c42d628e93 SHA512 783fd8d7cb0291d0339931c1c9c8227fe681bca4702b77f1f95d34fb4810eedc0c28f76ae1c00267227a9d4fd6b642ecae009b9284257f1b81e01487630f4358
+EBUILD workrave-1.10.20.ebuild 2791 BLAKE2B 2611855f90ca9c0bca255165df386f0f3f4250f71cf1ab325f33ba0d10c0a31706a6e5df511215c4d43ed688349513af1a81b1456fb256542b41d6751fa7a1b2 SHA512 2f84f8f077e8b91a1024f518269c270000d1a2300e3f941008d7b087137262bc53ccfb86fc1ba3b7816d26294c19c45809aecbf462910c3e4e5998370c1158aa
MISC metadata.xml 766 BLAKE2B 7fdc6a41af2c9048875b633ed213337c255b0449474d9c3052615655a904406ee35e226b652ca5519d3c12be63550da344eeabad3656604a8c5cb8df0b25fc18 SHA512 980b66185f9d02d4c0cfd2fe24700a4bb325741097ecf63e7bcd7e47c183e4693c22a6486c70dfce2b7d80837de7ab7c9c908f3be12ba5d16bba1de5d61f6858
diff --git a/app-misc/workrave/workrave-1.10.20.ebuild b/app-misc/workrave/workrave-1.10.20.ebuild
new file mode 100644
index 000000000000..0d3fce130b04
--- /dev/null
+++ b/app-misc/workrave/workrave-1.10.20.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools gnome2 python-single-r1 versionator vcs-snapshot
+
+DESCRIPTION="Helpful utility to attack Repetitive Strain Injury (RSI)"
+HOMEPAGE="http://www.workrave.org/"
+MY_PV=$(replace_all_version_separators '_')
+SRC_URI="https://github.com/rcaelers/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# dbus support looks to be used only for trying to use panel applets on gnome3!
+IUSE="ayatana doc gnome gstreamer introspection mate nls pulseaudio test xfce"
+REQUIRED_USE="ayatana? ( introspection ) ${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0:3[introspection?,X]
+ >=dev-cpp/gtkmm-3.18.0:3.0
+ >=dev-cpp/glibmm-2.28.0:2
+ >=dev-libs/libsigc++-2.2.4.2:2
+ ayatana? (
+ >=dev-libs/libdbusmenu-0.4[gtk3,introspection]
+ >=dev-libs/libindicator-0.4:3 )
+ gnome? ( >=gnome-base/gnome-shell-3.6.2 )
+ gstreamer? (
+ media-libs/gstreamer:1.0[introspection?]
+ media-libs/gst-plugins-base:1.0[introspection?]
+ media-plugins/gst-plugins-meta:1.0 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ mate? ( mate-base/mate-applets )
+ pulseaudio? ( >=media-sound/pulseaudio-0.9.15 )
+ xfce? (
+ >=x11-libs/gtk+-2.6.0:2[introspection?]
+ >=xfce-base/xfce4-panel-4.4 )
+ x11-libs/libXScrnSaver
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-libs/libXt
+ x11-libs/libXmu
+ ${PYTHON_DEPS}
+"
+# dbus? (
+# >=sys-apps/dbus-1.2
+# dev-libs/dbus-glib )
+
+DEPEND="${RDEPEND}
+ dev-python/cheetah
+ >=dev-util/intltool-0.40.0
+ sys-devel/autoconf-archive
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/recordproto
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-sgml-utils
+ app-text/xmlto )
+ nls? ( >=sys-devel/gettext-0.17 )
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ vcs-snapshot_src_unpack
+}
+
+src_prepare() {
+ # Fix gstreamer slot automagic dependency, bug #563584
+ # http://issues.workrave.org/show_bug.cgi?id=1179
+ eapply "${FILESDIR}"/${PN}-1.10.6-automagic-gstreamer.patch
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ # gnet ("distribution") is dead for ages and other distributions stopped
+ # relying on it for such time too.
+ gnome2_src_configure \
+ --disable-dbus \
+ --disable-distribution \
+ --enable-exercises \
+ --disable-experimental \
+ --disable-gnome2 \
+ --disable-static \
+ --disable-xml \
+ $(use_enable ayatana indicator) \
+ $(use_enable doc manual) \
+ $(use_enable gnome gnome3) \
+ $(use_enable gstreamer) \
+ $(use_enable introspection) \
+ $(use_enable mate) \
+ $(use_enable nls) \
+ $(use_enable pulseaudio pulse) \
+ $(use_enable test tests) \
+ $(use_enable xfce)
+}