summaryrefslogtreecommitdiff
path: root/app-misc/wyrd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/wyrd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/wyrd')
-rw-r--r--app-misc/wyrd/Manifest3
-rw-r--r--app-misc/wyrd/metadata.xml15
-rw-r--r--app-misc/wyrd/wyrd-1.4.6-r1.ebuild34
3 files changed, 52 insertions, 0 deletions
diff --git a/app-misc/wyrd/Manifest b/app-misc/wyrd/Manifest
new file mode 100644
index 000000000000..59dd61b4385a
--- /dev/null
+++ b/app-misc/wyrd/Manifest
@@ -0,0 +1,3 @@
+DIST wyrd-1.4.6.tar.gz 425829 BLAKE2B f732b0d69ebb200913f51ab5ea1d42f551469ebd4bc4fd22862499a01db6a6a5bfc21caac7b14e7bf247b75b73a64c3d7ed7c9249d0bc4123a6fc1a27d5017db SHA512 fc09c4567ea8d6225638ee6851ddab716665913b7d7b2f6b5a3cc7f2af9144df617e2a95ca78c74874bec3ff355aba028c7c51eafe1426d9ae803ab77ce84477
+EBUILD wyrd-1.4.6-r1.ebuild 653 BLAKE2B 292c6f86f35e078526610e5303aeef5defd6073b9c404aa0936cb9a16b0686468d1a5eef3fe9d0e4d64e3cfd87980bab49d02b8f0ff91144db4628162adee336 SHA512 791ebbaec3b630cad1a5392319948a39df0a5ad6289e7caea04d8884854d9e02890f9a226c116cc8616a3bc16d0c4ada6a14fcfdb799a11d2ca91cb2fa90c165
+MISC metadata.xml 685 BLAKE2B 53ba89c84de3ae5d0a70c8c2f6aef9000aea4d201f4998557a2fec17d525400f143c279782fd63189f794737163c1172ac4392fde5c5c0f1cdfd29a0b24ddc87 SHA512 96684d600777e987e9cc7b5ff08713d1292e2413778cfb2775127043e4685acd2df50294b72186eedacbeb448601a3064e98a4851198df6875491cc20d01681a
diff --git a/app-misc/wyrd/metadata.xml b/app-misc/wyrd/metadata.xml
new file mode 100644
index 000000000000..4920b59165e4
--- /dev/null
+++ b/app-misc/wyrd/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Wyrd is a text-based front-end to Remind, a sophisticated calendar and alarm
+ program. Remind's power lies in its programmability, and Wyrd does not hide this
+ capability behind flashy GUI dialogs. Rather, Wyrd is designed to make you more
+ efficient at editing your reminder files directly. It also offers a scrollable
+ timetable suitable for visualizing your schedule at a glance.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/wyrd/wyrd-1.4.6-r1.ebuild b/app-misc/wyrd/wyrd-1.4.6-r1.ebuild
new file mode 100644
index 000000000000..531160d57311
--- /dev/null
+++ b/app-misc/wyrd/wyrd-1.4.6-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="Text-based front-end to Remind"
+HOMEPAGE="http://pessimization.com/software/wyrd/"
+SRC_URI="http://pessimization.com/software/wyrd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="unicode"
+
+RDEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ >=app-misc/remind-03.01
+ dev-ml/camlp4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/ocaml-3.08
+"
+
+src_configure() {
+ econf \
+ $(use_enable unicode utf8)
+}
+
+src_install() {
+ export STRIP_MASK="/usr/bin/wyrd"
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog
+ dohtml doc/manual.html
+}