summaryrefslogtreecommitdiff
path: root/app-misc/yagtd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-misc/yagtd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-misc/yagtd')
-rw-r--r--app-misc/yagtd/Manifest3
-rw-r--r--app-misc/yagtd/metadata.xml13
-rw-r--r--app-misc/yagtd/yagtd-0.3.4-r1.ebuild34
3 files changed, 50 insertions, 0 deletions
diff --git a/app-misc/yagtd/Manifest b/app-misc/yagtd/Manifest
new file mode 100644
index 000000000000..bfc5c1734f54
--- /dev/null
+++ b/app-misc/yagtd/Manifest
@@ -0,0 +1,3 @@
+DIST yagtd-0.3.4.tar.gz 1402287 BLAKE2B 52712e11fb30c6951ea1c6dd7ca826a8e38d68c95c6716cbc93524959d98c97f75413166312cfb6c684d27d6423493c215e9bec22f3a7112e064b1a413c9c16b SHA512 99f8dd5344615285a09e039f9c829fdcb09305baa1beaef03710fb5661ba5dde53491264142e9ed2c207e89e06855cbd64621e447468aa033e9f972b896385a8
+EBUILD yagtd-0.3.4-r1.ebuild 716 BLAKE2B 0d9b7b166e718a9d69b830305704258749795cb244d238d3110b1656a120cbd19b71a65e08b70e542931974244588868e858aae4f34d86eda39f4a92eef0694b SHA512 e08af3a6e46cac85fade6e7cd5d76edb51b291ee4ba89de30aeafd0a046db269f5f759f0d05d245fee0977f7c4031bd30dec59c10d001ddbe8179e5297946cf2
+MISC metadata.xml 598 BLAKE2B 291f0e2b7556cee527dc1fa85b29315efd060eb1e831f5f3c90ee7055158c1197254296d08b64c8ea10cd8c29437111534e3bebb36c78c9b3547700bd85dc74e SHA512 6b8a68577ea7e42575d795b3aecb3726b325e0cc6bc8828eb497c92175a537d551baf3f1872eb205d08d2312b3cc6fba43ba6df62519f157ffd3a29b33cc2864
diff --git a/app-misc/yagtd/metadata.xml b/app-misc/yagtd/metadata.xml
new file mode 100644
index 000000000000..a28d1359ca9c
--- /dev/null
+++ b/app-misc/yagtd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+<longdescription lang="en">
+yaGTD incorporates major features from Allen's 'Getting Things Done' philosophy and
+notion of urgency and importance preached by Stephen Covey
+(cf Seven Habits of Highly Effective People book).
+To resume, if you are comfortable at the command line a simple plain text is an
+age-old but perfect method for tracking your stuff, and yaGTD can help you to
+manage efficiently this file.
+</longdescription>
+</pkgmetadata>
diff --git a/app-misc/yagtd/yagtd-0.3.4-r1.ebuild b/app-misc/yagtd/yagtd-0.3.4-r1.ebuild
new file mode 100644
index 000000000000..d1f94ec737ae
--- /dev/null
+++ b/app-misc/yagtd/yagtd-0.3.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="CLI todo list manager based on the 'Getting Things Done' philosophy"
+HOMEPAGE="https://gna.org/projects/yagtd/"
+SRC_URI="http://download.gna.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+src_prepare() {
+ #fix doc install location
+ sed -i -e "s:\/doc\/yagtd:\/doc\/${P}:g" setup.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_install() {
+ distutils-r1_python_install
+ ln -s yagtd.py "${D}$(python_get_scriptdir)"/yagtd || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ dosym yagtd.py /usr/bin/yagtd
+}