summaryrefslogtreecommitdiff
path: root/app-mobilephone/kannel-sqlbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-mobilephone/kannel-sqlbox
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-mobilephone/kannel-sqlbox')
-rw-r--r--app-mobilephone/kannel-sqlbox/Manifest4
-rw-r--r--app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd33
-rw-r--r--app-mobilephone/kannel-sqlbox/kannel-sqlbox-1.5.0-r1.ebuild75
-rw-r--r--app-mobilephone/kannel-sqlbox/metadata.xml14
4 files changed, 126 insertions, 0 deletions
diff --git a/app-mobilephone/kannel-sqlbox/Manifest b/app-mobilephone/kannel-sqlbox/Manifest
new file mode 100644
index 000000000000..1f35b945217a
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/Manifest
@@ -0,0 +1,4 @@
+AUX kannel-sqlbox.initd 818 BLAKE2B 0935d27448cab3f3ac6216d04a3b5e5e83cbca961417ee8fa2c3cc2cd133143726a8a85dcb192408345dd7fd323d9c7f85d01ac817ff2b943ec5c2dbc8ebae9e SHA512 80a195dca95e07ae739dd348d0f2bc0d93f283e2897b4a56f249399c9213b8e88c50c43b293ecba8463806ad2682611e3b1addfc1f77b448429d2602572e823e
+DIST gateway-1.5.0.tar.gz 3469476 BLAKE2B c77c43ec782884f8404e70dbe8fb76cb66526ba7f313db7b7ee83073aae71fb2a1661b58be297f0dc2e6bffbccc862d5e7f1239bd4431bbfa4f009848d57face SHA512 5bd35ff40e0f5882367f717e67104a0dc8703b5d6d95654e1268ded15cf6fac6366968b10adbe2eec22b3ac17fe3ae33b4142cd38f51fd3d75a56c8fe7653652
+EBUILD kannel-sqlbox-1.5.0-r1.ebuild 1937 BLAKE2B 237e15e08e547a679c5e76e13262df7c1227240450ca0b241373177fd7dad1d4095612a100da9d05696acf74cce7aaac18dcb8e119322fdfa508b273d9d29fe4 SHA512 084f7b79bc7c55723bde01ca4916a821959d7799e6515932290ce822eb69d0be0333a3a6c63c8d8e3283d6f77124dad08421fee7bd552915709a39da2b6ad444
+MISC metadata.xml 547 BLAKE2B d4a5fd4ff72acf919033017f0b68c750594f8359c9d52ba9fd0a675dc56217bd54e24c4cfd43eb35fe3236cb60c2132aceaf5ea6a42fd95430517ea1f71b9022 SHA512 4fed0437024490404e13873af9b0cfb103cd89cfb878be1c1900a23d506d0c345cb0da2b284b85a940f00c3ab6785ca43e79a92a95cf6bff040f8369d5a610cf
diff --git a/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd
new file mode 100644
index 000000000000..fd270e65e544
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/files/kannel-sqlbox.initd
@@ -0,0 +1,33 @@
+#!/sbin/openrc-run
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+KANNEL_SERVICE=${SVCNAME#*-}
+
+depend() {
+ need kannel-bearerbox
+ before kannel-smsbox
+}
+
+checkconfig() {
+ if [ ! -f /etc/kannel/kannel.conf ] ; then
+ eerror "/etc/kannel/kannel.conf file doesn't exists!"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting kannel ${KANNEL_SERVICE}"
+ start-stop-daemon --start --quiet --exec /usr/sbin/${KANNEL_SERVICE} -- \
+ --daemonize --user kannel --logfile /var/log/kannel/${KANNEL_SERVICE}.log \
+ --pid-file /var/run/kannel/${KANNEL_SERVICE}.pid /etc/kannel/sqlbox.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping kannel ${KANNEL_SERVICE}"
+ start-stop-daemon --stop --verbose --pidfile /var/run/kannel/${KANNEL_SERVICE}.pid
+ eend $?
+}
diff --git a/app-mobilephone/kannel-sqlbox/kannel-sqlbox-1.5.0-r1.ebuild b/app-mobilephone/kannel-sqlbox/kannel-sqlbox-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..06043457fe0c
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/kannel-sqlbox-1.5.0-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils flag-o-matic readme.gentoo-r1
+
+DESCRIPTION="DB-Based Kannel Box for message queueing"
+HOMEPAGE="http://www.kannel.org/"
+SRC_URI="http://www.kannel.org/download/${PV}/gateway-${PV}.tar.gz"
+
+LICENSE="Apache-1.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ssl doc"
+
+RDEPEND="|| (
+ ~app-mobilephone/kannel-${PV}[mysql]
+ ~app-mobilephone/kannel-${PV}[sqlite]
+ ~app-mobilephone/kannel-${PV}[postgres]
+ )
+ net-libs/libnsl:0=
+ ssl? ( dev-libs/openssl:0 )"
+DEPEND="${RDEPEND}
+ doc? ( media-gfx/transfig
+ app-text/jadetex
+ app-text/docbook-dsssl-stylesheets
+ app-text/docbook-sgml-dtd:3.1 )"
+
+S="${WORKDIR}/gateway-${PV}/addons/sqlbox/"
+
+pkg_setup() {
+ append-ldflags $(no-as-needed)
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="Please view the following page for config information:
+http://www.kannel.org/pipermail/users/2006-October/000859.html
+
+In essence you need to do 3 things:
+1. Create the database (tables will be automatically created by kannel)
+2. Point sqlbox to the smsbox-port in kannel [core] group
+3. Point smsbox to smsbox-port in sqlbox [sqlbox] group
+
+This literally puts sqlbox in between the bearerbox and smsbox
+for data storage into a database"
+}
+
+src_configure() {
+ econf --docdir=/usr/share/doc/${PF} \
+ --without-ctlib \
+ --without-mssql \
+ $(use_enable ssl) \
+ $(use_enable doc docs) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed emake install"
+
+ if use doc; then
+ emake doc/userguide.html || die "emake docs failed"
+ dohtml doc/userguide.html || die "userguide.html not found"
+ fi
+
+ newinitd "${FILESDIR}"/kannel-sqlbox.initd kannel-sqlbox
+
+ dodoc AUTHORS ChangeLog NEWS README
+ insinto /etc/kannel
+ newins example/sqlbox.conf.example sqlbox.conf.sample
+
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}
diff --git a/app-mobilephone/kannel-sqlbox/metadata.xml b/app-mobilephone/kannel-sqlbox/metadata.xml
new file mode 100644
index 000000000000..fff2720d8361
--- /dev/null
+++ b/app-mobilephone/kannel-sqlbox/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>travisghansen@yahoo.com</email>
+ <name>Travis Hansen</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <longdescription>Sqlbox is a special Kannel box that sits between bearerbox and
+smsbox and uses a database queue to store and forward messages.</longdescription>
+</pkgmetadata>