summaryrefslogtreecommitdiff
path: root/app-mobilephone/vmoconv/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-mobilephone/vmoconv/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-mobilephone/vmoconv/files')
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-external-libgsm.patch36
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch17
-rw-r--r--app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch24
3 files changed, 77 insertions, 0 deletions
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-external-libgsm.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-external-libgsm.patch
new file mode 100644
index 000000000000..8ab3670aa098
--- /dev/null
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-external-libgsm.patch
@@ -0,0 +1,36 @@
+diff -Nru vmoconv-1.0.orig/src/Makefile.am vmoconv-1.0/src/Makefile.am
+--- vmoconv-1.0.orig/src/Makefile.am 2003-02-17 21:39:18.000000000 +0000
++++ vmoconv-1.0/src/Makefile.am 2009-03-03 21:24:12.000000000 +0000
+@@ -1,32 +1,6 @@
+
+-noinst_LTLIBRARIES = libgsm.la
+-
+ INCLUDES = -I.
+
+-libgsm_la_SOURCES = add.c \
+- code.c \
+- debug.c \
+- decode.c \
+- long_term.c \
+- lpc.c \
+- preprocess.c \
+- rpe.c \
+- gsm_destroy.c \
+- gsm_decode.c \
+- gsm_encode.c \
+- gsm_explode.c \
+- gsm_implode.c \
+- gsm_create.c \
+- gsm_print.c \
+- gsm_option.c \
+- short_term.c \
+- table.c \
+- proto.h \
+- unproto.h \
+- config.h \
+- private.h \
+- gsm.h
+-
+ vmo2wav_LDADD = -lgsm
+
+ vmo2wav_SOURCES = vmo2wav.c
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch
new file mode 100644
index 000000000000..031b6eefaaca
--- /dev/null
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-flags.patch
@@ -0,0 +1,17 @@
+diff -Nru vmoconv-1.0.orig/configure.in vmoconv-1.0/configure.in
+--- vmoconv-1.0.orig/configure.in 2004-09-26 15:17:48.000000000 +0000
++++ vmoconv-1.0/configure.in 2009-03-03 21:32:40.000000000 +0000
+@@ -26,10 +26,10 @@
+ [printf(__func__)],,
+ [AC_DEFINE(__func__, "", [non-C99 fake support for __func__])])
+
+-dnl Turn on debugging and all warnings when using gcc
++dnl Turn on all warnings when using gcc
+ if test "$ac_cv_prog_gcc" = "yes"; then
+- CFLAGS="$CFLAGS -g -Wall -Wmissing-declarations -Wmissing-prototypes"
+- LDFLAGS="$LDFLAGS -g -Wall"
++ CFLAGS="$CFLAGS -Wall -Wmissing-declarations -Wmissing-prototypes"
++ LDFLAGS="$LDFLAGS -Wall"
+ fi
+
+ AC_SUBST(CFLAGS)
diff --git a/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
new file mode 100644
index 000000000000..ec957b40c5cd
--- /dev/null
+++ b/app-mobilephone/vmoconv/files/vmoconv-1.0-glibc28.patch
@@ -0,0 +1,24 @@
+diff -Naur vmoconv-1.0.orig/src/gsm2vmo.c vmoconv-1.0/src/gsm2vmo.c
+--- vmoconv-1.0.orig/src/gsm2vmo.c 2008-06-15 12:57:07.000000000 -0400
++++ vmoconv-1.0/src/gsm2vmo.c 2008-06-15 12:57:36.000000000 -0400
+@@ -27,7 +27,7 @@
+ * 12 bit header and 260 bits standard GSM frame, as described
+ * in GSM 06.10 and GSM 06.12. The header is 0x2010 always.
+ */
+-
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+diff -Naur vmoconv-1.0.orig/src/vmo2gsm.c vmoconv-1.0/src/vmo2gsm.c
+--- vmoconv-1.0.orig/src/vmo2gsm.c 2008-06-15 12:57:07.000000000 -0400
++++ vmoconv-1.0/src/vmo2gsm.c 2008-06-15 12:57:36.000000000 -0400
+@@ -27,7 +27,7 @@
+ * 12 bit header and 260 bits standard GSM frame, as described
+ * in GSM 06.10 and GSM 06.12. The header is 0x2010 always.
+ */
+-
++#include <limits.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>