summaryrefslogtreecommitdiff
path: root/app-office/dia2code/dia2code-1.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/dia2code/dia2code-1.0.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/dia2code/dia2code-1.0.0.ebuild')
-rw-r--r--app-office/dia2code/dia2code-1.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-office/dia2code/dia2code-1.0.0.ebuild b/app-office/dia2code/dia2code-1.0.0.ebuild
new file mode 100644
index 000000000000..7f505bb1e808
--- /dev/null
+++ b/app-office/dia2code/dia2code-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Convert UML diagrams produced with Dia to various source code flavours"
+HOMEPAGE="http://dia2code.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc ~sparc x86"
+IUSE="test"
+
+RDEPEND="${DEPEND}"
+DEPEND="
+ dev-libs/libxml2
+ test? ( app-shells/bash )
+"
+
+src_prepare() {
+ # Script makes use of arrays
+ sed -e 's:/bin/sh:/bin/bash:' \
+ -i tests/tests.sh || die
+ gnome2_src_prepare
+}
+
+src_install() {
+ gnome2_src_install
+ doman docs/dia2code.1
+}