summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/libreoffice/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/libreoffice/files')
-rw-r--r--app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch10
-rw-r--r--app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch11
-rw-r--r--app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch42
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch216
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch37
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-poppler-0.64.patch71
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch13
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch34
-rw-r--r--app-office/libreoffice/files/libreoffice-6.0.5.2-enable-gio-w-gtk3.patch46
9 files changed, 480 insertions, 0 deletions
diff --git a/app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch b/app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch
new file mode 100644
index 000000000000..d714ff2074bc
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.2.5.1-glibc-2.24.patch
@@ -0,0 +1,10 @@
+--- libreoffice-5.2.5.1.orig/desktop/unx/source/pagein.c 2017-01-11 16:54:33.000000000 -0800
++++ libreoffice-5.2.5.1/desktop/unx/source/pagein.c 2017-02-03 10:22:51.697673613 -0800
+@@ -26,6 +26,7 @@
+ #include <string.h>
+ #include <sys/stat.h>
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+
+ /* do_pagein */
+ static void do_pagein (const char * filename)
diff --git a/app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch b/app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch
new file mode 100644
index 000000000000..a6e732f7f379
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.3.4.2-kioclient5.patch
@@ -0,0 +1,11 @@
+--- a/shell/source/unix/misc/senddoc.sh 2017-06-15 15:44:22.000000000 +0200
++++ b/shell/source/unix/misc/senddoc.sh 2017-06-25 01:00:08.525435930 +0200
+@@ -389,6 +389,8 @@
+ elif [ -n "$DESKTOP_LAUNCH" ]; then
+ # http://lists.freedesktop.org/pipermail/xdg/2004-August/002873.html
+ MAILER=${DESKTOP_LAUNCH}
++ elif [ -n "$KDE_FULL_SESSION" -a -x /usr/bin/kde-open5 ] ; then
++ MAILER=/usr/bin/kde-open5
+ elif [ -n "$KDE_FULL_SESSION" -a -x /usr/bin/kde-open ] ; then
+ MAILER=/usr/bin/kde-open
+ elif [ -x /usr/bin/xdg-open ] ; then
diff --git a/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch b/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
new file mode 100644
index 000000000000..83b56d1a1927
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-5.4-system-pyuno.patch
@@ -0,0 +1,42 @@
+--- a/desktop/scripts/soffice.sh
++++ a/desktop/scripts/soffice.sh
+@@ -147,6 +147,9 @@ if echo "$checks" | grep -q "cc" ; then
+ exit 1;
+ fi
+
++PYTHONPATH=$sd_prog${PYTHONPATH+:$PYTHONPATH}
++export PYTHONPATH
++
+ case "$(uname -s)" in
+ NetBSD|OpenBSD|DragonFly)
+ # this is a temporary hack until we can live with the default search paths
+--- a/pyuno/source/module/uno.py
++++ a/pyuno/source/module/uno.py
+@@ -16,11 +16,16 @@
+ # except in compliance with the License. You may obtain a copy of
+ # the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ #
++import os
+ import pyuno
+ import sys
+ import traceback
+ import warnings
+
++sys.path.append('%eprefix%/usr/%libdir%/libreoffice/program')
++if getattr(os.environ, 'URE_BOOTSTRAP', None) is None:
++ os.environ['URE_BOOTSTRAP'] = "vnd.sun.star.pathname:%eprefix%/usr/%libdir%/libreoffice/program/fundamentalrc"
++
+ # since on Windows sal3.dll no longer calls WSAStartup
+ import socket
+
+--- a/pyuno/source/officehelper.py
++++ a/pyuno/source/officehelper.py
+@@ -45,7 +45,7 @@ def bootstrap():
+ if "UNO_PATH" in os.environ:
+ sOffice = os.environ["UNO_PATH"]
+ else:
+- sOffice = "" # lets hope for the best
++ sOffice = "%eprefix%/usr/%libdir%/libreoffice/program"
+ sOffice = os.path.join(sOffice, "soffice")
+ if platform.startswith("win"):
+ sOffice += ".exe"
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch
new file mode 100644
index 000000000000..03421c5e12be
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-1.patch
@@ -0,0 +1,216 @@
+Kindly borrowed from Debian.
+
+14:13 < mst__> _rene_, the toolkit unoapi tests are known to be flaky (in some
+ system dependent way) e.g. on the Win@6 tinderbox it always
+ crashes
+14:14 < mst__> _rene_, sc.ScAccessible* tests also fail on some systems some of
+ the time
+
+diff --git a/toolkit/Module_toolkit.mk b/toolkit/Module_toolkit.mk
+index 25db0b6..14e507c 100644
+--- a/toolkit/Module_toolkit.mk
++++ b/toolkit/Module_toolkit.mk
+@@ -26,11 +26,11 @@ $(eval $(call gb_Module_add_targets,toolkit,\
+ ifneq ($(OOO_JUNIT_JAR),)
+ $(eval $(call gb_Module_add_subsequentcheck_targets,toolkit,\
+ JunitTest_toolkit_complex \
+- JunitTest_toolkit_unoapi_1 \
+- JunitTest_toolkit_unoapi_2 \
+- JunitTest_toolkit_unoapi_3 \
+- JunitTest_toolkit_unoapi_4 \
+ ))
+ endif
++# JunitTest_toolkit_unoapi_1 \
++# JunitTest_toolkit_unoapi_2 \
++# JunitTest_toolkit_unoapi_3 \
++# JunitTest_toolkit_unoapi_4 \
+
+ # vim: set noet sw=4 ts=4:
+diff --git a/sc/qa/unoapi/sc_1.sce b/sc/qa/unoapi/sc_1.sce
+index fa1684c..cc8e1a5 100644
+--- a/sc/qa/unoapi/sc_1.sce
++++ b/sc/qa/unoapi/sc_1.sce
+@@ -24,10 +24,3 @@
+ # i84554 -o sc.AccessibleEditableTextPara_PreviewNote
+ # i88241 -o sc.AccessibleEditableTextPara_HeaderFooter
+ -o sc.AccessibleEditableTextPara_PreviewCell
+--o sc.ScAccessibleCell
+-# i91044 -o sc.ScAccessibleCsvCell
+-# i91044 -o sc.ScAccessibleCsvGrid
+-# i84641 -o sc.ScAccessibleCsvRuler
+-# i88330 -o sc.ScAccessibleDocument
+-# i91045 -o sc.ScAccessibleDocumentPagePreview
+--o sc.ScAccessiblePageHeader
+diff --git a/sc/qa/unoapi/sc_2.sce b/sc/qa/unoapi/sc_2.sce
+index dbfc3e1..d235c5d 100644
+--- a/sc/qa/unoapi/sc_2.sce
++++ b/sc/qa/unoapi/sc_2.sce
+@@ -15,11 +15,6 @@
+ # except in compliance with the License. You may obtain a copy of
+ # the License at http://www.apache.org/licenses/LICENSE-2.0 .
+ #
+-# fdo#FOO -o sc.ScAccessiblePageHeaderArea
+--o sc.ScAccessiblePreviewCell
+--o sc.ScAccessiblePreviewHeaderCell
+--o sc.ScAccessiblePreviewTable
+-# fdo#45337 -o sc.ScAccessibleSpreadsheet
+ # FIXME_REMOVE_WHEN_RE_BASE_COMPLETE
+ # -o sc.ScAnnotationObj
+ # -o sc.ScAnnotationShapeObj
+
+12:18 < _rene_> chris_wot: ping?
+12:18 < chris_wot> heya
+12:18 < chris_wot> you pinged?
+12:19 < _rene_> chris_wot: any news on
+ https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815292?
+12:20 < _rene_> (of course the this-night-uploaded rc3 also failed)
+12:21 < chris_wot> ah, sorry - I've looked at an EMF regression, but I've not
+ gotten any further on that one
+12:22 < chris_wot> I honestly think that for this one just disable the test for
+ now
+12:22 < chris_wot> I'll ping the ML
+
+This seems fixed when opening the original doc.
+
+diff --git a/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx b/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx
+index 54eed4d..78019bd 100644
+--- a/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx
++++ b/sw/qa/extras/ooxmlexport/ooxmlexport7.cxx
+@@ -1128,30 +1128,30 @@ DECLARE_OOXMLEXPORT_TEST(testTDF93675, "no-numlevel-but-indented.odt")
+
+
+
+-DECLARE_OOXMLEXPORT_TEST(testFlipAndRotateCustomShape, "flip_and_rotate.odt")
+-{
+- xmlDocPtr pXmlDoc = parseExport("word/document.xml");
+- if (!pXmlDoc)
+- return;
+- // there should be no flipH and flipV attributes in this case
+- assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipH");
+- assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipV");
+- // check rotation angle
+- assertXPath(pXmlDoc, "//a:xfrm", "rot", "13500000");
+- // check the first few coordinates of the polygon
+-#ifndef MACOSX /* Retina-related rounding roundtrip error
+- * hard to smooth out due to the use of string compare
+- * instead of number */
+-#if !defined(_WIN32)
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "x", "2351");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "y", "3171");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "x", "1695");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "y", "3171");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "x", "1695");
+- assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "y", "1701");
+-#endif
+-#endif
+-}
++//DECLARE_OOXMLEXPORT_TEST(testFlipAndRotateCustomShape, "flip_and_rotate.odt")
++//{
++// xmlDocPtr pXmlDoc = parseExport("word/document.xml");
++// if (!pXmlDoc)
++// return;
++// // there should be no flipH and flipV attributes in this case
++// assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipH");
++// assertXPathNoAttribute(pXmlDoc, "//a:xfrm", "flipV");
++// // check rotation angle
++// assertXPath(pXmlDoc, "//a:xfrm", "rot", "13500000");
++// // check the first few coordinates of the polygon
++//#ifndef MACOSX /* Retina-related rounding roundtrip error
++// * hard to smooth out due to the use of string compare
++// * instead of number */
++//#if !defined(_WIN32)
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "x", "2351");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[1]/a:pt", "y", "3171");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "x", "1695");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[2]/a:pt", "y", "3171");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "x", "1695");
++// assertXPath(pXmlDoc, "//a:custGeom/a:pathLst/a:path/a:lnTo[3]/a:pt", "y", "1701");
++//#endif
++//#endif
++//}
+
+
+ CPPUNIT_PLUGIN_IMPLEMENT();
+diff --git a/svx/qa/unoapi/svx.sce b/svx/qa/unoapi/svx.sce
+index 1c3925f..a16f001 100644
+--- a/svx/qa/unoapi/svx.sce
++++ b/svx/qa/unoapi/svx.sce
+@@ -25,7 +25,7 @@
+ #i111216 -o svx.AccessiblePresentationGraphicShape
+ #i111216 -o svx.AccessiblePresentationOLEShape
+ #i85539 -o svx.AccessiblePresentationShape
+--o svx.AccessibleShape
++#-o svx.AccessibleShape
+ #i90294 -o svx.GraphicExporter
+ -o svx.SvxDrawPage
+ #i85501 -o svx.SvxGraphCtrlAccessibleContext
+
+19:26 <@x1sc0> _rene_, since that test is using exact dimensions, it seems it
+ fails on your side probably because the paragraph style is
+ different. 1. I will change the test to avoid the exact
+ dimensions. 2. meantime you can skip that test:
+https://cgit.freedesktop.org/libreoffice/core/commit/?id=e05f16e6bf36efbaab16dd2ed1427a750ce7cafd
+19:26 < IZBot> core - disable UI test that does exact comparison
+19:27 < _rene_> mmh, ok, saw that but that was for a different test, so.. :)
+19:27 -!- jacobo [~jaragunde@fanzine.igalia.com] has quit [Quit: Leaving.]
+19:27 < _rene_> thanks, will do
+
+diff --git a/uitest/writer_tests/tdf79236.py b/uitest/writer_tests/tdf79236.py
+index 8585e48d8c64..704f42c009a1 100644
+--- a/uitest/writer_tests/tdf79236.py
++++ b/uitest/writer_tests/tdf79236.py
+@@ -8,8 +8,11 @@ from uitest.framework import UITestCase
+ import time
+ from uitest.uihelper.common import get_state_as_dict, type_text
+
++import unittest
++
+ class tdf79236(UITestCase):
+
++ @unittest.skip("Currently broken")
+ def test_paragraph(self):
+
+ self.ui_test.create_doc_in_start_center("writer")
+
+14:39 < ztamas> _rene_: chart2dump is used to fail because of font size differences, just use a bigger delta or disable it if it
+ fails for you.
+14:40 <@sberg_> noelgrandin, no
+14:40 < noelgrandin> sberg_, sure seems that way both in the debugger and in the resulting SAL_WARN output
+14:42 < ztamas> _rene_: there were some work on making font rendering consistent on different platforms, but it's not finished
+ yet, I guess
+diff --git a/chart2/Module_chart2.mk b/chart2/Module_chart2.mk
+index 3273055d5373..cb452139170c 100644
+--- a/chart2/Module_chart2.mk
++++ b/chart2/Module_chart2.mk
+@@ -33,9 +33,9 @@ $(eval $(call gb_Module_add_slowcheck_targets,chart2,\
+ CppunitTest_chart2_export \
+ CppunitTest_chart2_import \
+ CppunitTest_chart2_trendcalculators \
+- CppunitTest_chart2_dump \
+ CppunitTest_chart2_pivot_chart_test \
+ ))
++# CppunitTest_chart2_dump \
+
+ ifeq ($(ENABLE_CHART_TESTS),TRUE)
+ ifeq ($(WITH_FONTS), TRUE)
+diff --git a/sw/qa/extras/ooxmlimport/ooxmlimport.cxx b/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
+index 4d65beeb90c4..f3d71501c41a 100644
+--- a/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
++++ b/sw/qa/extras/ooxmlimport/ooxmlimport.cxx
+@@ -1559,14 +1559,14 @@ DECLARE_OOXMLIMPORT_TEST(testTdf43017, "tdf43017.docx")
+ }
+
+
+-DECLARE_OOXMLIMPORT_TEST(testTdf112443, "tdf112443.docx")
++/*DECLARE_OOXMLIMPORT_TEST(testTdf112443, "tdf112443.docx")
+ {
+ // the position of the flying text frame should be off page
+ // 30624 below its anchor
+ OUString aTop = parseDump("//fly[1]/infos/bounds", "top");
+ CPPUNIT_ASSERT_EQUAL( OUString("30624"), aTop );
+
+-}
++}*/
+
+ DECLARE_OOXMLIMPORT_TEST(testTdf113946, "tdf113946.docx")
+ {
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch
new file mode 100644
index 000000000000..55f2d8a55fc7
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-disable-flaky-tests-2.patch
@@ -0,0 +1,37 @@
+--- a/xmlsecurity/qa/unit/signing/signing.cxx 2018-01-27 18:21:08.228434985 +0100
++++ b/xmlsecurity/qa/unit/signing/signing.cxx 2018-01-27 18:21:37.428824309 +0100
+@@ -114,7 +114,7 @@
+ /// Test a typical broken ODF signature where the XML dsig hash is corrupted.
+ void testODFBrokenDsigGPG();
+ /// Test loading an encrypted ODF document
+- void testODFEncryptedGPG();
++// void testODFEncryptedGPG();
+ #endif
+ CPPUNIT_TEST_SUITE(SigningTest);
+ CPPUNIT_TEST(testDescription);
+@@ -143,7 +143,7 @@
+ CPPUNIT_TEST(testODFUntrustedGoodGPG);
+ CPPUNIT_TEST(testODFBrokenStreamGPG);
+ CPPUNIT_TEST(testODFBrokenDsigGPG);
+- CPPUNIT_TEST(testODFEncryptedGPG);
++// CPPUNIT_TEST(testODFEncryptedGPG);
+ #endif
+ CPPUNIT_TEST_SUITE_END();
+
+@@ -743,14 +743,14 @@
+ CPPUNIT_ASSERT_EQUAL(static_cast<int>(SignatureState::BROKEN), static_cast<int>(pObjectShell->GetDocumentSignatureState()));
+ }
+
+-void SigningTest::testODFEncryptedGPG()
++/*void SigningTest::testODFEncryptedGPG()
+ {
+ createDoc(m_directories.getURLFromSrc(DATA_DIRECTORY) + "encryptedGPG.odt");
+ SfxBaseModel* pBaseModel = dynamic_cast<SfxBaseModel*>(mxComponent.get());
+ CPPUNIT_ASSERT(pBaseModel);
+ SfxObjectShell* pObjectShell = pBaseModel->GetObjectShell();
+ CPPUNIT_ASSERT(pObjectShell);
+-}
++}*/
+
+ #endif
+
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-poppler-0.64.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-poppler-0.64.patch
new file mode 100644
index 000000000000..37a554d807da
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-poppler-0.64.patch
@@ -0,0 +1,71 @@
+From 106b2c96e9807af14d6eb6e8f83dcf25095a093e Mon Sep 17 00:00:00 2001
+From: Rene Engelhard <rene@debian.org>
+Date: Tue, 24 Apr 2018 15:56:23 +0200
+Subject: fix build with poppler 0.64
+
+GooString became const...
+
+Change-Id: Icc95be2e8603a4e22c6a9ac2008986bacd0bfba5
+Reviewed-on: https://gerrit.libreoffice.org/53422
+Tested-by: Jenkins <ci@libreoffice.org>
+Reviewed-by: Michael Stahl <Michael.Stahl@cib.de>
+---
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx | 10 ++++++++++
+ sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx | 4 ++++
+ 2 files changed, 14 insertions(+)
+
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+index 00fd56a..9618e5b 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.cxx
+@@ -446,6 +446,9 @@ int PDFOutDev::parseFont( long long nNewId, GfxFont* gfxFont, GfxState* state )
+ FontAttributes aNewFont;
+ int nSize = 0;
+
++#if POPPLER_CHECK_VERSION(0, 64, 0)
++ const
++#endif
+ GooString* pFamily = gfxFont->getName();
+ if( pFamily )
+ {
+@@ -742,6 +745,9 @@ void PDFOutDev::updateFont(GfxState *state)
+ FontAttributes aFont;
+ int nEmbedSize=0;
+
++#if POPPLER_CHECK_VERSION(0, 64, 0)
++ const
++#endif
+ Ref* pID = gfxFont->getID();
+ // TODO(Q3): Portability problem
+ long long fontID = (long long)pID->gen << 32 | (long long)pID->num;
+@@ -932,7 +938,11 @@ void PDFOutDev::drawChar(GfxState *state, double x, double y,
+ printf( "\n" );
+ }
+
++#if POPPLER_CHECK_VERSION(0, 64, 0)
++void PDFOutDev::drawString(GfxState*, const GooString* /*s*/)
++#else
+ void PDFOutDev::drawString(GfxState*, GooString* /*s*/)
++#endif
+ {
+ // TODO(F3): NYI
+ }
+diff --git a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+index 922c513..2a6268c 100644
+--- a/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
++++ b/sdext/source/pdfimport/xpdfwrapper/pdfioutdev_gpl.hxx
+@@ -223,7 +223,11 @@ namespace pdfi
+ double dx, double dy,
+ double originX, double originY,
+ CharCode code, int nBytes, Unicode *u, int uLen) override;
++#if POPPLER_CHECK_VERSION(0, 64, 0)
++ virtual void drawString(GfxState *state, const GooString *s) override;
++#else
+ virtual void drawString(GfxState *state, GooString *s) override;
++#endif
+ virtual void endTextObject(GfxState *state) override;
+
+ //----- image drawing
+--
+cgit v1.1
+
diff --git a/app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch b/app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch
new file mode 100644
index 000000000000..bd84b3162527
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.3.2-testTdf108947.patch
@@ -0,0 +1,13 @@
+diff --git a/sw/qa/extras/rtfimport/rtfimport.cxx b/sw/qa/extras/rtfimport/rtfimport.cxx
+index 457aedce0acb..4f02cf2b4040 100644
+--- a/sw/qa/extras/rtfimport/rtfimport.cxx
++++ b/sw/qa/extras/rtfimport/rtfimport.cxx
+@@ -1352,7 +1352,7 @@ DECLARE_RTFIMPORT_TEST(testImportHeaderFooter, "tdf108055.rtf")
+ DECLARE_RTFIMPORT_TEST(testTdf108947, "tdf108947.rtf")
+ {
+ //Check page count
+- CPPUNIT_ASSERT_EQUAL(2, getPages());
++ CPPUNIT_ASSERT_EQUAL(1, getPages());
+
+ //Check if Headers/Footers contain what they should in this document
+ uno::Reference<text::XText> xHeaderTextRight = getProperty<uno::Reference<text::XText>>(
diff --git a/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
new file mode 100644
index 000000000000..1430fdf1a346
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.4.2-glm-0.9.9.patch
@@ -0,0 +1,34 @@
+From 5f1bf6598b5725ad1e50ae9f7ec7524cc8a834fa Mon Sep 17 00:00:00 2001
+From: Louis Sautier <sautier.louis@gmail.com>
+Date: Sun, 10 Jun 2018 12:25:18 +0200
+Subject: Fix build with GLM 0.9.9.0, tdf#118070
+
+One of the test files was forgotten in 953c4add8fd76d88f49a81ae4c21a1fdcc007e57
+
+Change-Id: I0315433c688ff7edb2ba599bbef203cac9de3022
+Reviewed-on: https://gerrit.libreoffice.org/55554
+Reviewed-by: Rene Engelhard <rene@debian.org>
+Tested-by: Rene Engelhard <rene@debian.org>
+---
+ vcl/Executable_icontest.mk | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/vcl/Executable_icontest.mk b/vcl/Executable_icontest.mk
+index ce16330..8c917b7 100644
+--- a/vcl/Executable_icontest.mk
++++ b/vcl/Executable_icontest.mk
+@@ -19,6 +19,12 @@ $(eval $(call gb_Executable_use_externals,icontest,\
+ ))
+ endif
+
++ifeq ($(SYSTEM_GLM),TRUE)
++$(eval $(call gb_Executable_add_defs,icontest,\
++ -DGLM_ENABLE_EXPERIMENTAL \
++))
++endif
++
+ $(eval $(call gb_Executable_use_api,icontest,\
+ offapi \
+ udkapi \
+--
+cgit v1.1
diff --git a/app-office/libreoffice/files/libreoffice-6.0.5.2-enable-gio-w-gtk3.patch b/app-office/libreoffice/files/libreoffice-6.0.5.2-enable-gio-w-gtk3.patch
new file mode 100644
index 000000000000..4a018711ca2c
--- /dev/null
+++ b/app-office/libreoffice/files/libreoffice-6.0.5.2-enable-gio-w-gtk3.patch
@@ -0,0 +1,46 @@
+From a560bcbea943cb317e96c15c608c5e2f66e5698f Mon Sep 17 00:00:00 2001
+From: Stephan Bergmann <sbergman@redhat.com>
+Date: Thu, 31 May 2018 14:14:48 +0200
+Subject: --enable-gio also for --disable-gtk --enable-gtk3
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+...as is used by the Flatpak build. Other settings only checked in that block
+controlled by ENABLE_GTK, and thus potentially erronously left empty for
+--disable-gtk --enable-gtk3 builds, are GTHREAD- and GTK_PRINT-related settings.
+GTHREAD_LIBS is explicitly used in vcl/Library_vclplug_gtk3.mk even, but it
+being empty apparently has no negative effects, so leave it at that for now.
+On the GTK_PRINT-related settings, Caolan commented on IRC: "ENABLE_GTK_PRINT
+is probably best removed entirely I guess, it didn't work out and they're
+redoing the dialog in upstream gtk again I'm told."
+
+Change-Id: I7e026c0ac9b23e7ace2c2e92390bdcc3be7d39a3
+Reviewed-on: https://gerrit.libreoffice.org/55127
+Tested-by: Jenkins <ci@libreoffice.org>
+Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
+(cherry picked from commit b5dd045bf533a2ba4d1c98debe5a2acba4c8b486)
+Reviewed-on: https://gerrit.libreoffice.org/55164
+Reviewed-by: Caolán McNamara <caolanm@redhat.com>
+Tested-by: Caolán McNamara <caolanm@redhat.com>
+---
+ configure.ac | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index e35db48..9da61d9 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -9875,7 +9875,9 @@ if test "$test_gtk" = "yes"; then
+ GTK_PRINT_CFLAGS=$(printf '%s' "$GTK_PRINT_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
+ FilterLibs "${GTK_PRINT_LIBS}"
+ GTK_PRINT_LIBS="${filteredlibs}"
++ fi
+
++ if test "$ENABLE_GTK" = "TRUE" || test "$ENABLE_GTK3" = "TRUE"; then
+ AC_MSG_CHECKING([whether to enable GIO support])
+ if test "$_os" != "WINNT" -a "$_os" != "Darwin" -a "$enable_gio" = "yes"; then
+ dnl Need at least 2.26 for the dbus support.
+--
+cgit v1.1
+