summaryrefslogtreecommitdiff
path: root/app-office/libreoffice/libreoffice-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-10 04:21:55 +0100
commit677b7ba5c317778df2ad7e70df94b9b7eec4adbc (patch)
tree6c418a1546fff5becab5d8b9ed6803323e7f316e /app-office/libreoffice/libreoffice-9999.ebuild
parentfbda87924e6faa7a1919f1a2b4182490bde5ec5c (diff)
gentoo resync : 10.09.2021
Diffstat (limited to 'app-office/libreoffice/libreoffice-9999.ebuild')
-rw-r--r--app-office/libreoffice/libreoffice-9999.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/app-office/libreoffice/libreoffice-9999.ebuild b/app-office/libreoffice/libreoffice-9999.ebuild
index 45f856b59db4..48469b754b1d 100644
--- a/app-office/libreoffice/libreoffice-9999.ebuild
+++ b/app-office/libreoffice/libreoffice-9999.ebuild
@@ -44,12 +44,13 @@ unset DEV_URI
# These are bundles that can't be removed for now due to huge patchsets.
# If you want them gone, patches are welcome.
ADDONS_SRC=(
+ # broken against latest upstream release, too many patches on top:
+ # https://github.com/tdf/libcmis/pull/43
+ "${ADDONS_URI}/libcmis-0.5.2.tar.xz"
# not packaged in Gentoo, https://www.netlib.org/fp/dtoa.c
"${ADDONS_URI}/dtoa-20180411.tgz"
# not packaged in Gentoo, https://skia.org/
- "${ADDONS_URI}/skia-m88-59bafeeaa7de9eb753e3778c414e01dcf013dcd8.tar.xz"
- # QR code generating library for >=libreoffice-6.4, bug #691740
- "${ADDONS_URI}/QR-Code-generator-1.4.0.tar.gz"
+ "${ADDONS_URI}/skia-m94-975fcdd755dfc5d57cddbb25857e0c4ac29abe98.tar.xz"
"base? (
${ADDONS_URI}/commons-logging-1.2-src.tar.gz
${ADDONS_URI}/ba2930200c9f019c2d93a8c88c651a0f-flow-engine-0.9.4.zip
@@ -136,7 +137,6 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=dev-cpp/clucene-2.3.3.4-r2
>=dev-cpp/libcmis-0.5.2
dev-db/unixODBC
- >=games-engines/box2d-2.4.1:0
dev-lang/perl
>=dev-libs/boost-1.72.0:=[nls]
dev-libs/expat
@@ -152,6 +152,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
dev-libs/nss
>=dev-libs/redland-1.0.16
>=dev-libs/xmlsec-1.2.28[nss]
+ >=games-engines/box2d-2.4.1:0
media-gfx/fontforge
media-gfx/graphite2
media-libs/fontconfig
@@ -165,6 +166,7 @@ COMMON_DEPEND="${PYTHON_DEPS}
>=media-libs/libpng-1.4:0=
>=media-libs/libvisio-0.1.0
media-libs/libzmf
+ media-libs/zxing-cpp
>=net-libs/neon-0.31.1:=
net-misc/curl
sci-mathematics/lpsolve
@@ -291,7 +293,7 @@ PATCHES=(
# not upstreamable stuff
"${FILESDIR}/${PN}-5.3.4.2-kioclient5.patch"
"${FILESDIR}/${PN}-6.1-nomancompress.patch"
- "${FILESDIR}/${PN}-7.0.3.1-qt5detect.patch"
+ "${FILESDIR}/${PN}-7.2.0.4-qt5detect.patch"
)
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -463,7 +465,6 @@ src_configure() {
# --without-system-sane: just sane.h header that is used for scan in writer,
# not linked or anything else, worthless to depend on
# --disable-pdfium: not yet packaged
- # --without-system-qrcodegen: has no real build system and LO is the only user
local myeconfargs=(
--with-system-dicts
--with-system-epoxy
@@ -506,8 +507,8 @@ src_configure() {
--with-system-gpgmepp
--without-system-jfreereport
--without-system_apache_commons
+ --without-system-libcmis
--without-system-sane
- --without-system-qrcodegen
$(use_enable base report-builder)
$(use_enable bluetooth sdremote-bluetooth)
$(use_enable coinmp)