summaryrefslogtreecommitdiff
path: root/app-office/moneydance
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-11-18 09:38:27 +0000
commit536c3711867ec947c1738f2c4b96f22e4863322d (patch)
tree697733f5cb713908dcf378e13fd15a798a906a91 /app-office/moneydance
parentf65628136faa35d0c4d3b5e7332275c7b35fcd96 (diff)
gentoo resync : 18.11.2018
Diffstat (limited to 'app-office/moneydance')
-rw-r--r--app-office/moneydance/Manifest4
-rw-r--r--app-office/moneydance/metadata.xml17
-rw-r--r--app-office/moneydance/moneydance-2017.8.ebuild62
3 files changed, 83 insertions, 0 deletions
diff --git a/app-office/moneydance/Manifest b/app-office/moneydance/Manifest
new file mode 100644
index 000000000000..a606da444b03
--- /dev/null
+++ b/app-office/moneydance/Manifest
@@ -0,0 +1,4 @@
+DIST moneydance-2017.8-amd64.tar.gz 132109962 BLAKE2B 4984b6266eed96337ab284168db1a167121daa6b454a338f348d1d724587e6dfd6a52c25ff739ca0e09a9c0441b1b582e59a571f001e8b2ddc6c5e10917100cd SHA512 53e46ee63ee89b86f3108045e9a16fdda637effb5edb719ccf7192632e6ebace607f40871ee54b5c5bde40821fdf2cbf89a5abd6eba0698618a8db8d848971c6
+DIST moneydance-2017.8-x86.tar.gz 134851425 BLAKE2B 4c40f30798b66d01b5abacc5cfbfa584a107f351de8bd2eb8c291aea6d96c122a36feb5ed092ea0aec4a99be7e1507f79551a1c6a1cd79365b8dfc52892a57bc SHA512 434fbd0c941a455c862963e572b7c1489fa19ccf30efb315af33eac3974acdad57292943d129433e6a59d3f233cd797b6697c0e82d9293ce0464d25ab8c32912
+EBUILD moneydance-2017.8.ebuild 1414 BLAKE2B 1512bcddeb14697fc637eae397c8391b5b6694c7a2f0244e921e10cb969cdc78c1c5d355973b3d1cac22db3ac5874550c8ddb41fb30ff64bb76e02463e49816e SHA512 3a3091dfc72decc00faaedeaaabd46c077b0247ff3cbefde057dc99330800660a0911e5dea48a5b50ce2443913e5bd74e4d1d75145a984c5bc819e33f7d55241
+MISC metadata.xml 601 BLAKE2B da75b9789bf828531d9a23f3143bf6977af23efdefd4c2d9cf1488c7d3a66a304f202b1cd496fc807cdf52d271f7a50bf3090e1d7d60d427656ab2bdec4f9ce1 SHA512 a77ece9db983b7955d26e760f6d1951cafaafac57c217cd916070a3d477daaea93338a26ff523d87e4ca4227e1ce02d122f5939069caf8c7bbbb3d0fda9d8e6d
diff --git a/app-office/moneydance/metadata.xml b/app-office/moneydance/metadata.xml
new file mode 100644
index 000000000000..2c7b5849ff8c
--- /dev/null
+++ b/app-office/moneydance/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ck+gentoo@bl4ckb0x.de</email>
+ <name>Conrad Kostecki</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ Moneydance is easy to use personal finance software that is loaded
+ with all the features you need: online banking and bill payment,
+ account management, budgeting and investment tracking.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-office/moneydance/moneydance-2017.8.ebuild b/app-office/moneydance/moneydance-2017.8.ebuild
new file mode 100644
index 000000000000..801d4007af9c
--- /dev/null
+++ b/app-office/moneydance/moneydance-2017.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="Moneydance"
+
+inherit desktop gnome2-utils java-pkg-2
+
+DESCRIPTION="A cross-platform personal finance application"
+HOMEPAGE="https://moneydance.com/"
+SRC_URI="
+ amd64? ( https://infinitekind.com/stabledl/current/${MY_PN}_linux_amd64.tar.gz -> ${P}-amd64.tar.gz )
+ x86? ( https://infinitekind.com/stabledl/current/${MY_PN}_linux_x86.tar.gz -> ${P}-x86.tar.gz )
+"
+
+LICENSE="Apache-1.0 Apache-2.0 BSD CPAL-1.0 CPL-1.0 CSL-2.0 LGPL-2 MIT TIK"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/jre-1.8"
+
+DEPEND="
+ >=virtual/jdk-1.8"
+
+S="${WORKDIR}/${MY_PN}"
+
+RESTRICT="bindist fetch mirror"
+
+pkg_nofetch() {
+ elog "Please download ${A} from"
+ elog "https://www.infinitekind.com/download-moneydance-personal-finance-software"
+ elog "and place it in your DISTDIR directory."
+}
+
+src_prepare() {
+ default
+
+ # Modify .desktop file, to fix QA errors
+ sed -e 's/Application;//g' -e 's/.png//g' -i resources/moneydance.desktop || die
+}
+
+src_compile() {
+ :;
+}
+
+src_install() {
+ java-pkg_dojar jars/*.jar
+ java-pkg_dolauncher moneydance --main "Moneydance" --java_args "-client -Dawt.useSystemAAFontSettings=gasp -Dawt.useSystemAAFontSettings=on -Xmx1024m"
+
+ doicon resources/*.png
+ domenu resources/moneydance.desktop
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}