summaryrefslogtreecommitdiff
path: root/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-29 16:53:27 +0100
commit1173ad5704ce725916e0c332416aff326d850d06 (patch)
treed48d60977ce19864893dfb2222bf2982ffb4262a /app-office/pinpoint/pinpoint-0.1.8-r1.ebuild
parent8c364c784966be1700ea39ae45028f3e9be9cae0 (diff)
gentoo resync : 29.03.2018
Diffstat (limited to 'app-office/pinpoint/pinpoint-0.1.8-r1.ebuild')
-rw-r--r--app-office/pinpoint/pinpoint-0.1.8-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild b/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..7bf59666c4c6
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://wiki.gnome.org/Apps/Pinpoint"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND="
+ >=media-libs/clutter-1.23.7:1.0
+ >=media-libs/clutter-gtk-1.6:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( media-libs/clutter-gst:3.0 )
+ pdf? ( gnome-base/librsvg:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix CVE-2013-7447, bug #574384, https://bugzilla.gnome.org/show_bug.cgi?id=762029
+ "${FILESDIR}"/${P}-CVE-2013-7447.patch
+)
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ gnome2_src_configure \
+ --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ gnome2_src_install
+
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+}