summaryrefslogtreecommitdiff
path: root/app-office/pinpoint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/pinpoint
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/pinpoint')
-rw-r--r--app-office/pinpoint/Manifest4
-rw-r--r--app-office/pinpoint/files/pinpoint-0.1.8-CVE-2013-7447.patch33
-rw-r--r--app-office/pinpoint/metadata.xml13
-rw-r--r--app-office/pinpoint/pinpoint-0.1.8-r1.ebuild50
4 files changed, 100 insertions, 0 deletions
diff --git a/app-office/pinpoint/Manifest b/app-office/pinpoint/Manifest
new file mode 100644
index 000000000000..53e4d0a28823
--- /dev/null
+++ b/app-office/pinpoint/Manifest
@@ -0,0 +1,4 @@
+AUX pinpoint-0.1.8-CVE-2013-7447.patch 1197 BLAKE2B 3a9593e8175ade71784f1f656971b854ea7ccaa69ea28d90f34ed73b4049179871bf1dc731f0a29d0d8c129a1a108d18270a2cc65ba75e89accb616ceef8fa87 SHA512 1ad48cd84f1dc4c14e7e9886263bb595573e3941b9725dc777bee15bbe2404fb5b582a2850a0a6068627af608d0fe960a1775b388c3f175906ad9fd884708756
+DIST pinpoint-0.1.8.tar.xz 772980 BLAKE2B 1ca653b1cece97b47accd3a9cfe2560030f70a35703bd12b52cb692a15181b9bac2d40265bb6eaa486dc1919044f7b74874cb8b7fc8f4f37b78d938c89cb28ca SHA512 dc41405f79bf03b6a7c77ec31304e505d4ae2d13407304fbcc2f338dfe175f91db3c554ea06ba8041edbf99a12551f16efed98b5a07f29b7f24255cad2b1b94d
+EBUILD pinpoint-0.1.8-r1.ebuild 1194 BLAKE2B 69910e8197750b647780faa4e87912805006911f3b1c1f00b6af9631840d7362a9ea9d44741d84237d92ee7ded143088ef5fb62e995f4cf0e8f5c06e4eab088f SHA512 0a793115dc2df8613acc8163700f5b81dff7e49ef4a550124aebb1534fe612f7b4f16734c70db9bf66f253ee283ddeb2693e6f4ae2870391106f6f430c1b4e9d
+MISC metadata.xml 507 BLAKE2B e171dd659b7a4c19874ae97040e6241f761a7cdf49228c121ba44b82cba3175f3a444ec69933ece62b70be5d970ba95f5bee0480e4b012564f29921fa5c58f7b SHA512 be6bb803225f307fc7d2a9febd4ece776ce2e99f902d952b80c5bb8068793a9f32ab09c6a79a4c950299a83829fd32fab366600637892fbac02a908f038add74
diff --git a/app-office/pinpoint/files/pinpoint-0.1.8-CVE-2013-7447.patch b/app-office/pinpoint/files/pinpoint-0.1.8-CVE-2013-7447.patch
new file mode 100644
index 000000000000..b9c39ad7206d
--- /dev/null
+++ b/app-office/pinpoint/files/pinpoint-0.1.8-CVE-2013-7447.patch
@@ -0,0 +1,33 @@
+From f90483245250456d6306b4fff2f68f445ef33864 Mon Sep 17 00:00:00 2001
+From: RyuzakiKK <aasonykk@gmail.com>
+Date: Sat, 5 Aug 2017 20:00:30 +0200
+Subject: [PATCH] Avoid integer overflow
+
+pinpoint is affected by a possible integer overflow, that was also
+found and patched upstream in gtk+
+https://git.gnome.org/browse/gtk+/commit/?id=894b1ae76a32720f4bb3d39cf460402e3ce331d6
+
+With g_malloc_m we can avoid the integer overflow.
+
+As pointed out by Pacho Ramos in
+https://bugzilla.gnome.org/show_bug.cgi?id=762029
+---
+ pp-cairo.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pp-cairo.c b/pp-cairo.c
+index 8afb362..dc0a452 100644
+--- a/pp-cairo.c
++++ b/pp-cairo.c
+@@ -120,7 +120,7 @@ _cairo_new_surface_from_pixbuf (const GdkPixbuf *pixbuf)
+ format = CAIRO_FORMAT_ARGB32;
+
+ cairo_stride = cairo_format_stride_for_width (format, width);
+- cairo_pixels = g_malloc (height * cairo_stride);
++ cairo_pixels = g_malloc_n (height, cairo_stride);
+ surface = cairo_image_surface_create_for_data ((unsigned char *)cairo_pixels,
+ format,
+ width, height, cairo_stride);
+--
+2.13.4
+
diff --git a/app-office/pinpoint/metadata.xml b/app-office/pinpoint/metadata.xml
new file mode 100644
index 000000000000..3f1c1dff8912
--- /dev/null
+++ b/app-office/pinpoint/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription lang="en">
+ Pinpoint is a simple presentation tool that hopes to avoid audience
+ death by bullet point and instead encourage presentations containing
+ beautiful images and small amounts of concise text in slides.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild b/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild
new file mode 100644
index 000000000000..0102de0eb567
--- /dev/null
+++ b/app-office/pinpoint/pinpoint-0.1.8-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="A tool for making hackers do excellent presentations"
+HOMEPAGE="https://wiki.gnome.org/Apps/Pinpoint"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gstreamer +pdf"
+
+# rsvg is used for svg-in-pdf -- clubbing it under pdf for now
+RDEPEND="
+ >=media-libs/clutter-1.23.7:1.0
+ >=media-libs/clutter-gtk-1.6:1.0
+ >=dev-libs/glib-2.28:2
+ >=x11-libs/cairo-1.9.4
+ x11-libs/pango
+ x11-libs/gdk-pixbuf:2
+ gstreamer? ( media-libs/clutter-gst:3.0 )
+ pdf? ( gnome-base/librsvg:2 )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Fix CVE-2013-7447, bug #574384, https://bugzilla.gnome.org/show_bug.cgi?id=762029
+ "${FILESDIR}"/${P}-CVE-2013-7447.patch
+)
+
+src_configure() {
+ # dax support is disabled because we don't have it in tree yet and it's
+ # experimental
+ gnome2_src_configure \
+ --disable-dax \
+ $(use_enable gstreamer cluttergst) \
+ $(use_enable pdf rsvg)
+}
+
+src_install() {
+ gnome2_src_install
+
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto "/usr/share/doc/${PF}/examples"
+ doins introduction.pin bg.jpg bowls.jpg linus.jpg
+}