summaryrefslogtreecommitdiff
path: root/app-office/plan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /app-office/plan
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'app-office/plan')
-rw-r--r--app-office/plan/Manifest4
-rw-r--r--app-office/plan/plan-1.10.ebuild49
2 files changed, 23 insertions, 30 deletions
diff --git a/app-office/plan/Manifest b/app-office/plan/Manifest
index 0f459bc86584..4dac21d4f10e 100644
--- a/app-office/plan/Manifest
+++ b/app-office/plan/Manifest
@@ -1,4 +1,4 @@
-DIST plan-1.10-gentoo.tar.xz 5976 BLAKE2B 598c92a750fc0a305d7f51211f9e42eae36644de1a83175fcb86c8c30450b8fc1e7d2eabbaced62779d80b557f7f725c97395bc744171952970faa3543abba2f SHA512 60fcfe1fec1d7911a155d6737e6a808ea897ce7c4207bd2f4e95f57b1d154d8d594c6f5ecc8a959cc0d7f47f1415f86797e0c4053873775decfc048bc16048a3
+DIST plan-1.10-patches.txz 6132 BLAKE2B 617c68a012e4757f7ef039557cfe15e04706129501f044005e554a50aa9ebbe9e33e2e406ec5647060a7b67efb81b671c35eb6846d426a26c517c38b10e7eabb SHA512 c0802f12e935d7ab18d89b6c4e8ae8373ca620b8149520b8bc9d9fb8e871ad4c2b0bc0e7ca84c34e72d0a25cb406af51fac1fc1907844867f4fd7fdff8a06d54
DIST plan-1.10.tar.gz 460150 BLAKE2B a44c79537ff6aae8fa5c65c8b6514f0f37d1417522f4e54823ad14cf6306bb88223377de13f22c365516e2861fa561902e31245c9729786f425140bed30b320d SHA512 fde17ef17f25412cbe69427364f4130564f46a940859066c25d837d14eca6920752b843211192a6c1cdc83be05de9ac57c88424ca555928b67eb219fa8564fe8
-EBUILD plan-1.10.ebuild 1455 BLAKE2B c3d42ed02f554e789067b71db881715e004a659379ef46dc3142cb4912c90dc551cc06f9597e4191050d9a3bcfc5743b2f3e3077dd960fcf44baecf84fc8d759 SHA512 8345d80d13ad376e83a72e4a54375cf2751659b31909dada23decec001e73bebd3cc144d3dab1d0c14891702ca5248205133a46f4b749fb54f39786f88e155e8
+EBUILD plan-1.10.ebuild 1495 BLAKE2B 370173539537d06515024aa34377a6d6e3bb762d020b33c55e4de5e70b5dba45ca0f19b77e0cefb2ae71ecb47660873c3c2dab6d38d04c3f3ca3b36a8bf98683 SHA512 087c4ebdecfcd9cfb469b0e4ab7d9a088564e450e5290c716d729a86166aa3187b94deb814574eb49abdd85a1f8ddb23473e41808ba6c2ec688c36ef2d2744bd
MISC metadata.xml 258 BLAKE2B 18104e5bf54213c7d7302cc72c3ec47d0c322f2fd397dde15b5ee29db433961329fd2b22c379d19125d7f5ded7dcc376d3afb9ce77426d9615022bde50078649 SHA512 a4886b16e304b05a448e28681a38ec68fcdd7828029444fd9c01aab0fdda8d9540cd0d829da2e9f22b38b33d10e85bf111c8e45b49966c32b267c90704adec40
diff --git a/app-office/plan/plan-1.10.ebuild b/app-office/plan/plan-1.10.ebuild
index bb35e5181561..e16129ffdb18 100644
--- a/app-office/plan/plan-1.10.ebuild
+++ b/app-office/plan/plan-1.10.ebuild
@@ -1,65 +1,58 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Motif based schedule planner"
HOMEPAGE="https://www.bitrot.de/plan.html"
-SRC_URI="ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
- mirror://gentoo/${P}-gentoo.tar.xz"
+SRC_URI="
+ ftp://ftp.fu-berlin.de/unix/X11/apps/plan/${P}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${P}-patches.txz"
LICENSE="GPL-2+" #448646
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
-IUSE=""
-DEPEND="
- x11-libs/libXpm
- >=x11-libs/motif-2.3:0
-"
-RDEPEND="${DEPEND}"
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/motif:0"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex"
-QA_PRESTRIPPED="
-/usr/bin/netplan
-/usr/bin/plan
-"
-src_prepare() {
- epatch "${WORKDIR}"/${P}-patches/*.patch
-}
+PATCHES=( "${WORKDIR}"/patches )
src_compile() {
- pushd src
- emake CC=$(tc-getCC) SHARE=/usr/share/plan linux
- popd
+ emake -C src CC="$(tc-getCC)" SHARE=/usr/share/plan linux
}
src_install() {
- pushd src
- emake \
- DESTDIR="${D}" \
+ emake -C src \
+ DESTDIR="${ED}" \
SHARE=/usr/share/plan \
install
keepdir /usr/share/plan/netplan.dir
- popd
dodoc HISTORY README
- pushd misc
+ pushd misc >/dev/null || die
doman netplan.1 plan.1 plan.4
insinto /usr/share/${PN}/misc
doins netplan.boot BlackWhite Monochrome plan.fti Plan.xpm plan.xpm
exeinto /usr/share/${PN}/misc
doexe Killpland cvs vsc msschedule2plan plan2vcs
- popd
+ popd >/dev/null || die
- pushd web
+ pushd web >/dev/null || die
insinto /usr/share/${PN}/web
doins help.html bottom.html cgi-lib.pl common.pl holiday_webplan rtsban.jpg
exeinto /usr/share/${PN}/web
doexe *.cgi
- popd
+ popd >/dev/null || die
}
pkg_postinst() {