summaryrefslogtreecommitdiff
path: root/app-office/texmacs/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-office/texmacs/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-office/texmacs/files')
-rw-r--r--app-office/texmacs/files/texmacs-1.99-remove-new-declaration.patch19
-rw-r--r--app-office/texmacs/files/texmacs-1.99.2-desktop.patch23
-rw-r--r--app-office/texmacs/files/texmacs-1.99.6-guile-size_t.patch21
-rw-r--r--app-office/texmacs/files/texmacs-1.99.6-math_util.patch15
-rw-r--r--app-office/texmacs/files/texmacs-plugins-1.patch48
-rw-r--r--app-office/texmacs/files/texmacs-updates.patch29
6 files changed, 155 insertions, 0 deletions
diff --git a/app-office/texmacs/files/texmacs-1.99-remove-new-declaration.patch b/app-office/texmacs/files/texmacs-1.99-remove-new-declaration.patch
new file mode 100644
index 000000000000..45b08226f652
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.99-remove-new-declaration.patch
@@ -0,0 +1,19 @@
+Remove new/delete declarations, which cause problems with recent GCC versions:
+* /usr/lib/gcc/x86_64-pc-linux-gnu/4.9.3/include/g++-v4/new:135:41: error: declaration of ‘void operator delete [](void*) throw ()’ has a different exception specifier
+
+See also: https://bugs.gentoo.org/show_bug.cgi?id=590002
+
+--- TeXmacs-1.99.5-src/src/System/Misc/fast_alloc.hpp
++++ TeXmacs-1.99.5-src/src/System/Misc/fast_alloc.hpp
+@@ -384,11 +384,6 @@
+ void operator delete (register void* ptr) throw();
+ void* operator new[] (register size_t s) throw(std::bad_alloc);
+ void operator delete[] (register void* ptr) throw();
+-#else
+-void* operator new (register size_t s);
+-void operator delete (register void* ptr);
+-void* operator new[] (register size_t s);
+-void operator delete[] (register void* ptr);
+ #endif
+ #endif // not defined NO_FAST_ALLOC
+
diff --git a/app-office/texmacs/files/texmacs-1.99.2-desktop.patch b/app-office/texmacs/files/texmacs-1.99.2-desktop.patch
new file mode 100644
index 000000000000..275f5571ebd8
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.99.2-desktop.patch
@@ -0,0 +1,23 @@
+ TeXmacs/misc/mime/texmacs.desktop | 7 +------
+ 1 file changed, 1 insertion(+), 6 deletions(-)
+
+diff --git a/TeXmacs/misc/mime/texmacs.desktop b/TeXmacs/misc/mime/texmacs.desktop
+index 493103c..cfd66b3 100644
+--- a/TeXmacs/misc/mime/texmacs.desktop
++++ b/TeXmacs/misc/mime/texmacs.desktop
+@@ -1,14 +1,9 @@
+ [Desktop Entry]
+ Name=GNU TeXmacs
+ Comment=A structured wysiwyg scientific text editor
+-BinaryPattern=texmacs
+-Protocols=
+ MimeType=text/x-texmacs;text/plain;text/x-tex;
+ Exec=texmacs %f
+ Icon=TeXmacs
+-TerminalOptions=
+-Path=
+ Type=Application
+-Terminal=0
+-MapNotify=false
++Terminal=false
+ Categories=Education;Science;Math;
diff --git a/app-office/texmacs/files/texmacs-1.99.6-guile-size_t.patch b/app-office/texmacs/files/texmacs-1.99.6-guile-size_t.patch
new file mode 100644
index 000000000000..3068169618fb
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.99.6-guile-size_t.patch
@@ -0,0 +1,21 @@
+C compiler compiles this code for bot int-based and size_t-based
+guile. C++ compiler does not (and is what used by texmacs).
+
+https://bugs.gentoo.org/652054
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 37e9e87..5de2711 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -274,11 +274,11 @@ SET(CMAKE_REQUIRED_FLAGS "-Werror ${Guile_CFLAGS}")
+ SET(CMAKE_REQUIRED_INCLUDES ${Guile_INCLUDE_DIRS})
+ SET(CMAKE_REQUIRED_LIBRARIES ${Guile_LIBRARIES})
+
+ MESSAGE(STATUS "Checking the size_t of guile strings")
+
+-CHECK_C_SOURCE_COMPILES( "#include <guile/gh.h>
++CHECK_CXX_SOURCE_COMPILES( "#include <guile/gh.h>
+ #include <libguile.h>
+ void print_string (SCM s) {
+ int len_r;
+ char* r= gh_scm2newstr (s, &len_r); } int main() { return 0; }
+ " _guile_str_size_test)
diff --git a/app-office/texmacs/files/texmacs-1.99.6-math_util.patch b/app-office/texmacs/files/texmacs-1.99.6-math_util.patch
new file mode 100644
index 000000000000..006c92c2be33
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.99.6-math_util.patch
@@ -0,0 +1,15 @@
+diff -r -U2 TeXmacs-1.99.6-src.orig/src/Graphics/Types/math_util.hpp TeXmacs-1.99.6-src/src/Graphics/Types/math_util.hpp
+--- TeXmacs-1.99.6-src.orig/src/Graphics/Types/math_util.hpp 2017-12-22 03:27:43.000000000 +0700
++++ TeXmacs-1.99.6-src/src/Graphics/Types/math_util.hpp 2017-12-22 16:44:35.052378917 +0700
+@@ -24,11 +24,4 @@
+ inline int sign (double x) { return x>0?1:x<0?-1:0; }
+ inline bool fnull (double x, double approx) { return norm(x) <= approx; }
+-#ifndef __SUNPRO_CC
+-inline double pow (double x, int n) {
+- double r= 1.0;
+- while (n > 0) { r *= x; n--; }
+- return r; }
+-#endif
+-
+
+ #endif // defined MATH_UTIL_H
diff --git a/app-office/texmacs/files/texmacs-plugins-1.patch b/app-office/texmacs/files/texmacs-plugins-1.patch
new file mode 100644
index 000000000000..1d3299f407ce
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-plugins-1.patch
@@ -0,0 +1,48 @@
+diff -r -U1 TeXmacs-1.0.7.21-src.orig/plugins/axiom/Makefile TeXmacs-1.0.7.21-src/plugins/axiom/Makefile
+--- TeXmacs-1.0.7.21-src.orig/plugins/axiom/Makefile 2013-11-04 06:09:24.000000000 +0700
++++ TeXmacs-1.0.7.21-src/plugins/axiom/Makefile 2013-12-29 02:40:24.263756226 +0700
+@@ -16,3 +16,3 @@
+ bin/tm_axiom: src/tm_axiom.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) src/tm_axiom.c -o bin/tm_axiom
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) src/tm_axiom.c -o bin/tm_axiom
+
+diff -r -U1 TeXmacs-1.0.7.21-src.orig/plugins/graphviz/Makefile TeXmacs-1.0.7.21-src/plugins/graphviz/Makefile
+--- TeXmacs-1.0.7.21-src.orig/plugins/graphviz/Makefile 2013-11-04 06:09:18.000000000 +0700
++++ TeXmacs-1.0.7.21-src/plugins/graphviz/Makefile 2013-12-29 02:41:10.245753123 +0700
+@@ -16,3 +16,3 @@
+ bin/tm_graphviz: src/tm_graphviz.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) src/tm_graphviz.c -o bin/tm_graphviz
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) src/tm_graphviz.c -o bin/tm_graphviz
+
+diff -r -U1 TeXmacs-1.0.7.21-src.orig/plugins/maple/Makefile TeXmacs-1.0.7.21-src/plugins/maple/Makefile
+--- TeXmacs-1.0.7.21-src.orig/plugins/maple/Makefile 2013-11-04 06:09:23.000000000 +0700
++++ TeXmacs-1.0.7.21-src/plugins/maple/Makefile 2013-12-29 02:41:45.834750721 +0700
+@@ -17,3 +17,3 @@
+ bin/tm_maple_5: src/tm_maple_5.cpp
+- $(CXX) $(CPPFLAGS) $(CXXFLAGS) src/tm_maple_5.cpp -o bin/tm_maple_5
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) src/tm_maple_5.cpp -o bin/tm_maple_5
+
+diff -r -U1 TeXmacs-1.0.7.21-src.orig/plugins/mathematica/Makefile TeXmacs-1.0.7.21-src/plugins/mathematica/Makefile
+--- TeXmacs-1.0.7.21-src.orig/plugins/mathematica/Makefile 2013-11-04 06:09:22.000000000 +0700
++++ TeXmacs-1.0.7.21-src/plugins/mathematica/Makefile 2013-12-29 02:42:33.470747506 +0700
+@@ -14,3 +14,3 @@
+ bin/realpath: src/realpath.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) src/realpath.c -o bin/realpath
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) src/realpath.c -o bin/realpath
+
+diff -r -U1 TeXmacs-1.0.7.21-src.orig/plugins/r/Makefile TeXmacs-1.0.7.21-src/plugins/r/Makefile
+--- TeXmacs-1.0.7.21-src.orig/plugins/r/Makefile 2013-11-04 06:09:24.000000000 +0700
++++ TeXmacs-1.0.7.21-src/plugins/r/Makefile 2013-12-29 02:43:32.538743520 +0700
+@@ -16,3 +16,3 @@
+ bin/tm_r: src/tm_r.c
+- $(CC) $(CPPFLAGS) $(CFLAGS) -I../../src/System src/tm_r.c -o bin/tm_r -lutil
++ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) -I../../src/System src/tm_r.c -o bin/tm_r -lutil
+
+diff -r -U1 TeXmacs-1.0.7.21-src.orig/plugins/shell/Makefile TeXmacs-1.0.7.21-src/plugins/shell/Makefile
+--- TeXmacs-1.0.7.21-src.orig/plugins/shell/Makefile 2013-11-04 06:09:21.000000000 +0700
++++ TeXmacs-1.0.7.21-src/plugins/shell/Makefile 2013-12-29 02:44:07.584741155 +0700
+@@ -16,3 +16,3 @@
+ bin/tm_shell: src/tm_shell.cpp
+- $(CXX) $(CPPFLAGS) $(CXXFLAGS) -I../../src/System src/tm_shell.cpp -o bin/tm_shell -lutil
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) -I../../src/System src/tm_shell.cpp -o bin/tm_shell -lutil
+
diff --git a/app-office/texmacs/files/texmacs-updates.patch b/app-office/texmacs/files/texmacs-updates.patch
new file mode 100644
index 000000000000..f9517cd25edc
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-updates.patch
@@ -0,0 +1,29 @@
+diff -r -U1 TeXmacs-1.0.7.16-src.orig/Makefile.in TeXmacs-1.0.7.16-src/Makefile.in
+--- TeXmacs-1.0.7.16-src.orig/Makefile.in 2012-07-09 21:33:36.000000000 +0700
++++ TeXmacs-1.0.7.16-src/Makefile.in 2012-09-16 11:20:06.000000000 +0700
+@@ -171,3 +171,2 @@
+ $(DESTDIR)$(datadir)/applications
+- @update-desktop-database 2>/dev/null || :
+ $(MKDIR) $(DESTDIR)$(datadir)/application-registry
+@@ -181,3 +180,2 @@
+ $(CP) $(tmdir)/misc/mime/texmacs.xml $(DESTDIR)$(datadir)/mime/packages
+- @update-mime-database $(DESTDIR)$(datadir)/mime/ 2>/dev/null || :
+ $(MKDIR) $(DESTDIR)$(datadir)/pixmaps
+@@ -193,4 +191,2 @@
+ $(DESTDIR)$(datadir)/icons/gnome/scalable/mimetypes
+- @gtk-update-icon-cache -t --force \
+- $(DESTDIR)$(datadir)/icons/gnome 2>/dev/null || :
+ @echo installed TeXmacs mime info in $(DESTDIR)$(datadir)
+@@ -223,3 +219,2 @@
+ $(RM) $(datadir)/applications/texmacs.desktop
+- @update-desktop-database 2>/dev/null || :
+ $(RM) $(datadir)/application-registry/texmacs.applications
+@@ -228,3 +223,2 @@
+ $(RM) $(datadir)/mime/packages/texmacs.xml
+- @update-mime-database $(DESTDIR)$(datadir)/mime/ 2>/dev/null || :
+ $(RM) $(datadir)/pixmaps/TeXmacs.xpm
+@@ -232,4 +226,2 @@
+ $(RM) $(datadir)/icons/gnome/scalable/mimetypes/text-texmacs.svg
+- @gtk-update-icon-cache -t --force \
+- $(DESTDIR)$(datadir)/icons/gnome 2>/dev/null || :
+ @echo removed TeXmacs mime info from $(datadir)