summaryrefslogtreecommitdiff
path: root/app-office
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 22:13:37 +0000
commit39ca6159b9ac903dc56818918d9f97bc831f0955 (patch)
treee9b34845be7f96bc244fd239f6dd8090096ce703 /app-office
parentbc968d15e7f24968eb69567c7f2fca470fdedacd (diff)
gentoo auto-resync : 04:11:2023 - 22:13:37
Diffstat (limited to 'app-office')
-rw-r--r--app-office/Manifest.gzbin8071 -> 8071 bytes
-rw-r--r--app-office/gnumeric/Manifest2
-rw-r--r--app-office/gnumeric/gnumeric-1.12.56.ebuild93
3 files changed, 95 insertions, 0 deletions
diff --git a/app-office/Manifest.gz b/app-office/Manifest.gz
index 4dc0027c24d5..2b5c3b245f00 100644
--- a/app-office/Manifest.gz
+++ b/app-office/Manifest.gz
Binary files differ
diff --git a/app-office/gnumeric/Manifest b/app-office/gnumeric/Manifest
index 8b205a28ac43..b2a24673cb1d 100644
--- a/app-office/gnumeric/Manifest
+++ b/app-office/gnumeric/Manifest
@@ -1,3 +1,5 @@
DIST gnumeric-1.12.55.tar.xz 18157492 BLAKE2B 6c084f681e33f00af80cc11dbddf33166877ca30480ae6fc6b65a0ef06271c634e2ba24af55df4c6b306833e2611e959dcbd8b117c97bbf46598419ed4d124e4 SHA512 04127a353d5109e3a31d9a3bd42d6d177366cc6c5d900516b4c8a7a8fcaecc71bd4e2e94876719246841070964b393af97988cafbd6313cea135c1757889e878
+DIST gnumeric-1.12.56.tar.xz 18125644 BLAKE2B 0b43ed53dd544dda76ae1401d329f8b029f16117dafb4c2f939c1c48bf61d035e17692485df4034ce77a63031c5477aefd307a04d756c3017fed47354acb4f8a SHA512 badcba4cb08627628c216e4f2429c361d3d8ec7f653b6dda8a451356c798dc0cf323348c0272696a02bd47dd97b95bde0e7b23551cc0f63d8bf470dca219be0d
EBUILD gnumeric-1.12.55.ebuild 2329 BLAKE2B 8e53fd2b978d3af15d80f0078acd0d0c1fa7eb7f18898e3b5be5ad32f3017d6e2355610ea593466794e96671930a241232362b8cff114c4b15c40d2c9b027b4a SHA512 6eca09bef45efb679a57ef9d23e6fb3dce2448b618f84c87f4c78be6757bfaffb788250726dff076ce15c12088e7794e48f9bbdd8826aea599829ef859e9dd40
+EBUILD gnumeric-1.12.56.ebuild 2330 BLAKE2B 31359752b7425ebe0c44bdf08b5a2f303b9d1830403cd8c83f14c5fd3a70c1d4553bf2c90dd7d11a3f7b0d35adc06c0cbbc61246ee5cb594daf0ca4da6217c2d SHA512 82d1fb526faeeddf3f9fef9d3485a9cb11e7324af34af6a8d3a81313604250ecc1735197c79e33e2b63e6fdf729e14a737c6d1058db56cb286a49581a27e0bff
MISC metadata.xml 627 BLAKE2B 6704cf7889bf073ee97e1af9145395462f326aa44ad6fa04f4cc4908bbde8a486518c0f11e3a9ab887835c0af862868b8a86ca29191ac1bdf179aa060c621020 SHA512 451313a3c0d62af5f647bcdce0ac76bf1948189bb70c555f6aa871245bf3ce62b0ad306c8835a7c42b24333c3e9ce449a209d3d6967e487ec061792969092107
diff --git a/app-office/gnumeric/gnumeric-1.12.56.ebuild b/app-office/gnumeric/gnumeric-1.12.56.ebuild
new file mode 100644
index 000000000000..9c945b556cdc
--- /dev/null
+++ b/app-office/gnumeric/gnumeric-1.12.56.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit autotools gnome.org python-r1 xdg
+
+DESCRIPTION="The GNOME Spreadsheet"
+HOMEPAGE="http://www.gnumeric.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+introspection libgda perl"
+REQUIRED_USE="introspection? ( ${PYTHON_REQUIRED_USE} )"
+
+# Missing gnome-extra/libgnomedb required version in tree
+# but its upstream is dead and will be dropped soon.
+
+# lots of missing files, also fails tests due to 80-bit long story
+# upstream bug #721556
+RESTRICT="test"
+
+# Gnumeric has two python components
+# 1. The python loader for loading python-based plugins.
+# This component is pure python 2 and a port "is not currently being worked on".
+# 2. The python gobject-based introspection API. This component is compatible
+# with python 3.
+# Component 1. can only be re-enabled once someone has ported the upstream
+# codebase to python 3.
+# https://gitlab.gnome.org/GNOME/gnumeric/issues/419#note_618852
+RDEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ >=dev-libs/glib-2.40.0:2
+ >=gnome-extra/libgsf-1.14.33:=
+ >=x11-libs/goffice-0.10.55:0.10[introspection?]
+ >=dev-libs/libxml2-2.4.12:2
+ >=x11-libs/pango-1.24.0:=
+
+ >=x11-libs/gtk+-3.8.7:3
+ x11-libs/cairo:=[svg(+)]
+
+ introspection? (
+ ${PYTHON_DEPS}
+ >=dev-libs/gobject-introspection-1:=
+ )
+ perl? ( dev-lang/perl:= )
+ libgda? ( gnome-extra/libgda:5[gtk] )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-text/docbook-xml-dtd:4.5
+ app-text/yelp-tools
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Manage gi overrides ourselves
+ sed '/SUBDIRS/ s/introspection//' -i Makefile.{am,in} || die
+
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-gtk-doc \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-static \
+ --without-psiconv \
+ --without-python \
+ --with-zlib \
+ $(use_with libgda gda) \
+ $(use_enable introspection) \
+ $(use_with perl)
+}
+
+src_install() {
+ default
+ dodoc HACKING MAINTAINERS
+
+ if use introspection; then
+ python_moduleinto gi.overrides
+ python_foreach_impl python_domodule introspection/gi/overrides/Gnm.py
+ fi
+
+ # no static archives
+ find "${ED}" -name '*.la' -delete || die
+}