summaryrefslogtreecommitdiff
path: root/app-officeext/languagetool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-officeext/languagetool
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-officeext/languagetool')
-rw-r--r--app-officeext/languagetool/Manifest5
-rw-r--r--app-officeext/languagetool/languagetool-3.4.ebuild25
-rw-r--r--app-officeext/languagetool/languagetool-3.5.ebuild25
-rw-r--r--app-officeext/languagetool/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/app-officeext/languagetool/Manifest b/app-officeext/languagetool/Manifest
new file mode 100644
index 000000000000..f425b1924823
--- /dev/null
+++ b/app-officeext/languagetool/Manifest
@@ -0,0 +1,5 @@
+DIST LanguageTool-3.4.oxt 58043690 BLAKE2B d381d0e426619182e8e5d7469dfb18e41c7a993f1850afd1a2720199618eaaadd093f3b7efafc23601a42221e991e71820d963326618f24be4889cf55b04f5f1 SHA512 29eda8c4a26eb4da4dce68db6f962c8a8828bb0eb76aef3e31a58607aea9a15705aaccc4a1bc5366760bdb00c9133ef225291941e5873cbcc384627464eb9a8f
+DIST LanguageTool-3.5.oxt 58210562 BLAKE2B 77a455a9a7950aed69c5b6ffd1bfca43b0821f6b84cfa96d5aea05b9a57995c4542e4d651e150d964173bdc1e3364b96ececeda07919db68ad04293673f02c9f SHA512 1a36c04117c473ccb812f3b216763d816ddc796869488bfcf2f36d8ab325ef1620edf148ebb8b1b1b2d62a043b5b45f738e27ff440f6f99067601828a49f0e0e
+EBUILD languagetool-3.4.ebuild 469 BLAKE2B 989837d26b982fd26508b9e55fb47e473d8b9f8368831688b0639fbafb6bef949db088b59545812110d40350ef036428e2c8b9fb1f986238f3dca6e4f3a7377d SHA512 c1df1c13175daa42c33b3f8a1347ce33578d345a90428f485477f88e9591995f1d65b33d9f24560272ff24f64588bc262aefe6bd53095fcdb3d0cc4b2774abf3
+EBUILD languagetool-3.5.ebuild 471 BLAKE2B 77fd207069a87824ebb6b34488c5e8745e190663554a301785a2f1bc5bd19593b93a2c5bb9adb5b930e0813012ba74ac1e092e8c321b712efa8b977b8cdcf040 SHA512 44281aba8e5dcf70012a14dd98e21da441c488b440834407313a2a838ca24594b3d25385be98670511bc7b556e53b7d1557cb3f3b9bc6b92e87d0e2c6ecaf362
+MISC metadata.xml 255 BLAKE2B 9b8486730bea2158e8be5cbbe0552c5460d1b18e2236a68e3f11d85ce4eeb96eb0e746f44a10cb7cdcf1bf498190a512ef42f47852c6843b9a3c937ceabc338d SHA512 ac646e8ac676faf0aac283e4be31c5f2b29e98ccf07327073ed05e688ce696caf639bdfea63e4aed141a90e84c0a86892bc717a52b95cdf1739aaa15240013c3
diff --git a/app-officeext/languagetool/languagetool-3.4.ebuild b/app-officeext/languagetool/languagetool-3.4.ebuild
new file mode 100644
index 000000000000..e000f3752945
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-3.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P="LanguageTool-${PV}"
+
+OFFICE_REQ_USE="java"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="https://www.languagetool.org/"
+SRC_URI="https://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
diff --git a/app-officeext/languagetool/languagetool-3.5.ebuild b/app-officeext/languagetool/languagetool-3.5.ebuild
new file mode 100644
index 000000000000..14d714d60ce5
--- /dev/null
+++ b/app-officeext/languagetool/languagetool-3.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_P="LanguageTool-${PV}"
+
+OFFICE_REQ_USE="java"
+
+OFFICE_EXTENSIONS=(
+ "${MY_P}.oxt"
+)
+
+inherit office-ext-r1
+
+DESCRIPTION="Style and Grammar Checker for libreoffice"
+HOMEPAGE="https://www.languagetool.org/"
+SRC_URI="https://www.languagetool.org/download/${MY_P}.oxt"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.8"
diff --git a/app-officeext/languagetool/metadata.xml b/app-officeext/languagetool/metadata.xml
new file mode 100644
index 000000000000..13ce236ee519
--- /dev/null
+++ b/app-officeext/languagetool/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>office@gentoo.org</email>
+ <name>Gentoo Office project</name>
+ </maintainer>
+</pkgmetadata>