summaryrefslogtreecommitdiff
path: root/app-pda/libimobiledevice/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-04 22:28:33 +0100
commita978c074e4272bb901fbe4a10de0a7b2af574f17 (patch)
tree8c764c1cc0576389ce22abd317bceba71ea5732d /app-pda/libimobiledevice/files
parent40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (diff)
gentoo resync : 04.05.2021
Diffstat (limited to 'app-pda/libimobiledevice/files')
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch25
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.3.0-missing_libflags.patch31
-rw-r--r--app-pda/libimobiledevice/files/libimobiledevice-1.3.0-slibtool.patch105
3 files changed, 136 insertions, 25 deletions
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch
deleted file mode 100644
index 0957c9132cbf..000000000000
--- a/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-libressl.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 170e1c445e8c930f4ee9dddfb9f1bcf24c089962 Mon Sep 17 00:00:00 2001
-From: Nikias Bassen <nikias@gmx.li>
-Date: Thu, 6 Aug 2020 20:43:08 +0200
-Subject: [PATCH] idevice: Fix build with LibreSSL
-
-Upstream-Status: Accepted
-[https://github.com/libimobiledevice/libimobiledevice/commit/170e1c445e8c930f4ee9dddfb9f1bcf24c089962]
-Signed-off-by: Stefan Strogin <steils@gentoo.org>
----
- src/idevice.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/idevice.c b/src/idevice.c
-index fea1e03f..47c9ab4d 100644
---- a/src/idevice.c
-+++ b/src/idevice.c
-@@ -1015,7 +1015,7 @@ LIBIMOBILEDEVICE_API idevice_error_t idevice_connection_enable_ssl(idevice_conne
- return ret;
- }
-
--#if OPENSSL_VERSION_NUMBER >= 0x10100000L
-+#if OPENSSL_VERSION_NUMBER >= 0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
- SSL_CTX_set_security_level(ssl_ctx, 0);
- #endif
-
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-missing_libflags.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-missing_libflags.patch
new file mode 100644
index 000000000000..b52bf89355d9
--- /dev/null
+++ b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-missing_libflags.patch
@@ -0,0 +1,31 @@
+From 4b2f17e8cce8fa078aa55f5da5f726c20eac3e2e Mon Sep 17 00:00:00 2001
+From: Nikias Bassen <nikias@gmx.li>
+Date: Tue, 13 Apr 2021 05:36:03 +0200
+Subject: [PATCH] common: Add missing *_LIBS and *_CFLAGS to fix build
+
+---
+ common/Makefile.am | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/common/Makefile.am b/common/Makefile.am
+index 4e3facba..ab01b834 100644
+--- a/common/Makefile.am
++++ b/common/Makefile.am
+@@ -8,12 +8,17 @@ AM_CFLAGS = \
+ $(libplist_CFLAGS) \
+ $(libgnutls_CFLAGS) \
+ $(libtasn1_CFLAGS) \
++ $(libgcrypt_CFLAGS) \
+ $(openssl_CFLAGS) \
+ $(LFS_CFLAGS)
+
+ AM_LDFLAGS = \
+ $(libusbmuxd_LIBS) \
+ $(libplist_LIBS) \
++ $(libgnutls_LIBS) \
++ $(libtasn1_LIBS) \
++ $(libgcrypt_LIBS) \
++ $(openssl_LIBS) \
+ ${libpthread_LIBS}
+
+ noinst_LTLIBRARIES = libinternalcommon.la
diff --git a/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-slibtool.patch b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-slibtool.patch
new file mode 100644
index 000000000000..1e9fa6caf585
--- /dev/null
+++ b/app-pda/libimobiledevice/files/libimobiledevice-1.3.0-slibtool.patch
@@ -0,0 +1,105 @@
+From 735ac51e0eeaa3419e85dbad9579401ae828f631 Mon Sep 17 00:00:00 2001
+From: orbea <orbea@riseup.net>
+Date: Tue, 6 Apr 2021 13:06:35 -0700
+Subject: [PATCH] tools: Fix usage of LDFLAGS and LDADD.
+
+Signed-off-by: orbea <orbea@riseup.net>
+---
+ tools/Makefile.am | 40 ++++++++++++++++++++--------------------
+ 1 file changed, 20 insertions(+), 20 deletions(-)
+
+diff --git a/tools/Makefile.am b/tools/Makefile.am
+index 8ed8ad91..04a5faa7 100644
+--- a/tools/Makefile.am
++++ b/tools/Makefile.am
+@@ -40,8 +40,8 @@ bin_PROGRAMS = \
+
+ ideviceinfo_SOURCES = ideviceinfo.c
+ ideviceinfo_CFLAGS = $(AM_CFLAGS)
+-ideviceinfo_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-ideviceinfo_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++ideviceinfo_LDFLAGS = $(AM_LDFLAGS)
++ideviceinfo_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicename_SOURCES = idevicename.c
+ idevicename_CFLAGS = $(AM_CFLAGS)
+@@ -50,8 +50,8 @@ idevicename_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
+ idevicepair_SOURCES = idevicepair.c
+ idevicepair_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS)
+-idevicepair_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS) $(libusbmuxd_LIBS)
+-idevicepair_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicepair_LDFLAGS = $(AM_LDFLAGS) $(libusbmuxd_LIBS)
++idevicepair_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicesyslog_SOURCES = idevicesyslog.c
+ idevicesyslog_CFLAGS = $(AM_CFLAGS)
+@@ -65,18 +65,18 @@ idevice_id_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
+ idevicebackup_SOURCES = idevicebackup.c
+ idevicebackup_CFLAGS = $(AM_CFLAGS)
+-idevicebackup_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-idevicebackup_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicebackup_LDFLAGS = $(AM_LDFLAGS)
++idevicebackup_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicebackup2_SOURCES = idevicebackup2.c
+ idevicebackup2_CFLAGS = $(AM_CFLAGS)
+-idevicebackup2_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-idevicebackup2_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicebackup2_LDFLAGS = $(AM_LDFLAGS)
++idevicebackup2_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ ideviceimagemounter_SOURCES = ideviceimagemounter.c
+ ideviceimagemounter_CFLAGS = $(AM_CFLAGS)
+-ideviceimagemounter_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-ideviceimagemounter_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++ideviceimagemounter_LDFLAGS = $(AM_LDFLAGS)
++ideviceimagemounter_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicescreenshot_SOURCES = idevicescreenshot.c
+ idevicescreenshot_CFLAGS = $(AM_CFLAGS)
+@@ -95,13 +95,13 @@ idevicedate_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
+ ideviceprovision_SOURCES = ideviceprovision.c
+ ideviceprovision_CFLAGS = $(AM_CFLAGS)
+-ideviceprovision_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-ideviceprovision_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++ideviceprovision_LDFLAGS = $(AM_LDFLAGS)
++ideviceprovision_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicedebugserverproxy_SOURCES = idevicedebugserverproxy.c
+ idevicedebugserverproxy_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS)
+-idevicedebugserverproxy_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-idevicedebugserverproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicedebugserverproxy_LDFLAGS = $(AM_LDFLAGS)
++idevicedebugserverproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicediagnostics_SOURCES = idevicediagnostics.c
+ idevicediagnostics_CFLAGS = $(AM_CFLAGS)
+@@ -110,8 +110,8 @@ idevicediagnostics_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
+ idevicedebug_SOURCES = idevicedebug.c
+ idevicedebug_CFLAGS = $(AM_CFLAGS)
+-idevicedebug_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-idevicedebug_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicedebug_LDFLAGS = $(AM_LDFLAGS)
++idevicedebug_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicenotificationproxy_SOURCES = idevicenotificationproxy.c
+ idevicenotificationproxy_CFLAGS = $(AM_CFLAGS)
+@@ -120,10 +120,10 @@ idevicenotificationproxy_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
+
+ idevicecrashreport_SOURCES = idevicecrashreport.c
+ idevicecrashreport_CFLAGS = -I$(top_srcdir) $(AM_CFLAGS)
+-idevicecrashreport_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-idevicecrashreport_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicecrashreport_LDFLAGS = $(AM_LDFLAGS)
++idevicecrashreport_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la
+
+ idevicesetlocation_SOURCES = idevicesetlocation.c
+ idevicesetlocation_CFLAGS = $(AM_CFLAGS)
+-idevicesetlocation_LDFLAGS = $(top_builddir)/common/libinternalcommon.la $(AM_LDFLAGS)
+-idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la
++idevicesetlocation_LDFLAGS = $(AM_LDFLAGS)
++idevicesetlocation_LDADD = $(top_builddir)/src/libimobiledevice-1.0.la $(top_builddir)/common/libinternalcommon.la