summaryrefslogtreecommitdiff
path: root/app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-18 00:58:25 +0100
commit5e0a5ca921524f8859808527a57655eec16efa52 (patch)
tree7c58411b1e81478df4e20082a6adec2553c24c5c /app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild
parent4c16e0a214824f15f09396e359db4f1f5c086fec (diff)
gentoo auto-resync : 18:07:2023 - 00:58:24
Diffstat (limited to 'app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild')
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild b/app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..e7f3c8e166d5
--- /dev/null
+++ b/app-pda/usbmuxd/usbmuxd-1.1.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd udev
+
+DESCRIPTION="USB multiplex daemon for use with Apple iPhone/iPod Touch devices"
+HOMEPAGE="https://libimobiledevice.org/"
+SRC_URI="https://github.com/libimobiledevice/usbmuxd/releases/download/${PV}/${P}.tar.bz2"
+
+# src/utils.h is LGPL-2.1+, rest is found in COPYING*
+LICENSE="|| ( GPL-2 GPL-3 ) LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="selinux systemd"
+
+DEPEND="
+ acct-user/usbmux
+ >=app-pda/libimobiledevice-1.3.0:=
+ >=app-pda/libplist-2.2:=
+ virtual/libusb:1=
+"
+
+RDEPEND="
+ ${DEPEND}
+ virtual/udev
+ selinux? ( sec-policy/selinux-usbmuxd )
+ systemd? ( sys-apps/systemd )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf \
+ "$(use_with systemd)" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ --with-udevrulesdir="$(get_udevdir)"/rules.d
+}
+
+pkg_postrm() {
+ udev_reload
+}
+
+pkg_postinst() {
+ udev_reload
+}