summaryrefslogtreecommitdiff
path: root/app-portage/command-not-found/command-not-found-0.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-28 11:40:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-28 11:40:46 +0000
commit73c06e01ebc820f47f0140310b8a096e9d20877b (patch)
treee42588135c33dc1c950c2ac5de5dd32897af342b /app-portage/command-not-found/command-not-found-0.0.3.ebuild
parent88f366f99d8e731ae1a13d9eca9a5284484d2c6f (diff)
gentoo auto-resync : 28:02:2024 - 11:40:46
Diffstat (limited to 'app-portage/command-not-found/command-not-found-0.0.3.ebuild')
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-portage/command-not-found/command-not-found-0.0.3.ebuild b/app-portage/command-not-found/command-not-found-0.0.3.ebuild
new file mode 100644
index 000000000000..b0007e526a58
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/AndrewAmmerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/AndrewAmmerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "command-not-found is automatically setup with bash, to use it with zsh add"
+ elog " \"source /etc/bash/bashrc.d/command-not-found.sh\""
+ elog "anywhere in your /etc/zsh/zshrc or ~/.zshrc"
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}