summaryrefslogtreecommitdiff
path: root/app-portage/eix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-portage/eix
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-portage/eix')
-rw-r--r--app-portage/eix/Manifest4
-rw-r--r--app-portage/eix/eix-0.33.11.ebuild107
-rw-r--r--app-portage/eix/eix-0.33.9-r1.ebuild2
3 files changed, 111 insertions, 2 deletions
diff --git a/app-portage/eix/Manifest b/app-portage/eix/Manifest
index f1f6ba946b15..a8807c86e964 100644
--- a/app-portage/eix/Manifest
+++ b/app-portage/eix/Manifest
@@ -1,3 +1,5 @@
+DIST eix-0.33.11.tar.xz 623256 BLAKE2B 756feed85cb4f40ef9228a03d2a8b8470eb6017b00d93b364d67e3d11ecaacce2bb9c6afed388d9f70dfcb7a0b9ece13ca6ee523f5839b7d9bf80cf3b2721524 SHA512 2829d1482abfe479ae71e8b00da07abe74ba3090ba2a3f9d9a93437cb2d4d64213968bcd6c082a6703ec1d9c36dfcfaa0850172f3ffd4d256f553b98eeaf29e6
DIST eix-0.33.9.tar.xz 627944 BLAKE2B cb4add12301a4f08b6ca052df92be34c8a448b386aa700e8ac7e1fbe8563cd76047994007ac94d8989747d843f70a5e1731b401510f58badd9811b30c2ce3be8 SHA512 7539a91d5b5343532ceab1f4aeb82a95413c39b1a57b9e7922032acc937cc8b839494fc40f3510218349561c6d50e89e1861d2fce5e60eabed2465316b28a756
-EBUILD eix-0.33.9-r1.ebuild 2751 BLAKE2B 27c90574b7c05483ceec0d9985ec31988310f54d13a607175855adfc26ea0d46d55bc6a09fb20f129855ca2010253595fedc092b59b9a35c9f2aa6ee65530463 SHA512 3327c42e8156f7f8fbf29fc0844e9e9cda86b69414440891792a2a92d625b8ac30e848a20311cc0586df24523f77b9260b241558182291a96fb4aacca31b4e75
+EBUILD eix-0.33.11.ebuild 2758 BLAKE2B ddc7cac8477ca415c0b7f23e543412e31b2588113c9f43b13fb7021bd127d6ca7f7c3e0f11cd4c34ba83023e05c191fcfd1ad54ebd9c98a7d9176fe87d79164e SHA512 338c4fde1c41bf2f4605cfea0d1fee46b2b381897adbff2fbbb31ddd87bff54de8e081df803345daf98752925d06a81809543bd19ad2a7e7506df8156bafa26d
+EBUILD eix-0.33.9-r1.ebuild 2749 BLAKE2B dac326d96f83bb0f386c9ca28a73886d7a15e3b933c4237af307ded2e2a630232ea941ca5c4d14ca290fc03bcc317820d4debd3935786520cf9cf1682fcecba8 SHA512 c6eb8819f27226a211edf1dfd063877ea91f83b62cd8cffdc8b96d09cb290f4dabbc261ea0015f5faf4841792c39383ae041d5767299788419db0049c4f0c835
MISC metadata.xml 1051 BLAKE2B b77439c3a8d8eab9fc711c96ce2b2ccaf307f2eca4cfee32bfb75279ff4da31fd05b3319136af38e70d274c28cb2f1c2567916390d81425b7b7daf956815c7e4 SHA512 208b3db2b2e5afb5667a29e6b18538f3cea5e3fb2758d3c9b30823d7b2a22f31f150d6a01abec6a6c8ca62486c975b47002de9e1bac89ded31eb7013bdbb38c6
diff --git a/app-portage/eix/eix-0.33.11.ebuild b/app-portage/eix/eix-0.33.11.ebuild
new file mode 100644
index 000000000000..1f78164374e2
--- /dev/null
+++ b/app-portage/eix/eix-0.33.11.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools bash-completion-r1 flag-o-matic tmpfiles
+
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
+SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc nls sqlite"
+
+BOTHDEPEND="nls? ( virtual/libintl )
+ sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+ >=app-shells/push-2.0-r1
+ >=app-shells/quoter-3.0_p2-r1"
+DEPEND="${BOTHDEPEND}
+ app-arch/xz-utils
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ # remove stale cache file to prevent collisions
+ local old_cache=${EROOT}/var/cache/${PN}
+ if [[ -f ${old_cache} ]]; then
+ rm "${old_cache}" || die
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+
+ sed -e "/eixf_source=/s:push.sh:cat \"${EPREFIX}/usr/share/push/push.sh\":" \
+ -e "/eixf_source=/s:quoter_pipe.sh:cat \"${EPREFIX}/usr/share/quoter/quoter_pipe.sh\":" \
+ -i src/eix-functions.sh.in || die
+ sed -e "s:'\$(bindir)/eix-functions.sh':cat \\\\\"${EPREFIX}/usr/share/eix/eix-functions\\\\\":" \
+ -i src/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable debug paranoic-asserts)
+ $(use_enable nls)
+ $(use_with doc extra-doc)
+ $(use_with sqlite)
+
+ # default configuration
+ $(use_with prefix always-accept-keywords)
+ --with-dep-default
+ --with-required-use-default
+
+ # paths
+ --with-portage-rootpath="${ROOTPATH}"
+ --with-eprefix-default="${EPREFIX}"
+
+ # build a single executable with symlinks
+ --disable-separate-binaries
+ --disable-separate-tools
+
+ # used purely to control/disrespect *FLAGS
+ --disable-debugging
+ --disable-new_dialect
+ --disable-optimization
+ --disable-strong-optimization
+ --disable-security
+ --disable-nopie-security
+ --disable-strong-security
+ )
+
+ # https://github.com/vaeth/eix/issues/35
+ append-cxxflags -std=c++14
+
+ # work around https://github.com/vaeth/eix/issues/64, bug#687988
+ local -x mv_fCXXFLAGS_cache='-mindirect-branch=thunk'
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ dobashcomp bash/eix
+ dotmpfiles tmpfiles.d/eix.conf
+
+ rm -r "${ED}"/usr/bin/eix-functions.sh || die
+
+}
+
+pkg_postinst() {
+ tmpfiles_process eix.conf
+
+ local obs=${EROOT}/var/cache/eix.previous
+ if [[ -f ${obs} ]]; then
+ ewarn "Found obsolete ${obs}, please remove it"
+ fi
+}
+
+pkg_postrm() {
+ if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+ rm -rf "${EROOT}/var/cache/${PN}" || die
+ fi
+}
diff --git a/app-portage/eix/eix-0.33.9-r1.ebuild b/app-portage/eix/eix-0.33.9-r1.ebuild
index ca0dba09d33b..d3a156ca40f5 100644
--- a/app-portage/eix/eix-0.33.9-r1.ebuild
+++ b/app-portage/eix/eix-0.33.9-r1.ebuild
@@ -11,7 +11,7 @@ SRC_URI="https://github.com/vaeth/eix/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="debug doc nls sqlite"
BOTHDEPEND="nls? ( virtual/libintl )