summaryrefslogtreecommitdiff
path: root/app-portage/elt-patches/elt-patches-20170422.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-portage/elt-patches/elt-patches-20170422.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-portage/elt-patches/elt-patches-20170422.ebuild')
-rw-r--r--app-portage/elt-patches/elt-patches-20170422.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-portage/elt-patches/elt-patches-20170422.ebuild b/app-portage/elt-patches/elt-patches-20170422.ebuild
new file mode 100644
index 000000000000..ea7235f801ef
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20170422.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-linux ~arm-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt ~x64-cygwin ~x86-cygwin"
+IUSE=""
+
+RDEPEND="sys-apps/gentoo-functions"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" install
+}