summaryrefslogtreecommitdiff
path: root/app-portage/elt-patches/elt-patches-20221210.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-10 09:20:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-10 09:20:14 +0000
commitc15acf374d4b25ba5afcb52435da6090f2d98a20 (patch)
treef3be21d2a949edee4af8b18e1d9ae7501ae5f186 /app-portage/elt-patches/elt-patches-20221210.ebuild
parentcaf79cb4f7c4d5f7cce488d8f50dfb98ddbd09ab (diff)
gentoo auto-resync : 10:12:2022 - 09:20:14
Diffstat (limited to 'app-portage/elt-patches/elt-patches-20221210.ebuild')
-rw-r--r--app-portage/elt-patches/elt-patches-20221210.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-portage/elt-patches/elt-patches-20221210.ebuild b/app-portage/elt-patches/elt-patches-20221210.ebuild
new file mode 100644
index 000000000000..e9ea9fdac84e
--- /dev/null
+++ b/app-portage/elt-patches/elt-patches-20221210.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of patches for libtool.eclass"
+HOMEPAGE="https://gitweb.gentoo.org/proj/elt-patches.git/"
+SRC_URI="https://dev.gentoo.org/~grobian/distfiles/${P}.tar.xz
+ https://dev.gentoo.org/~vapier/dist/${P}.tar.xz
+ https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~arm64-linux ~ppc64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+
+RDEPEND="sys-apps/gentoo-functions"
+BDEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake rootprefix="${EPREFIX}" libdirname="$(get_libdir)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" rootprefix="${EPREFIX}" install
+}