summaryrefslogtreecommitdiff
path: root/app-portage/flaggie
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/flaggie
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/flaggie')
-rw-r--r--app-portage/flaggie/Manifest4
-rw-r--r--app-portage/flaggie/flaggie-0.2.1-r1.ebuild40
-rw-r--r--app-portage/flaggie/flaggie-9999.ebuild40
-rw-r--r--app-portage/flaggie/metadata.xml16
4 files changed, 100 insertions, 0 deletions
diff --git a/app-portage/flaggie/Manifest b/app-portage/flaggie/Manifest
new file mode 100644
index 000000000000..93ea0023c94c
--- /dev/null
+++ b/app-portage/flaggie/Manifest
@@ -0,0 +1,4 @@
+DIST flaggie-0.2.1.tar.bz2 16767 BLAKE2B fea0fbc505bfa97e7bee2c05f0cc19077b9b23a021b01aafa2c4b064466677f9dd4ae95c36f6de65b4ad07c5046d539ceb0cb667dcb791b60410d7a5e688813f SHA512 3f273ebeceaaedce7a3807126fb3f450e420338a883440066d06a4d6a95b63bd538bb5da882fea23e0d390b28a83f50375dbda2624f656327775b2b700f2b2e4
+EBUILD flaggie-0.2.1-r1.ebuild 1183 BLAKE2B 80cf98bc9f217d6f34b40ad3b5acaa7ecdf456f4756b0b717dec3d97424a1383d00d3387d5e4abc8c44aa2e1bda3b6998a598972a49862038fcac383268ca317 SHA512 658d4d06e9a35e4cd39c344716c8f1c3c1021f8d377d26885c244205e5b945818a9ad2e249c6c19424b737cbf4bff318a6488a354a697e1460c62c5554e862e1
+EBUILD flaggie-9999.ebuild 1096 BLAKE2B 160eb996e148481ae0625a866c97e71175b78991eec0acb87f7c7221c202553f4e49df7d8034c873fae8b324a4f1e50ca9ac9ebcb387c1d6423afc843b0fa4cd SHA512 71826a72d278256024ed1fe9c127b3f7eed003c2a79c639bd094dc8aab1b91861c43d3f69e2028b70eea3b279fb31790df5225d9c83ac71a85cec92b730dbec7
+MISC metadata.xml 503 BLAKE2B f86cc20c12e1bf2bfb8d04b6ec0ae1cb66fd4a239cfe41885b1277abc2590fbed0a27dcdad6c0290227f140e4b783ffcbeb8c4556fa4874f0cb4e1d77e691165 SHA512 d406c0b2397c2d40c1aab0db4d4a54c2b928075558c823da63fe21762ed618da5aa20fcfc86c4b3066d8a7bbbc4dcc55d6037025db27a7873de274282dc0a88f
diff --git a/app-portage/flaggie/flaggie-0.2.1-r1.ebuild b/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..6cf9bd001462
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.2.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="https://github.com/mgorny/flaggie/"
+SRC_URI="https://github.com/mgorny/flaggie/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm ~hppa ~mips ~ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "Please denote that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+ elog
+ elog "bash-completion support requires:"
+ elog " app-shells/gentoo-bashcomp"
+ has_version app-shells/gentoo-bashcomp && \
+ elog "(installed already)"
+}
diff --git a/app-portage/flaggie/flaggie-9999.ebuild b/app-portage/flaggie/flaggie-9999.ebuild
new file mode 100644
index 000000000000..b6b4297c035b
--- /dev/null
+++ b/app-portage/flaggie/flaggie-9999.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+EGIT_REPO_URI="https://github.com/mgorny/flaggie.git"
+inherit bash-completion-r1 distutils-r1 git-r3
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="https://github.com/mgorny/flaggie/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ || (
+ sys-apps/portage[${PYTHON_USEDEP}]
+ sys-apps/portage-mgorny[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ newbashcomp contrib/bash-completion/${PN}.bash-completion ${PN}
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ ewarn "Please note that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+ if ! has_version app-shells/gentoo-bashcomp; then
+ elog
+ elog "If you want to use bash-completion, you need to install:"
+ elog " app-shells/gentoo-bashcomp"
+ fi
+}
diff --git a/app-portage/flaggie/metadata.xml b/app-portage/flaggie/metadata.xml
new file mode 100644
index 000000000000..f4ff1e6030fa
--- /dev/null
+++ b/app-portage/flaggie/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <maintainer status="active">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <bugs-to>https://github.com/mgorny/flaggie/issues/</bugs-to>
+ <remote-id type="github">mgorny/flaggie</remote-id>
+ </upstream>
+</pkgmetadata>