summaryrefslogtreecommitdiff
path: root/app-portage/gentle/gentle-0.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-02 22:04:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-02 22:04:01 +0100
commita55e5c074db9bb024358a8f0bd2c5e992b7cf6f6 (patch)
treeee290879083a50ef99b06b22b9b3e46e38e281b5 /app-portage/gentle/gentle-0.3.1.ebuild
parent8164a4e49d69b936f2d820456e48468dc0e241ad (diff)
gentoo auto-resync : 02:07:2023 - 22:04:01
Diffstat (limited to 'app-portage/gentle/gentle-0.3.1.ebuild')
-rw-r--r--app-portage/gentle/gentle-0.3.1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-portage/gentle/gentle-0.3.1.ebuild b/app-portage/gentle/gentle-0.3.1.ebuild
new file mode 100644
index 000000000000..b24f526fe46e
--- /dev/null
+++ b/app-portage/gentle/gentle-0.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=flit
+PYPI_PN="gentle-mxml"
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Gentoo Lazy Entry - a metadata.xml generator"
+HOMEPAGE="
+ https://gentle.sysrq.in
+ https://pypi.org/project/gentle-mxml/
+"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ app-text/xmldiff[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/rdflib[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep \
+ 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
+ )
+"
+
+distutils_enable_tests pytest
+
+distutils_enable_sphinx docs \
+ dev-python/insipid-sphinx-theme \
+ dev-python/sphinx-prompt
+
+pkg_postinst() {
+ optfeature "PKG-INFO support" dev-python/pkginfo
+ optfeature "yaml support" dev-python/pyyaml
+ optfeature "rdf support" dev-python/rdflib
+ optfeature "toml support" dev-python/tomli
+}