summaryrefslogtreecommitdiff
path: root/app-portage/gentle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-30 00:00:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-30 00:00:01 +0100
commit4c2b70adc6484c35ff05e412de08a7b7f50cfb34 (patch)
treec7557ae36b9b2bfa7134849511e79da938581c5f /app-portage/gentle
parent5f0030fd1370c4d03dbb2e0d3086f5e618a33749 (diff)
gentoo auto-resync : 30:04:2024 - 00:00:01
Diffstat (limited to 'app-portage/gentle')
-rw-r--r--app-portage/gentle/Manifest4
-rw-r--r--app-portage/gentle/gentle-1.0.0.ebuild (renamed from app-portage/gentle/gentle-0.3.1.ebuild)19
2 files changed, 16 insertions, 7 deletions
diff --git a/app-portage/gentle/Manifest b/app-portage/gentle/Manifest
index bc29e0dd9bc9..a0fc46fc4b36 100644
--- a/app-portage/gentle/Manifest
+++ b/app-portage/gentle/Manifest
@@ -1,5 +1,5 @@
-DIST gentle_mxml-0.3.1.tar.gz 141735 BLAKE2B 6720ff9af32d83beac66e5e8fc71cc33a7554edb000b835d4f770da199806ebfbc3bdd95954b738f21768da6b6f8315cb870e2185b8066d5f69cad85128f60ec SHA512 4722e37c635d7f1b492bf52f3f4003deda1ba65c79be56228009875241048d6976b38e836e62f6d90adb8ec1bc545ff903487759ad581ffc0bb2e371d25dd780
DIST gentle_mxml-0.4.0.tar.gz 329273 BLAKE2B baf6d954838d6cd2fc9548aaa33c85cb53307b325521a2fe300486a2cc08e833f835016ba632b484c1068c7deee3b2eeb17606f0180d248081304fa866b79461 SHA512 beac2c7bd3e4d80448fec5a633502e6cdc763145541b9205e3c354597b4e9c724f94cadb747b87df3c49669f5534cc9d123ded00b45b9cb783cd4e086a9b3ceb
-EBUILD gentle-0.3.1.ebuild 987 BLAKE2B 25e6ecfe4e0e1670767a551bb68ff60f79c9421c89d01b4af025187056b013366ea726999fa6e2a12f8a82699135c9659e2d1201786c29b90b3ce5448e7a25b0 SHA512 0563946dc237f41923b96b8847d47635e2bd6b282dcd07d56a6fdbee2cbeaf54b0d4777196694b3263dc469a82c0381a268e703478b3c5dbb65ee808f0fcf152
+DIST gentle_mxml-1.0.0.tar.gz 356588 BLAKE2B bb5eddfd91876226cad27c6e2b06ac60926c7f1075c3c6838b2abf262b9a7ec7740083e8397a3980174d83d3c2b6fff67772adf2454fb11892a1624d27ebf533 SHA512 fdd9399545e6613b932de3bfc093815019941fcbba1535384a77431259320b478cd4a020ea3d657f1bf2a296a8f788fb9a08bc1c917b3c59e06d2a237f22a91a
EBUILD gentle-0.4.0.ebuild 1303 BLAKE2B b80df2f448356aa63e5379f9da01882d9dd94640c6626af72f4a5fdc7e934bd15ca932a0a19dc5738b3462acf21bd04ad6f6b39c8b3f3bc203ed566adca836db SHA512 7fd63fcdf5f898b48c676d935fa675673541ff4dc8d664d0b22dce1deb704fb555096ad2b59e72b2c3d3430e6c5e46ee7b53a6017a38ced190e5bb32712d2ec3
+EBUILD gentle-1.0.0.ebuild 1146 BLAKE2B c3d5b91c22cf49c7e05592ede043817734e9df72cff802294758944e57a4f0db555e2ec7df3f1b4c4bbddcfbcbef0273838b15d387e3f109c99f0bc7b36e341b SHA512 bf347eccda0101ad48ff8e69cc67b208ee5c334c255c9d41886fe8196ae197f8e4bd06101ad167300cd3d3c88e55bfd0d0aa07ad5bc13413a1b7681fd6fb27d3
MISC metadata.xml 422 BLAKE2B fddbe79d2169a174b500b7ac06e5ef7995d3e1a73a0db6b7e31e4365f276f8607a9e3b063454331b91c2da48ef39cda414cdf1c89c1d1035d47c60a721c51332 SHA512 31752bb8ab20266c285d90ddb665b9df873e3839d8f5e3d214ff719f6d6dadc95f72408c0b872e2258ea7a61960443640e3f1b7221b7814f2031a395a68a787d
diff --git a/app-portage/gentle/gentle-0.3.1.ebuild b/app-portage/gentle/gentle-1.0.0.ebuild
index b24f526fe46e..1185c8483539 100644
--- a/app-portage/gentle/gentle-0.3.1.ebuild
+++ b/app-portage/gentle/gentle-1.0.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2023 Gentoo Authors
+# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{11..12} )
DISTUTILS_USE_PEP517=flit
PYPI_PN="gentle-mxml"
inherit distutils-r1 optfeature pypi
@@ -18,14 +18,19 @@ LICENSE="WTFPL-2"
SLOT="0"
KEYWORDS="~amd64"
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+"
BDEPEND="
test? (
app-text/xmldiff[${PYTHON_USEDEP}]
+ dev-lang/perl
+ dev-lang/ruby:*
+ >=dev-python/build-1.2.0[${PYTHON_USEDEP}]
dev-python/pkginfo[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
dev-python/rdflib[${PYTHON_USEDEP}]
- $(python_gen_cond_dep \
- 'dev-python/tomli[${PYTHON_USEDEP}]' 3.10)
)
"
@@ -35,9 +40,13 @@ distutils_enable_sphinx docs \
dev-python/insipid-sphinx-theme \
dev-python/sphinx-prompt
+python_test() {
+ epytest --with-perl --with-ruby
+}
+
pkg_postinst() {
+ optfeature "python packaging support" dev-python/build
optfeature "PKG-INFO support" dev-python/pkginfo
optfeature "yaml support" dev-python/pyyaml
optfeature "rdf support" dev-python/rdflib
- optfeature "toml support" dev-python/tomli
}