summaryrefslogtreecommitdiff
path: root/app-portage/getuto/getuto-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-19 15:38:48 +0100
commit3b882b15eed3bb219b5f340b63733c8cda643079 (patch)
treec84890953bd9a939137323d667a7762da89f0f0c /app-portage/getuto/getuto-9999.ebuild
parent4d9aef45678c7cb55b24107642790224ab8c153b (diff)
gentoo auto-resync : 19:08:2023 - 15:38:48
Diffstat (limited to 'app-portage/getuto/getuto-9999.ebuild')
-rw-r--r--app-portage/getuto/getuto-9999.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-portage/getuto/getuto-9999.ebuild b/app-portage/getuto/getuto-9999.ebuild
new file mode 100644
index 000000000000..860cc3595dd0
--- /dev/null
+++ b/app-portage/getuto/getuto-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Stand-alone gentoo install trust anchor generation tool"
+HOMEPAGE="https://github.com/projg2/getuto"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/projg2/getuto"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/projg2/getuto/archive/refs/tags/${P}.tar.gz
+ "
+ S=${WORKDIR}/${PN}-${P}
+
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+SRC_URI+=" test? ( https://mirror.bytemark.co.uk/gentoo/releases/amd64/binpackages/17.1/x86-64/virtual/libc/libc-1-r1-1.gpkg.tar )"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ app-crypt/gnupg
+ dev-libs/openssl
+ sec-keys/openpgp-keys-gentoo-release
+"
+
+src_unpack() {
+ if [[ ${PV} == 9999 ]] ; then
+ git-r3_src_unpack
+ else
+ # Don't mangle test data
+ unpack ${P}.tar.gz
+ fi
+
+ if use test ; then
+ cp "${DISTDIR}"/libc-1-r1-1.gpkg.tar "${S}" || die
+ fi
+}
+
+src_install() {
+ dobin getuto
+}