summaryrefslogtreecommitdiff
path: root/app-portage/prefix-chain-setup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-09 09:27:03 +0100
commitcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (patch)
tree047fc92023c520d07f13ec5ac96e094d1b312a7a /app-portage/prefix-chain-setup
parent7b9f15840068dfaeea5684f8a1af1fe460dfa14c (diff)
gentoo resync : 09.06.2018
Diffstat (limited to 'app-portage/prefix-chain-setup')
-rw-r--r--app-portage/prefix-chain-setup/Manifest1
-rw-r--r--app-portage/prefix-chain-setup/prefix-chain-setup-0.5.ebuild222
2 files changed, 0 insertions, 223 deletions
diff --git a/app-portage/prefix-chain-setup/Manifest b/app-portage/prefix-chain-setup/Manifest
index 1001c4e6bde0..3f43c3d7242c 100644
--- a/app-portage/prefix-chain-setup/Manifest
+++ b/app-portage/prefix-chain-setup/Manifest
@@ -1,4 +1,3 @@
-EBUILD prefix-chain-setup-0.5.ebuild 6100 BLAKE2B 510539b5ece6329716c9a5c71fb0e03ad62577c75102e4354eaf88da839e6c0cbc24300241345a5a4635fceba56551011843c1c4fe01860af3034e28e1ef5909 SHA512 3e9251e974ccddfbeb4f4bb4fd408fff566fdb02b3a48fc61d60c745eba80324500d113c685fcf072e496ac871b4d2b8d89c8d99e80d0d27e752e3ab73e1ab07
EBUILD prefix-chain-setup-0.6.ebuild 6123 BLAKE2B 57a80f622d81f428304a4c2f06aaf719042eca5269dea2f806219bb8fadbfc25fa00d3f8ab4c6fbfe0096e4290313c1a38b6278874ed6acd87d016402038ecc0 SHA512 300c8ad213b746d5c62d07bbb918c6a3370184221d57b5dd3b19ea475c00aa22a7e0acf75cf40b8eab04e71e1fb58562c073964e7c77b747860c947cba15d602
EBUILD prefix-chain-setup-0.7.ebuild 6610 BLAKE2B e5b50102a64ec9e70ba8c9a3f3ac63e94738aaffd9390978a4d2def8446a52cea5fb9367109a8fbfbb1a95c5f7390447907ebdbc856714cf81f8d2ab79df00b8 SHA512 ee6013082cf657586aeac0261f7cab46bfff1b66190f70cc0b3cc842d7803ae246d25b41c18a0f94954c48d8da6ba51bf04174418b81ad43567c4f9ee1e200ba
MISC metadata.xml 243 BLAKE2B d650658b3e248940751d20c9e517a011a34f8d99df54d5203162d67c21df384f507e44ed0c848c1adc99fae8d511e204129f2709f5bdc5d1b2c8e41120bbe6db SHA512 8489be9ea6eac385511b0d193b1b61fad9c8e0d4cb86fd711e6faf04e66b2c935ae64ce6ce0a044d036e76de6787e5d440d67f831e89261a71e74b645a0999d9
diff --git a/app-portage/prefix-chain-setup/prefix-chain-setup-0.5.ebuild b/app-portage/prefix-chain-setup/prefix-chain-setup-0.5.ebuild
deleted file mode 100644
index a078612d6aad..000000000000
--- a/app-portage/prefix-chain-setup/prefix-chain-setup-0.5.ebuild
+++ /dev/null
@@ -1,222 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=0
-
-inherit prefix
-
-DESCRIPTION="Chained EPREFIX bootstrapping utility"
-HOMEPAGE="https://dev.gentoo.org/~mduft"
-SRC_URI=""
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~ppc-aix ~x64-cygwin ~x86-linux ~sparc-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-src_install() {
- eprefixify ${PN}
- sed -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST}," -i ${PN}
- dobin ${PN}
-}
-
-src_unpack() {
- { cat > "${PN}" || die; } <<'EOF'
-#!/usr/bin/env bash
-
-PARENT_EPREFIX="@GENTOO_PORTAGE_EPREFIX@"
-PARENT_CHOST="@GENTOO_PORTAGE_CHOST@"
-CHILD_EPREFIX=
-CHILD_PROFILE=
-DO_MINIMAL=no
-DO_SOURCES=no
-PORT_TMPDIR=
-
-#
-# get ourselfs the functions.sh script for ebegin/eend/etc.
-#
-for f in \
- /lib/gentoo/functions.sh \
- /etc/init.d/functions.sh \
- /sbin/functions.sh \
-; do
- if [[ -r ${PARENT_EPREFIX}${f} ]]; then
- . "${PARENT_EPREFIX}${f}"
- f=found
- break
- fi
-done
-
-if [[ ${f} != found ]]; then
- echo "Cannot find Gentoo functions, aborting." >&2
- exit 1
-fi
-
-for arg in "$@"; do
- case "${arg}" in
- --eprefix=*) CHILD_EPREFIX="${arg#--eprefix=}" ;;
- --profile=*) CHILD_PROFILE="${arg#--profile=}" ;;
- --sources) DO_SOURCES=yes ;;
- --portage-tmpdir=*) PORT_TMPDIR="${arg#--portage-tmpdir=}" ;;
-
- --help)
- einfo "$0 usage:"
- einfo " --eprefix=[PATH] Path to new EPREFIX to create chained to the prefix"
- einfo " where this script is installed (${PARENT_EPREFIX})"
- einfo " --profile=[PATH] The absolute path to the profile to use. This path"
- einfo " must point to a directory within ${PARENT_EPREFIX}"
- einfo " --sources inherit 'source' statements from the parent make.conf"
- einfo " --portage-tmpdir=DIR use DIR as portage temporary directory."
- exit 0
- ;;
- esac
-done
-
-#
-# sanity check of given values
-#
-
-test -n "${CHILD_EPREFIX}" || { eerror "no eprefix argument given"; exit 1; }
-test -d "${CHILD_EPREFIX}" && { eerror "${CHILD_EPREFIX} already exists"; exit 1; }
-test -n "${CHILD_PROFILE}" || { eerror "no profile argument given"; exit 1; }
-test -d "${CHILD_PROFILE}" || { eerror "${CHILD_PROFILE} does not exist"; exit 1; }
-if test -n "${PORT_TMPDIR}"; then
- if ! test -d "${PORT_TMPDIR}"; then
- einfo "creating temporary directory ${PORT_TMPDIR}"
- mkdir -p "${PORT_TMPDIR}"
- fi
-fi
-
-einfo "creating chained prefix ${CHILD_EPREFIX}"
-
-#
-# functions needed below.
-#
-eend_exit() {
- eend $1
- [[ $1 != 0 ]] && exit 1
-}
-
-#
-# create the directories required to bootstrap the least.
-#
-ebegin "creating directory structure"
-(
- set -e
- mkdir -p "${CHILD_EPREFIX}"/etc/portage
- mkdir -p "${CHILD_EPREFIX}"/var/log
-)
-eend_exit $?
-
-#
-# create a make.conf and set PORTDIR and PORTAGE_TMPDIR
-#
-ebegin "creating make.conf"
-(
- set -e
- echo "#"
- echo "# The following values where taken from the parent prefix's"
- echo "# environment. Feel free to adopt them as you like."
- echo "#"
- echo "CFLAGS=\"$(portageq envvar CFLAGS)\""
- echo "CXXFLAGS=\"$(portageq envvar CXXFLAGS)\""
- echo "MAKEOPTS=\"$(portageq envvar MAKEOPTS)\""
- niceness=$(portageq envvar PORTAGE_NICENESS || true)
- [[ -n ${niceness} ]] &&
- echo "PORTAGE_NICENESS=\"${niceness}\""
- echo "USE=\"prefix-chaining\""
- echo
- echo "# Mirrors from parent prefix."
- echo "GENTOO_MIRRORS=\"$(portageq envvar GENTOO_MIRRORS || true)\""
- echo
- echo "#"
- echo "# Below comes the chained-prefix setup. Only change things"
- echo "# if you know exactly what you are doing!"
- echo "# by default, only DEPEND is inherited from the parent in"
- echo "# the chain. if you want more, make it a comma seperated"
- echo "# list - like this: DEPEND,RDEPEND,PDEPEN - which would the"
- echo "# all that is possible"
- echo "#"
- echo "PORTDIR=\"$(portageq envvar PORTDIR)\""
- echo "SYNC=\"$(portageq envvar SYNC || true)\""
- if test -z "${PORT_TMPDIR}"; then
- case "${CHILD_PROFILE}" in
- *winnt*) echo "PORTAGE_TMPDIR=/var/tmp" ;;
- *) echo "PORTAGE_TMPDIR=\"${CHILD_EPREFIX}/var/tmp\"" ;;
- esac
- else
- echo "PORTAGE_TMPDIR=\"${PORT_TMPDIR}\""
- fi
- echo "READONLY_EPREFIX=\"${PARENT_EPREFIX}:DEPEND\""
-
- if test "${DO_SOURCES}" == "yes"; then
- # don't fail if nothing found
- for f in /etc/portage/make.conf /etc/make.conf; do
- if [[ -r ${PARENT_EPREFIX}${f} ]]; then
- egrep "^source .*" "${PARENT_EPREFIX}${f}" 2>/dev/null || true
- break;
- fi
- done
- fi
-) > "${CHILD_EPREFIX}"/etc/portage/make.conf
-eend_exit $?
-
-#
-# create the make.profile symlinks.
-#
-ebegin "creating make.profile"
-(
- ln -s "${CHILD_PROFILE}" "${CHILD_EPREFIX}/etc/portage/make.profile"
-)
-eend_exit $?
-
-#
-# adjust permissions of generated files.
-#
-ebegin "adjusting permissions"
-(
- chmod 644 "${CHILD_EPREFIX}"/etc/portage/make.conf
-)
-eend_exit $?
-
-#
-# now merge some basics.
-#
-ebegin "installing required basic packages"
-(
- # this -pv is there to avoid the global update output, which is
- # there on the first emerge run. (thus, just cosmetics).
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -p1qO baselayout-prefix > /dev/null 2>&1
-
- set -e
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -1qO gentoo-functions baselayout-prefix prefix-chain-utils
-
- # merge with the parent's chost. this forces the use of the parent
- # compiler, which generally would be illegal - this is an exception.
- # This is required for example on winnt, because the wrapper has to
- # be able to use/resolve symlinks, etc. native winnt binaries miss that
- # ability, but interix binaries don't.
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" CHOST="${PARENT_CHOST}" emerge -1qO gcc-config
-
- # select the chain wrapper profile from gcc-config
- env -i "$(type -P bash)" "${CHILD_EPREFIX}"/usr/bin/gcc-config 1
-
- # do this _AFTER_ selecting the correct compiler!
- PORTAGE_CONFIGROOT="${CHILD_EPREFIX}" EPREFIX="${CHILD_EPREFIX}" emerge -1qO libtool
-)
-eend_exit $?
-
-#
-# wow, all ok :)
-#
-ewarn
-ewarn "all done. don't forget to tune ${CHILD_EPREFIX}/etc/portage/make.conf."
-ewarn "to enter the new prefix, run \"${CHILD_EPREFIX}/startprefix\"."
-ewarn
-EOF
-}