summaryrefslogtreecommitdiff
path: root/app-portage/repoman/repoman-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-portage/repoman/repoman-9999.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-portage/repoman/repoman-9999.ebuild')
-rw-r--r--app-portage/repoman/repoman-9999.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-portage/repoman/repoman-9999.ebuild b/app-portage/repoman/repoman-9999.ebuild
index 5db2b94f6761..0ba9ff39dfda 100644
--- a/app-portage/repoman/repoman-9999.ebuild
+++ b/app-portage/repoman/repoman-9999.ebuild
@@ -3,8 +3,8 @@
EAPI=7
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
PYTHON_REQ_USE='bzip2(+)'
inherit distutils-r1
@@ -26,13 +26,14 @@ SLOT="0"
IUSE=""
RDEPEND="
- >=sys-apps/portage-3.0.4[${PYTHON_USEDEP}]
+ >=sys-apps/portage-3.0.18[${PYTHON_USEDEP}]
>=dev-python/lxml-3.6.0[${PYTHON_USEDEP}]
dev-python/pyyaml[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
python_test() {
+ unset REPOMAN_DEFAULT_OPTS
esetup.py test
}