summaryrefslogtreecommitdiff
path: root/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild')
-rw-r--r--app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
new file mode 100644
index 000000000000..c8a7533d0933
--- /dev/null
+++ b/app-portage/smart-live-rebuild/smart-live-rebuild-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
+inherit distutils-r1 git-r3
+
+DESCRIPTION="Check live packages for updates and emerge them as necessary"
+HOMEPAGE="https://github.com/mgorny/smart-live-rebuild/"
+SRC_URI=""
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-portage/gentoopm-0.2.1[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ insinto /etc/portage
+ newins smart-live-rebuild.conf{.example,}
+ insinto /usr/share/portage/config/sets
+ newins sets.conf.example smart-live-rebuild.conf
+}