summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
commit483d7c056fba15727fe24545f93627a1d1e1e2eb (patch)
tree80d144b60f8e1dc0d14c15cb3e5950da12c80074 /app-portage
parent8796aaedb3257bbe4d80b0033408b2210b2259d6 (diff)
gentoo auto-resync : 18:10:2024 - 04:04:23
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9594 -> 9590 bytes
-rw-r--r--app-portage/command-not-found/Manifest4
-rw-r--r--app-portage/command-not-found/command-not-found-0.0.7.ebuild40
-rw-r--r--app-portage/command-not-found/metadata.xml2
4 files changed, 44 insertions, 2 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index 6c00d22c9baf..2a3e45fe7030 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/command-not-found/Manifest b/app-portage/command-not-found/Manifest
index 6f09f16b8b0a..6b3dfcccb5fd 100644
--- a/app-portage/command-not-found/Manifest
+++ b/app-portage/command-not-found/Manifest
@@ -1,3 +1,5 @@
DIST command-not-found-0.0.6.tar.gz 10290 BLAKE2B 352a77790539acca9d54902e8078b580a5f4a789d61c395944363b4a42f8750cd518e3d8a22f69c409c8ab090cf6345677c324f3faa1e67071439cd6f600c7a3 SHA512 9396b7cb1cbcbc53047928ede0f77613e7f5ad3d5855f6476c40642c52a419aa6227e9b329d8d73d267fbd946e36f21740420ea854555025ddd2ea7eb1dbcec2
+DIST command-not-found-0.0.7.tar.gz 10310 BLAKE2B 02ff8cd66f7aa39bc4990eb57cbf84a83fb37af72cf8c231e89e77b9859f1668edb8ac6be2d606643b7b54dda00b2df47de8c64afa933f208cd8bf6cc0245a1c SHA512 95cc7a2237928fac0015f21529697d6f878c9c756800d30c435b1cd2116cb522020eb63896fcd1f32091944969f07c4811d8a2d7fa1f1c36d54728bd582c44a1
EBUILD command-not-found-0.0.6.ebuild 1120 BLAKE2B c7bdb52ac03b13c512366d916eb5891a42519aa3887856e0525a7ec6ae3161b5098641b501469f10f3be21c6a776af2bc165fe538925adf09477d2610b429126 SHA512 b0d95226e796512346cc195c41f82fd2b3769665cac1688bad83b92723a717e3ed976a58a8340760f3ac082fabfa6d4ae7caa241261acdaffcd66a01d104f716
-MISC metadata.xml 388 BLAKE2B 68d4cf665b154331bff48ea9c1cc0b68eea52cd82788f8cbe5e12907206036fb98ae8248738c34c6c221041055129e17aace5d47bd482b4cf27f36d09743b8c8 SHA512 08b5b851ffa5774aef0c2f0e6e7d3fb180492e898ab3197ce15e79a77ab04f7aa12e9213cb369998e48173af4a447ca94e9c5a61324771ad7d9ca2d1a4f5de80
+EBUILD command-not-found-0.0.7.ebuild 1126 BLAKE2B 406a7ea5cea082f2027634c1cbacf1c7bbc09c36aab7b0a1eb34ea37c356b7915899105f819ee87ab24cabd1fefe7811ced0de9aadc359c76d46a01f2459c42b SHA512 1a3b76e63c9d71c6392b016d4793e91ad1a3a914b97a95c95b37168af6c07335a7d36547b83bc006f31f35190601412439ea40d510768453fe513db4c53fb1cc
+MISC metadata.xml 387 BLAKE2B 4043ba444f514ec4d906c0f789f45fbf6c7632c35dc8c6a42955f055ac8cc5865cbb860d28b8c5d2a49e12b3f903c7c4924b882ac4694c94c39c344d8e96d819 SHA512 498a2330d76d51545cbd067320c7d786138904be1e3aa3037184f6e12aceaab1bc385a787328a91c416a722fce08ba2d3bc46fce0eceefb657d9fc76c3fde1a6
diff --git a/app-portage/command-not-found/command-not-found-0.0.7.ebuild b/app-portage/command-not-found/command-not-found-0.0.7.ebuild
new file mode 100644
index 000000000000..acc0acee7cde
--- /dev/null
+++ b/app-portage/command-not-found/command-not-found-0.0.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit optfeature python-r1
+
+DESCRIPTION="Command-not-found handler for Gentoo"
+HOMEPAGE="https://github.com/Nowa-Ammerlaan/command-not-found-gentoo"
+SRC_URI="https://github.com/Nowa-Ammerlaan/command-not-found-gentoo/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-gentoo-${PV}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}"
+
+src_install() {
+ python_foreach_impl python_doscript command-not-found
+
+ insinto /etc/bash/bashrc.d
+ doins command-not-found.sh
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "${PN} is automatically setup for app-shells/bash, see"
+ elog " /usr/share/doc/${PF}/README.md"
+ elog "for instructions on how to set it up for various other shells."
+ elog
+ optfeature "suggesting snaps providing the missing command" "app-containers/snapd"
+ optfeature "suggesting ebuilds providing the missing command" "app-portage/pfl"
+}
diff --git a/app-portage/command-not-found/metadata.xml b/app-portage/command-not-found/metadata.xml
index 87d84e421471..16d7d6dca53f 100644
--- a/app-portage/command-not-found/metadata.xml
+++ b/app-portage/command-not-found/metadata.xml
@@ -6,7 +6,7 @@
<name>Andrew Ammerlaan</name>
</maintainer>
<upstream>
- <remote-id type="github">AndrewAmmerlaan/command-not-found-gentoo</remote-id>
+ <remote-id type="github">Nowa-Ammerlaan/command-not-found-gentoo</remote-id>
</upstream>
<stabilize-allarches/>
</pkgmetadata>