summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-14 06:41:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-14 06:41:38 +0000
commit6e1fc32629c46e29012a7e22b07085307d65ac96 (patch)
tree3a10753f21f24b2f29706bc4c28b1074119343d8 /app-portage
parent4b1d73e089a436406c89fadc33638314981c44e6 (diff)
gentoo auto-resync : 14:01:2025 - 06:41:37
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9751 -> 9755 bytes
-rw-r--r--app-portage/prefix-toolkit/Manifest2
-rw-r--r--app-portage/prefix-toolkit/prefix-toolkit-11.ebuild169
3 files changed, 171 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index 49308566214e..7b958dd3f027 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/prefix-toolkit/Manifest b/app-portage/prefix-toolkit/Manifest
index cb9d3eabd60a..00ae7ada161d 100644
--- a/app-portage/prefix-toolkit/Manifest
+++ b/app-portage/prefix-toolkit/Manifest
@@ -1,3 +1,5 @@
DIST prefix-toolkit-10.tar.bz2 5715 BLAKE2B fe8b4642fc4f8fa97bd8c9dc4f9e907dd0ca464ddc20e28d2888354f766fce04dd6ebc3bfae23bc776c59986c8167cc94510fb950124917874c5dde4f68cddfe SHA512 58f7fabab8ce5e2c3b2f0725733d02e340efb714ecf3556c27dbe95e7cf9c4b2f4ae658c44749cf2c62111d1135c60c333bbf93ee1c7b79ea11b908cc923c730
+DIST prefix-toolkit-11.tar.bz2 5733 BLAKE2B 8077fb9c5a669d45ebec6e088d7770e149d1816db779828155857b5c5f3f90cfcc049194b683753feec997121409513a16b7f9f0b1757eabf1c011386145c018 SHA512 50e509f2c5a8cf6764820baa4d649cdb4f8a45529b116a508520cb9244f4fd6dbb728216ba853b15d118b7c7171f8913cdf7b05f84263b433f128f1f76758c3a
EBUILD prefix-toolkit-10-r1.ebuild 4443 BLAKE2B 222a1144f547bb775c21631812edc525e978f14afbcc65b5ed28413eac1a7ccd056b24e9e36010f64f09789a1415478a9b1943487a1a8bf3977776dbb39f182a SHA512 611fc11836734896d1193db04cf053e3ea668a0a4e665ef72db500d26e961a58af868c2f1e07776690f6ae5b8f3cc6e0bd1464c6b9e6813ffe2bd29b696ea408
+EBUILD prefix-toolkit-11.ebuild 4443 BLAKE2B 222a1144f547bb775c21631812edc525e978f14afbcc65b5ed28413eac1a7ccd056b24e9e36010f64f09789a1415478a9b1943487a1a8bf3977776dbb39f182a SHA512 611fc11836734896d1193db04cf053e3ea668a0a4e665ef72db500d26e961a58af868c2f1e07776690f6ae5b8f3cc6e0bd1464c6b9e6813ffe2bd29b696ea408
MISC metadata.xml 339 BLAKE2B 96b3655ac41cc800d2b100d19f9dfcd3bc7f2db133afc2463b5d952002960985e405909a29f12614d36682983ace78d93d7f6f412ee0eb152ee9eee99856a7e1 SHA512 629e45611cde94696213ca5883eda9a399a46a1e6c1777b0039d9d54f2ba8db5c85aff38a4378f5b8246ca2b7c46a6bd0c0bc3ea434b45b294d8d309bd074ccd
diff --git a/app-portage/prefix-toolkit/prefix-toolkit-11.ebuild b/app-portage/prefix-toolkit/prefix-toolkit-11.ebuild
new file mode 100644
index 000000000000..1a2fcf041b1b
--- /dev/null
+++ b/app-portage/prefix-toolkit/prefix-toolkit-11.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Utilities for users of Gentoo Prefix"
+HOMEPAGE="https://prefix.gentoo.org/"
+SRC_URI="https://gitweb.gentoo.org/proj/prefix/prefix-toolkit.git/snapshot/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+
+[[ ${PV} == 9999 ]] ||
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~riscv-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND=""
+BDEPEND="${DEPEND}
+ >sys-apps/portage-2.3.62
+"
+# In prefix-stack, these dependencies actually are the @system set,
+# as we rely on the base prefix anyway for package management,
+# which should have a proper @system set.
+# Strictly speaking, only baselayout and gcc-config are necessary, but
+# it is easier for now to install elt-patches, gentoo-functions and
+# gnuconfig as well, instead of fixing all uses that expect them in
+# EPREFIX rather than BROOT.
+# See also: pkg_preinst
+RDEPEND="${DEPEND}
+ prefix-stack? (
+ sys-devel/gcc-config
+ app-portage/elt-patches
+ sys-apps/gentoo-functions
+ sys-devel/gnuconfig
+ )
+"
+
+src_unpack() {
+ default
+
+ if use prefix-stack ; then
+ local editor pager
+ for editor in "${EDITOR}" {"${EPREFIX}","${BROOT}"}/bin/nano
+ do
+ [[ -x ${editor} ]] || continue
+ done
+ for pager in "${PAGER}" {"${EPREFIX}","${BROOT}"}/usr/bin/less
+ do
+ [[ -x ${pager} ]] || continue
+ done
+ printf '%s\n' "EDITOR=\"${editor}\"" "PAGER=\"${pager}\"" > 000fallback
+ fi
+}
+
+my_prefixify() {
+ local ebash eenv
+ if use prefix-stack ; then
+ ebash="${BROOT}/bin/bash"
+ eenv="${BROOT}/usr/bin/env"
+ else
+ ebash="${EPREFIX}/bin/bash"
+ eenv="${EPREFIX}/usr/bin/env"
+ fi
+
+ # the @=@ prevents repoman from believing we set readonly vars
+ sed -e "s,@GENTOO_PORTAGE_BPREFIX@,${BROOT},g" \
+ -e "s,@GENTOO_PORTAGE_EPREFIX@,${EPREFIX},g" \
+ -e "s,@GENTOO_PORTAGE_CHOST@,${CHOST},g" \
+ -e "s,@GENTOO_PORTAGE_EBASH@,${ebash},g" \
+ -e "s,@GENTOO_PORTAGE_EENV@,${eenv},g" \
+ -e "s,@=@,=,g" \
+ -i "$@" || die
+}
+
+src_configure() {
+ # do not eprefixify during unpack, to allow userpatches to apply
+ my_prefixify *
+}
+
+src_install-prefix-stack-ccwrap() {
+ # install toolchain wrapper.
+ local wrapperdir=/usr/${CHOST}/gcc-bin/${CHOST}-${PN}/${PV}
+ local wrappercfg=${CHOST}-${P}
+
+ exeinto $wrapperdir
+ doexe prefix-stack-ccwrap
+
+ local cc
+ for cc in \
+ gcc \
+ g++ \
+ cpp \
+ c++ \
+ windres \
+ ; do
+ dosym prefix-stack-ccwrap $wrapperdir/${CHOST}-${cc}
+ dosym ${CHOST}-${cc} $wrapperdir/${cc}
+ done
+
+ # LDPATH is required to keep gcc-config happy :(
+ cat > ./${wrappercfg} <<-EOF
+ GCC_PATH="${EPREFIX}$wrapperdir"
+ LDPATH="${EPREFIX}$wrapperdir"
+ EOF
+
+ insinto /etc/env.d/gcc
+ doins ./${wrappercfg}
+}
+
+src_install() {
+ if use prefix-stack; then
+ src_install-prefix-stack-ccwrap
+ insinto /etc
+ doins prefix-stack.bash_login
+ insinto /etc/bash
+ newins prefix-stack.bashrc bashrc
+ newenvd prefix-stack.envd.99stack 99stack
+ doenvd 000fallback
+ keepdir /usr/share/aclocal
+ else
+ dobin prefix-stack-setup
+ fi
+ if use prefix; then
+ exeinto /
+ doexe startprefix
+ fi
+}
+
+pkg_preinst() {
+ use prefix-stack || return 0
+ ebegin "Purging @system package set for prefix stack"
+ # In prefix stack we empty out the @system set defined via make.profile,
+ # as we may be using some normal profile, but that @system set applies
+ # to the base prefix only.
+ # Instead, we only put ourselve into the @system set, and have additional
+ # @system packages in our RDEPEND.
+ my_lsprofile() {
+ (
+ cd -P "${1:-.}" || exit 1
+ [[ -r ./parent ]] &&
+ for p in $(<parent)
+ do
+ my_lsprofile "${p}" || exit 1
+ done
+ pwd -P
+ )
+ }
+ local systemset="/etc/portage/profile/packages"
+ dodir "${systemset%/*}"
+ [[ -s ${EROOT}${systemset} ]] &&
+ grep -v "# maintained by ${PN}" \
+ "${EROOT}${systemset}" \
+ > "${ED}${systemset}"
+ local p
+ for p in $(my_lsprofile "${EPREFIX}"/etc/portage/make.profile)
+ do
+ [[ -s ${p}/${systemset##*/} ]] || continue
+ awk '/^[ \t]*[^-#]/{print "-" $1 " # maintained by '"${PN}-${PVR}"'"}' \
+ < "${p}"/packages || die
+ done | sort -u >> "${ED}${systemset}"
+ [[ ${PIPESTATUS[@]} == "0 0" ]] || die "failed to collect for ${systemset}"
+ echo "*${CATEGORY}/${PN} # maintained by ${PN}-${PVR}" >> "${ED}${systemset}" || die
+ eend $?
+}
+
+pkg_postinst() {
+ use prefix-stack || return 0
+ [[ -x ${EROOT}/usr/bin/gcc-config ]] || return 0
+ "${EROOT}"/usr/bin/gcc-config ${CHOST}-${P}
+}