summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-22 00:31:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-22 00:31:30 +0000
commit6fe1dafaa446d9bc41dea28a43551fffa73f6b87 (patch)
treec6ef70a96add765cc1bfc88ac4d1ece5595cc9bf /app-portage
parentae832415103492f73a8351ed7a91cb596392d779 (diff)
gentoo auto-resync : 22:03:2025 - 00:31:29
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9595 -> 9593 bytes
-rw-r--r--app-portage/pycargoebuild/Manifest2
-rw-r--r--app-portage/pycargoebuild/pycargoebuild-0.14.0.ebuild28
3 files changed, 30 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index b7a248638dae..92a6664b209a 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/pycargoebuild/Manifest b/app-portage/pycargoebuild/Manifest
index 5f0e2a441127..672ece1a18d5 100644
--- a/app-portage/pycargoebuild/Manifest
+++ b/app-portage/pycargoebuild/Manifest
@@ -1,3 +1,5 @@
DIST pycargoebuild-0.13.5.tar.gz 54179 BLAKE2B dd4d69a720ad780f69870e4f75b8d3383306c92b0916f713b5af2d9fef19b0d74a30b0fbae89d01fcc8ea6c076503a0d6c53562a666291f3e5ac9b593e745a1f SHA512 fcc66719c83e14cbad04b6e98bc4149327e79e6f2281fb564f2eb0ceabe6194da5e3a028060a788ecbe7b741b485c8449ba2c5873d4cc396daf79e08d01b9376
+DIST pycargoebuild-0.14.0.tar.gz 57877 BLAKE2B da6d23402a1294f3cee4fd4847079935614877495d52da97140e0d9a41097ab35d220ee0862ec1ad19ca3fac0f6717b36f9649980596cbb2f6b382a751219ccd SHA512 8a10d1233899d0ec17203095e26a0ec5607e68c953914d87812bb051691660a35324638e8f7ca9cdd8717197306914e2e81e7733d0b310aca3af30fea84d76b8
EBUILD pycargoebuild-0.13.5.ebuild 609 BLAKE2B b4f311ca86b846870b85b271f07025f43ab7a2a15fa3ca2a1a6723d0dc33c5ccc010c2fa17f3e6f5de0c385b5ff4337b05bd2c762288fba92d1301cd3e2962f7 SHA512 390aadc8308256a8d041b695ca1ec75428f19652424c61625d3cbb64f0313f3fc22f64547ca03bcbd6a4e7d341e1a4336ee2e88442482409d21c398f1657e7bf
+EBUILD pycargoebuild-0.14.0.ebuild 610 BLAKE2B b4869273ef4e91a027a4e1aaef2991ae99ca8318d43d6c3533aeecf520ff13fa6926d7ec1876d1b7992f3ee6b511a1dba8909ae3aae9779e5dc96ba62a590048 SHA512 796539a6e0adb383d786cc1f4e7e5f8beb7ffc24ac3616feb4187fae97c6da264e39f8f4e0dd6ef70bcff1e97c4eb6872092ef636c2975b0ec2cdbe24ff670d0
MISC metadata.xml 384 BLAKE2B a5c91cf81989cb7f2ff504cd9931e89cb85a2b17721818efbc436d13e68d673c4f384839c67eeec8fe24c1a78b112c3fe37ee1722d2d28f44c5a075ec8fe18ba SHA512 76ffa916e9630225aadb9a0d2073087fcb848b782f6e44c28c354533c5329ed337e609666ee7eba90ef1191be2a34e968d3bc06556cfafce32a43a22100cc6f0
diff --git a/app-portage/pycargoebuild/pycargoebuild-0.14.0.ebuild b/app-portage/pycargoebuild/pycargoebuild-0.14.0.ebuild
new file mode 100644
index 000000000000..e30eb2854e23
--- /dev/null
+++ b/app-portage/pycargoebuild/pycargoebuild-0.14.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} pypy3 pypy3_11 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A generator for Rust/Cargo ebuilds written in Python"
+HOMEPAGE="
+ https://github.com/projg2/pycargoebuild/
+ https://pypi.org/project/pycargoebuild/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64"
+
+RDEPEND="
+ dev-python/license-expression[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+
+distutils_enable_tests pytest