summaryrefslogtreecommitdiff
path: root/app-portage
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-20 00:02:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-20 00:02:16 +0100
commit77b275a53383b07b154caa09feb6f4961b206638 (patch)
treebf2b88f1f848dfe69541c3d78aaa35ef22560107 /app-portage
parent9d4810f84de876ec9d0ae03d0d44224500b41188 (diff)
gentoo auto-resync : 20:05:2024 - 00:02:15
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/Manifest.gzbin9600 -> 9596 bytes
-rw-r--r--app-portage/pfl/Manifest2
-rw-r--r--app-portage/pfl/pfl-3.5.3.ebuild49
3 files changed, 51 insertions, 0 deletions
diff --git a/app-portage/Manifest.gz b/app-portage/Manifest.gz
index c3ddb41810d7..2b46e07371e1 100644
--- a/app-portage/Manifest.gz
+++ b/app-portage/Manifest.gz
Binary files differ
diff --git a/app-portage/pfl/Manifest b/app-portage/pfl/Manifest
index d7082657edf2..fa0eb583b4c1 100644
--- a/app-portage/pfl/Manifest
+++ b/app-portage/pfl/Manifest
@@ -1,3 +1,5 @@
DIST pfl-3.5.2.tar.gz 21248 BLAKE2B 28f4f05bc533f4b27cdbef7f2706ed99f885983e4f9e4f2580e07b772bef471eeca197a41d03059e28c2053869de4cb5295a9923dcba6f598bbf6e6be5e57185 SHA512 5f38b627cd5928396fe8202dd822756ed63b6dd80d98d1ee3da9998eb750070e9a921d652bbc7ed852e4944005f9d6c61c14c67be01c591f5c82ca50f869465e
+DIST pfl-3.5.3.tar.gz 21303 BLAKE2B b7b4bf57b3ab7b8a118b84f412481485570274c9f37947c86d104b8e34a5fcac7748a3dbc928e66193813fec36a0a630a6ae7eb4a9cb25105b4abfc4d5b85344 SHA512 3e6e18cb80b054379bf938cfc02e44f9c26bdf959bceb9c85ba2f97cd60c5c9e8bf030fac093f7e0a9314463328b724ed812424298ffd9b9a146fb5900382d49
EBUILD pfl-3.5.2.ebuild 1258 BLAKE2B df023404997f5f6ff652988ff4a7a9aa2f74e96465be3a397e1f880a019e2c9093c74267faf479d9f84edd0fb3b7fa3826bae46e01133df538b8df34b03a654d SHA512 b3e1d6082116de2b0ef1c2d21e93f7ad9fb1bf6a6484de9077e48862e3becadc3e0535186adddd907c2aa48e2720e9fb2222391cd8f9f5809a8fc65694921886
+EBUILD pfl-3.5.3.ebuild 1265 BLAKE2B f0152b271be07e3a6d398885f8f1f9ff923938a655e9995560bbb307d0a021f12f910b7f068e0f39e39dca471a7e9640f12ed025e2975f788affdd077598285d SHA512 6ad65b02432eabe7bf3d3a5c28655583b48b691579ecf9185f1c8e7f207d84bb0aa1ebb35bd3d6640a758d0119059c73575bed75f5b39ff2aa5ab32c901ca5a6
MISC metadata.xml 584 BLAKE2B fd0efa0091e062c54bafbae6ba72101c43335b44071fa6bec9fd05583e4cd5b65372eda758bce4a4ab61581811c65f8f4a7515e1d63a66b57f9d9ef60d40f4ba SHA512 c194c1d03bd40333d00263e40534b7c980d54184a934f6199a6d2e008f35bef9f18883523f8678cf7e8472ac4dcbd5a817c587e4f80664407c44a4d24fe82497
diff --git a/app-portage/pfl/pfl-3.5.3.ebuild b/app-portage/pfl/pfl-3.5.3.ebuild
new file mode 100644
index 000000000000..287a582296b9
--- /dev/null
+++ b/app-portage/pfl/pfl-3.5.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 systemd
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="https://www.portagefilelist.de https://github.com/portagefilelist/client"
+SRC_URI="https://github.com/portagefilelist/client/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/client-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+RDEPEND="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/termcolor[${PYTHON_USEDEP}]
+ sys-apps/portage[${PYTHON_USEDEP}]
+ network-cron? ( sys-apps/util-linux[caps] )
+"
+
+python_install_all() {
+ if use network-cron ; then
+ exeinto /etc/cron.weekly
+ doexe cron/pfl
+ fi
+
+ systemd_dounit systemd/pfl.{service,timer}
+
+ keepdir /var/lib/${PN}
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+ touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+ fi
+ chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+ chmod 775 "${EROOT}/var/lib/${PN}" || die
+}