summaryrefslogtreecommitdiff
path: root/app-shells/bash-completion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-13 16:55:35 +0000
commit1dde4e5c4b92d849bf1abf0a48135b2a0644f7e1 (patch)
treec99a472cce74148d499f42ada873454b0e32a42d /app-shells/bash-completion
parentda6a52f691ef980bab92d003d5df8f463c623af8 (diff)
gentoo resync : 13.03.2018
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/Manifest3
-rw-r--r--app-shells/bash-completion/bash-completion-2.7-r3.ebuild133
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild7
3 files changed, 142 insertions, 1 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 3c9fdd254d82..b759e63ef940 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -4,5 +4,6 @@ DIST bash-completion-2.7.tar.xz 280048 BLAKE2B 88b09f451fd4e14daf8e139951a4b65aa
DIST bashcomp-2.0.2.tar.gz 3625 BLAKE2B ebd835e23634e8a7491467ad66c53941763cea43bad75fe24982d3885be2d2ba132e5273a655fec34705224315d7a3f0248c030fb7685fc613ac4f489cde5bf5 SHA512 46bc1bcc32263135f44be68569459a409250dd2c81c18190735f11e13a26508e9d3cb91d24a8fe7b21bdea678347873b7ac1b67d5e8c78c8444011f85dfdcdce
EBUILD bash-completion-2.4-r1.ebuild 3161 BLAKE2B 0c3b185bb625c951f47fb9571695ac67900d67868a0bab27d1a80cb15a31e997422fa8e43677f4d68c6644e10f502c25fad166e1ad1257696c9795bcdc2967c0 SHA512 2d6366a7609d3fab9a423fac06e2c78957f079c37a9c69d9694dac6f70ed50d4234b14f4fb54dda303ef916ec6f92402179b6bb2830208d83e6c5e98bacfb693
EBUILD bash-completion-2.7-r2.ebuild 3919 BLAKE2B 31c2303a5677e4b4170271383d9ae2f4eed90e7ad686e5f36372ec46f14365167e863dcf9d2465832b0d092b89d43d61909ba08426666d0aa9c9a77b9aa882ef SHA512 99a4b6f6c0ec34c2db9a31fa97e6afbea4ec45d45b4521b0d8b583154767828f38df7b1ba8885ae23e7f33b6f3f9e7d3e325a961410be3de529fe3057fe9bd51
-EBUILD bash-completion-9999.ebuild 3910 BLAKE2B 460f3a1a5bf4cfd9263bda21ea0a3e1ababb3880907b2e6e4c5a19e7f00823a33b6455d1f808f0ec1f3d9a94efbfe30065dcc1dbaede2a57ce13db19c26b2ebc SHA512 618c22f57fce51fc1218002d79ac5159e2820f68ab015a6345708e62546463f5866d4b2f0f8d30cc612499461dc3cc766b2827f359f70f5976add9ee91f8419c
+EBUILD bash-completion-2.7-r3.ebuild 4119 BLAKE2B 9365a14393d01d6b76e6d6ff85bf3067436035049c38110a3efaae396f4b51fd6ba00d02639b606396fddacda85df6fe253283fc071411be1607d2e95ee8eeec SHA512 53b0bf69f10b444b75ec6b6ab75a1241f93a012d1a642b5fa10d233dfa3e89c8bd18fa30536303488c6d4bde959cb910430b68ae1eb1dc00d1e537494957052c
+EBUILD bash-completion-9999.ebuild 4111 BLAKE2B 2ab05047183a4d61375bbe227d636f0712d4af2bc02ff13031fd60b6479387b9d196035970ce6ff7675eb573d8bc5517f908dbcaff9814f619a1b11d41b599de SHA512 d88f046b364efd340f390e3c2fa27bfa7fae666a82addd42f10fc1b320dd46c7dd74e21d122c885e40495b120f6dbdc024bc600ce0d795c3d106e4218511098b
MISC metadata.xml 1285 BLAKE2B 67ec44c85388b85802294201046537898af798f98bb3ffac39fcf9720a5aacad33aaa5bbbcd56e6f9ea1826c97f70c990810b4e04fbaeedb95f296f8c0838a1d SHA512 1bdcc390d3e58fbd70506738f281a165a9bad69d14be9774b7ae75deac54c5a1bdf6170a16d8ac817ecd15dd4ac820b3e861e208b1d80a9b5739b0d41a9e1e03
diff --git a/app-shells/bash-completion/bash-completion-2.7-r3.ebuild b/app-shells/bash-completion/bash-completion-2.7-r3.ebuild
new file mode 100644
index 000000000000..b7746efc1399
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-2.7-r3.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+BASHCOMP_P=bashcomp-2.0.2
+inherit versionator
+
+DESCRIPTION="Programmable Completion for bash"
+HOMEPAGE="https://github.com/scop/bash-completion"
+SRC_URI="https://github.com/scop/bash-completion/releases/download/${PV}/${P}.tar.xz
+ https://bitbucket.org/mgorny/bashcomp2/downloads/${BASHCOMP_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris"
+IUSE="test"
+# Multiple test failures, need to investigate the exact problem
+RESTRICT="test"
+
+# completion collision with net-fs/mc
+RDEPEND=">=app-shells/bash-4.3_p30-r1
+ sys-apps/miscfiles
+ !app-eselect/eselect-bashcomp
+ !!net-fs/mc"
+DEPEND="app-arch/xz-utils
+ test? (
+ ${RDEPEND}
+ app-misc/dtach
+ dev-util/dejagnu
+ dev-tcltk/tcllib
+ )"
+PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
+
+# Remove unwanted completions.
+STRIP_COMPLETIONS=(
+ # Slackware package stuff, quite generic names cause collisions
+ # (e.g. with sys-apps/pacman)
+ explodepkg installpkg makepkg pkgtool removepkg upgradepkg
+
+ # Debian/Red Hat network stuff
+ ifdown ifup ifstatus
+
+ # Installed in app-editors/vim-core
+ xxd
+
+ # Now-dead symlinks to deprecated completions
+ hd ncal
+
+ # Installed by sys-apps/util-linux-2.28
+ mount umount mount.linux umount.linux
+
+ # Installed by sys-apps/util-linux-2.31
+ rfkill
+)
+
+src_prepare() {
+ eapply "${WORKDIR}/${BASHCOMP_P}/${PN}"-2.1_p*.patch
+ # Bug 543100, update bug 601194
+ eapply "${FILESDIR}/${PN}-2.1-escape-characters-r1.patch"
+ eapply_user
+
+ # Remove implicit completions for vim.
+ # https://bugs.gentoo.org/649986
+ sed -i -e 's/vi vim gvim rvim view rview rgvim rgview gview//' \
+ bash_completion || die
+ rm test/completion/vi.exp || die
+}
+
+src_test() {
+ # Tests need an interactive shell, #477066
+ # idea stolen from:
+ # http://pkgs.fedoraproject.org/cgit/rpms/bash-completion.git/tree/bash-completion.spec
+
+ # real-time output of the log ;-)
+ touch "${T}/dtach-test.log" || die
+ tail -f "${T}/dtach-test.log" &
+ local tail_pid=${!}
+
+ nonfatal dtach -N "${T}/dtach.sock" \
+ bash -c 'emake check &> "${T}"/dtach-test.log; echo ${?} > "${T}"/dtach-test.out'
+
+ kill "${tail_pid}"
+ [[ -f ${T}/dtach-test.out ]] || die "Unable to run tests"
+ [[ $(<"${T}"/dtach-test.out) == 0 ]] || die "Tests failed"
+}
+
+src_install() {
+ # work-around race conditions, bug #526996
+ mkdir -p "${ED}"/usr/share/bash-completion/{completions,helpers} || die
+
+ emake DESTDIR="${D}" profiledir="${EPREFIX}"/etc/bash/bashrc.d install
+
+ local file
+ for file in "${STRIP_COMPLETIONS[@]}"; do
+ rm "${ED}"/usr/share/bash-completion/completions/${file} || die
+ done
+ # remove deprecated completions (moved to other packages)
+ rm "${ED}"/usr/share/bash-completion/completions/_* || die
+
+ dodoc AUTHORS CHANGES CONTRIBUTING.md README.md
+
+ # install the eselect module
+ insinto /usr/share/eselect/modules
+ doins "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect"
+ doman "${WORKDIR}/${BASHCOMP_P}/bashcomp.eselect.5"
+}
+
+pkg_postinst() {
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ if ! version_is_at_least 2.1-r90 ${v}; then
+ ewarn "For bash-completion autoloader to work, all completions need to"
+ ewarn "be installed in /usr/share/bash-completion/completions. You may"
+ ewarn "need to rebuild packages that installed completions in the old"
+ ewarn "location. You can do this using:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/usr/share/bash-completion -maxdepth 1 -type f '!' -name 'bash_completion' -exec emerge -1v {} +"
+ ewarn
+ ewarn "After the rebuild, you should remove the old setup symlinks:"
+ ewarn
+ ewarn "$ find ${EPREFIX}/etc/bash_completion.d -type l -delete"
+ fi
+ done
+
+ if has_version 'app-shells/zsh'; then
+ elog
+ elog "If you are interested in using the provided bash completion functions with"
+ elog "zsh, valuable tips on the effective use of bashcompinit are available:"
+ elog " http://www.zsh.org/mla/workers/2003/msg00046.html"
+ elog
+ fi
+}
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 5a21ed358e41..79657c0d217b 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -60,6 +60,13 @@ src_unpack() {
src_prepare() {
eapply "${WORKDIR}/${BASHCOMP_P}/${PN}"-2.1_p*.patch
eapply_user
+
+ # Remove implicit completions for vim.
+ # https://bugs.gentoo.org/649986
+ sed -i -e 's/vi vim gvim rvim view rview rgvim rgview gview//' \
+ bash_completion || die
+ rm test/completion/vi.exp || die
+
eautoreconf
}