summaryrefslogtreecommitdiff
path: root/app-shells/bash-completion
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-30 11:19:18 +0100
commit62f67115b5c46134c34f88f4b1cbdacc19384c0a (patch)
tree0a76b14de203a4c23040e5665e39df8de9867745 /app-shells/bash-completion
parent265dbe5dbc14c199299496c6db8fce3f76647015 (diff)
gentoo resync : 30.09.2018
Diffstat (limited to 'app-shells/bash-completion')
-rw-r--r--app-shells/bash-completion/Manifest2
-rw-r--r--app-shells/bash-completion/bash-completion-9999.ebuild19
2 files changed, 16 insertions, 5 deletions
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index ea20b3ee5dc0..1b572fa00928 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -4,5 +4,5 @@ DIST bash-completion-2.8.tar.xz 286128 BLAKE2B a99faeb3c9ee2ea6d1cc9988e61951f4e
DIST bashcomp-2.0.2.tar.gz 3625 BLAKE2B ebd835e23634e8a7491467ad66c53941763cea43bad75fe24982d3885be2d2ba132e5273a655fec34705224315d7a3f0248c030fb7685fc613ac4f489cde5bf5 SHA512 46bc1bcc32263135f44be68569459a409250dd2c81c18190735f11e13a26508e9d3cb91d24a8fe7b21bdea678347873b7ac1b67d5e8c78c8444011f85dfdcdce
EBUILD bash-completion-2.7-r3.ebuild 4109 BLAKE2B b19159a733eb34738622add375c11d71dad1b5bee4c16b3d7bf2b2d588757e0b412807601a3e9ab9a2bb9e1a796354d59f3fbe796f91577d7eb5368c499896f5 SHA512 2e91fc722b51b39cef6ba2892645cac41321d840e14d3774732084f6a091859d5ff01282e10a7ce1cc5ed89ed8e1473fe7afee551f0df4c1104b4d44dd7c770a
EBUILD bash-completion-2.8.ebuild 4068 BLAKE2B 45ddc9957d0a244be75adf3e9e2654987b64394f8a30e80fd28fe7621abfe46b7b9f79b8dcf067118ddc2f5bbf1ae238708d04d132cbadbc2be6879e9f39aa10 SHA512 6d1ab2d0ec5ff94310645780428e606b476610f2e40d55ebbfd0e56c6f8fd441f5cf2df737221b0bbecab28863a5aa6eeec0028c7643fdbdf0f01835bcefc70e
-EBUILD bash-completion-9999.ebuild 3957 BLAKE2B 904e828e4d3445cdd8709e255af384e5dece5e84fc7e0871b5d8492637803a7453c93d736fbed8373adbcff3b932ecf580eff5d60958275fd8b226f34ca8a178 SHA512 90384a3dcb94da824f31b023b57019bfad9807eed8fe875b27b37debb32db177d23642b21807e38e25fa77a9dd7f7ebc8f17fe41ecd58ac9ce530c193dbecb75
+EBUILD bash-completion-9999.ebuild 4273 BLAKE2B 8719ac5d05789b937b58f4f8a74b18a1bf148b95e7494274725a24baa82bfcbe05b892824e2caa4640ff72bb2b337aa233c44a009d40bdb9f7bcef5cdbba2bd0 SHA512 dcbd4bc4b8d11b841ac0d0d2d2f1ffc11b2ebe4b212a8922db5e1c96c229c57f07fd6cd2b09abcea39a8bc9d7392309769509e09fdfa723c128557183e8880ba
MISC metadata.xml 1309 BLAKE2B db08060cd74841bd7220e688e251225ddaf59e4da737c08785e7c6ce83c2d40600fbe38e9b9449fb559ccb2d03b8c2368295b647ec2a52191429fe1d3d1c7470 SHA512 3ee23fb6cbee1e80a0c8fab13f7bb67bdad3292fa8ec187e306b00804a7bf709358c8c08eda4101a5f5baa408e0892aa94c07ae466b5beae4edc18055b1192ee
diff --git a/app-shells/bash-completion/bash-completion-9999.ebuild b/app-shells/bash-completion/bash-completion-9999.ebuild
index 79ee3e0ac0af..766299412c53 100644
--- a/app-shells/bash-completion/bash-completion-9999.ebuild
+++ b/app-shells/bash-completion/bash-completion-9999.ebuild
@@ -4,20 +4,22 @@
EAPI=6
BASHCOMP_P=bashcomp-2.0.2
-EGIT_REPO_URI="https://github.com/scop/bash-completion"
-inherit autotools eapi7-ver git-r3
+PYTHON_COMPAT=( python3_{5,6} )
+inherit autotools eapi7-ver git-r3 python-any-r1
DESCRIPTION="Programmable Completion for bash"
HOMEPAGE="https://github.com/scop/bash-completion"
+EGIT_REPO_URI="https://github.com/scop/bash-completion"
SRC_URI="https://bitbucket.org/mgorny/bashcomp2/downloads/${BASHCOMP_P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS=""
IUSE="test"
+RESTRICT="!test? ( test )"
# completion collision with net-fs/mc
-RDEPEND=">=app-shells/bash-4.3_p30-r1
+RDEPEND=">=app-shells/bash-4.3_p30-r1:0
sys-apps/miscfiles
!app-eselect/eselect-bashcomp
!!net-fs/mc"
@@ -27,6 +29,10 @@ DEPEND="app-arch/xz-utils
app-misc/dtach
dev-util/dejagnu
dev-tcltk/tcllib
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
)"
PDEPEND=">=app-shells/gentoo-bashcomp-20140911"
@@ -52,6 +58,11 @@ STRIP_COMPLETIONS=(
_rfkill
)
+python_check_deps() {
+ has_version "dev-python/pexpect[${PYTHON_USEDEP}]" &&
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
src_unpack() {
git-r3_src_unpack
default