summaryrefslogtreecommitdiff
path: root/app-shells/bash/bash-2.05b_p13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /app-shells/bash/bash-2.05b_p13.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'app-shells/bash/bash-2.05b_p13.ebuild')
-rw-r--r--app-shells/bash/bash-2.05b_p13.ebuild26
1 files changed, 15 insertions, 11 deletions
diff --git a/app-shells/bash/bash-2.05b_p13.ebuild b/app-shells/bash/bash-2.05b_p13.ebuild
index cdacaa870073..5d27c8bf42fa 100644
--- a/app-shells/bash/bash-2.05b_p13.ebuild
+++ b/app-shells/bash/bash-2.05b_p13.ebuild
@@ -47,18 +47,19 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-2.05b-destdir.patch
- "${FILESDIR}"/autoconf-mktime-2.53.patch #220040
+ "${FILESDIR}"/autoconf-mktime-2.53.patch # bug #220040
"${FILESDIR}"/${PN}-2.05b-protos.patch
"${FILESDIR}"/${PN}-2.05b-empty-herestring.patch
- "${FILESDIR}"/${PN}-2.05b-rbash.patch #26854
- "${FILESDIR}"/${PN}-2.05b-parallel-build.patch #41002
+ "${FILESDIR}"/${PN}-2.05b-rbash.patch # bug #26854
+ "${FILESDIR}"/${PN}-2.05b-parallel-build.patch # bug #41002
"${FILESDIR}"/${PN}-2.05b-jobs.patch
"${FILESDIR}"/${PN}-2.05b-fix-job-warning.patch
- "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch #431850
+ "${FILESDIR}"/${PN}-3.1-dev-fd-buffer-overflow.patch # bug #431850
)
pkg_setup() {
- if is-flag -malign-double ; then #7332
+ # bug #7332
+ if is-flag -malign-double ; then
eerror "Detected bad CFLAGS '-malign-double'. Do not use this"
eerror "as it breaks LFS (struct stat64) on x86."
die "remove -malign-double from your CFLAGS mr ricer"
@@ -84,7 +85,13 @@ src_prepare() {
src_configure() {
local myconf=(
--with-installed-readline=.
+
+ # Force linking with system curses ... the bundled termcap lib
+ # sucks bad compared to ncurses. For the most part, ncurses
+ # is here because readline needs it. But bash itself calls
+ # ncurses in one or two small places :(.
--with-curses
+
$(use_with afs)
$(use_enable net net-redirections)
--disable-profiling
@@ -121,16 +128,13 @@ src_configure() {
# is at least what's in the DEPEND up above.
export ac_cv_rl_version=6.2
- # Force linking with system curses ... the bundled termcap lib
- # sucks bad compared to ncurses. For the most part, ncurses
- # is here because readline needs it. But bash itself calls
- # ncurses in one or two small places :(.
+ # bug #444070
+ tc-export AR
- tc-export AR #444070
# This old autoconf script does not re-exec itself properly and fails when
# /bin/sh is not bash. Rather than try to regen everything, just force the
# use of bash directly.
- CONFIG_SHELL="/bin/bash" econf "${myconf[@]}"
+ CONFIG_SHELL="${BROOT}/bin/bash" econf "${myconf[@]}"
}
src_install() {