summaryrefslogtreecommitdiff
path: root/app-shells/ccsh/ccsh-0.0.4-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/ccsh/ccsh-0.0.4-r4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/ccsh/ccsh-0.0.4-r4.ebuild')
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-shells/ccsh/ccsh-0.0.4-r4.ebuild b/app-shells/ccsh/ccsh-0.0.4-r4.ebuild
new file mode 100644
index 000000000000..aa40d26b0182
--- /dev/null
+++ b/app-shells/ccsh/ccsh-0.0.4-r4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="UNIX Shell for people already familiar with the C language"
+HOMEPAGE="http://ccsh.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ccsh/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ exeinto /bin
+ doexe "${PN}"
+ newman "${PN}.man" "${PN}.1"
+ dodoc ChangeLog README TODO
+}