summaryrefslogtreecommitdiff
path: root/app-shells/fzy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-16 12:59:29 +0000
commit79599515788b85b18aa655e7b7f8cc05c1bbddd8 (patch)
treeade7cb031f363fad64c77139dea7aa3d81908537 /app-shells/fzy
parent6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (diff)
gentoo resync : 16.02.1018
Diffstat (limited to 'app-shells/fzy')
-rw-r--r--app-shells/fzy/Manifest1
-rw-r--r--app-shells/fzy/files/fzy-add-utf-8-support.patch89
2 files changed, 0 insertions, 90 deletions
diff --git a/app-shells/fzy/Manifest b/app-shells/fzy/Manifest
index c77861d3a6ef..4f32e67062ab 100644
--- a/app-shells/fzy/Manifest
+++ b/app-shells/fzy/Manifest
@@ -1,5 +1,4 @@
AUX fzy-0.9-cflags.patch 299 BLAKE2B 61685e7180741ec77449b5de6fa711b4939faedd94dfcfd84ec86be0ef963b13d5a5308e294f4f22e83682982671a528b64446979fe41e112aeb8c5d143e865e SHA512 f3ea9b90a75f0a013466ef00190dbca451b22015e0a3c3f7e823f61dc2e4ef7d64f90a9685fec311675fb6c5bc788bb7436da2fd89f4f6baade4dfbee8318635
-AUX fzy-add-utf-8-support.patch 2642 BLAKE2B bdece2ab5d9122c9c2f306271b1c795c1130c145e3a434d4b831dd680bbdc09e5241763391fc2efa16a6af50cfbaf49b3fe98364f5f56a25b2d78af8fcba8a1b SHA512 203c0e8e7a9583661cd7d85cc094016eed2149a82fb55a578075e5d2fe513cbe2f7241ea76660e5990efd6b5f573f584ab3345ae832439fbea80950c64f7803b
DIST fzy-1.0.tar.gz 47432 BLAKE2B 5fef7061c797e63dabc3f77daf3dbc8a58671c257430dc8ba4680363a9ace5722562fc7e0aba618d53820e703b261dbe0182638f16223d1202080450a6c21ec2 SHA512 de5ed1af035260f4ae550c53b08c4ff302c978350784cbfd2981d1691f55d9c0f26b9333c74adea939b3f4578dd47e66ee99112e10afc5497c64011827d19dbc
EBUILD fzy-1.0.ebuild 1108 BLAKE2B 74ad203c978e5057efcd8b4a0dc69c08893e4e79074e4cdc3791d721a645b79437dae4aea10871280e457a2625d936b183dbd4b7c9bb11f518df0d92b37211a8 SHA512 905ae14042d9cbfa2c17ba61cbf2f9eca83c1f10bfa8097070379f111de62d9c12759a3c96c6b191c43dfe1db0f04f0314a6a238ad376de39c9a496644f753a9
EBUILD fzy-9999.ebuild 1108 BLAKE2B 74ad203c978e5057efcd8b4a0dc69c08893e4e79074e4cdc3791d721a645b79437dae4aea10871280e457a2625d936b183dbd4b7c9bb11f518df0d92b37211a8 SHA512 905ae14042d9cbfa2c17ba61cbf2f9eca83c1f10bfa8097070379f111de62d9c12759a3c96c6b191c43dfe1db0f04f0314a6a238ad376de39c9a496644f753a9
diff --git a/app-shells/fzy/files/fzy-add-utf-8-support.patch b/app-shells/fzy/files/fzy-add-utf-8-support.patch
deleted file mode 100644
index 886957379a83..000000000000
--- a/app-shells/fzy/files/fzy-add-utf-8-support.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 8dd7a9f49c2b65f28025902106f364ff11d4170d Mon Sep 17 00:00:00 2001
-From: syrrim <syrrim0@gmail.com>
-Date: Mon, 23 Apr 2018 01:25:48 -0400
-Subject: [PATCH] add utf-8 support to input, fixes #21
-
-- non ascii bytes won't be ignored
-- one can seek over and delete whole utf-8 codepoints at a time
-- the cursor will be positioned properly around double width chars
----
- src/tty_interface.c | 31 ++++++++++++++++++++++++++-----
- 1 file changed, 26 insertions(+), 5 deletions(-)
-
-diff --git a/src/tty_interface.c b/src/tty_interface.c
-index a7d506e..35f2919 100644
---- a/src/tty_interface.c
-+++ b/src/tty_interface.c
-@@ -7,6 +7,14 @@
- #include "tty_interface.h"
- #include "../config.h"
-
-+static int isprint_unicode(char c){
-+ return isprint(c) || c & (1<<7);
-+}
-+
-+static int is_boundary(char c) {
-+ return ~c & (1<<7) || c & (1<<6);
-+}
-+
- static void clear(tty_interface_t *state) {
- tty_t *tty = state->tty;
-
-@@ -95,7 +103,10 @@ static void draw(tty_interface_t *state) {
- tty_moveup(tty, num_lines);
- }
-
-- tty_setcol(tty, strlen(options->prompt) + state->cursor);
-+ tty_setcol(tty, 0);
-+ fputs(options->prompt, tty->fout);
-+ for(size_t i=0; i<state->cursor; i++)
-+ fputc(state->search[i], tty->fout);
- tty_flush(tty);
- }
-
-@@ -138,9 +149,13 @@ static void action_del_char(tty_interface_t *state) {
- if(state->cursor == 0) {
- return;
- }
-+ size_t original_cursor = state->cursor;
-
- state->cursor--;
-- memmove(&state->search[state->cursor], &state->search[state->cursor + 1], length - state->cursor);
-+ while(!is_boundary(state->search[state->cursor]) && state->cursor)
-+ state->cursor--;
-+
-+ memmove(&state->search[state->cursor], &state->search[original_cursor], length - original_cursor + 1);
- }
- }
-
-@@ -178,13 +193,19 @@ static void action_next(tty_interface_t *state) {
- }
-
- static void action_left(tty_interface_t *state) {
-- if (state->cursor > 0)
-+ if (state->cursor > 0){
- state->cursor--;
-+ while(!is_boundary(state->search[state->cursor]) && state->cursor)
-+ state->cursor--;
-+ }
- }
-
- static void action_right(tty_interface_t *state) {
-- if (state->cursor < strlen(state->search))
-+ if (state->cursor < strlen(state->search)){
- state->cursor++;
-+ while(!is_boundary(state->search[state->cursor]))
-+ state->cursor++;
-+ }
- }
-
- static void action_beginning(tty_interface_t *state) {
-@@ -315,7 +336,7 @@ static void handle_input(tty_interface_t *state, const char *s) {
-
- /* No matching keybinding, add to search */
- for (int i = 0; input[i]; i++)
-- if (isprint(input[i]))
-+ if (isprint_unicode(input[i]))
- append_search(state, input[i]);
-
- /* We have processed the input, so clear it */