summaryrefslogtreecommitdiff
path: root/app-shells/hstr/hstr-2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /app-shells/hstr/hstr-2.2-r1.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'app-shells/hstr/hstr-2.2-r1.ebuild')
-rw-r--r--app-shells/hstr/hstr-2.2-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-shells/hstr/hstr-2.2-r1.ebuild b/app-shells/hstr/hstr-2.2-r1.ebuild
new file mode 100644
index 000000000000..ced186d9d6b4
--- /dev/null
+++ b/app-shells/hstr/hstr-2.2-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Shell history suggest box"
+HOMEPAGE="https://github.com/dvorka/hstr http://www.mindforger.com"
+SRC_URI="https://github.com/dvorka/hstr/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="
+ sys-libs/ncurses:=[unicode(+)]"
+
+DEPEND="
+ ${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( CONFIGURATION.md README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-fix-ncurses-configure.patch
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e 's:-O2::g' \
+ -i src/Makefile.am || die
+
+ tc-export PKG_CONFIG
+
+ eautoreconf
+}