summaryrefslogtreecommitdiff
path: root/app-shells/ksh/ksh-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-09 07:02:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-09 07:02:36 +0000
commit6790f1eddc7029fda1a6bae94751a4ff1eb57776 (patch)
tree125d6b4446116f2b763d90aa93855d5e75c302bb /app-shells/ksh/ksh-9999.ebuild
parent7a808196491672645bab84bf994294bfcf1dd394 (diff)
gentoo auto-resync : 09:01:2024 - 07:02:36
Diffstat (limited to 'app-shells/ksh/ksh-9999.ebuild')
-rw-r--r--app-shells/ksh/ksh-9999.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/app-shells/ksh/ksh-9999.ebuild b/app-shells/ksh/ksh-9999.ebuild
index dd729029724d..c97a769209a6 100644
--- a/app-shells/ksh/ksh-9999.ebuild
+++ b/app-shells/ksh/ksh-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -9,7 +9,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ksh93/ksh"
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
MY_PV=$(ver_rs 3 - 4 .)
SRC_URI="https://github.com/ksh93/${PN}/archive/v${MY_PV}/ksh-v${MY_PV}.tar.gz"
S="${WORKDIR}/${PN}-${MY_PV}"
@@ -40,18 +40,17 @@ src_compile() {
"-Wno-unused-but-set-variable"
"-Wno-cpp"
"-Wno-maybe-uninitialized"
- "-Wno-lto-type-mismatch"
- "-Wno-error=int-conversion"
- "-Wno-int-conversion"
"-P"
)
append-cflags $(test-flags-CC ${extraflags[@]})
+ append-cflags -fno-strict-aliasing
filter-flags '-fdiagnostics-color=always' # https://github.com/ksh93/ksh/issues/379
- export CCFLAGS="${CFLAGS} -fno-strict-aliasing"
+ filter-lto
+ export CCFLAGS="${CFLAGS}"
tc-export AR CC LD NM
- sh bin/package make SHELL="${BROOT}"/bin/sh || die
+ sh bin/package make AR="${AR}" CC="${CC}" NM="${NM}" SHELL="${BROOT}"/bin/sh || die
}
src_test() {