summaryrefslogtreecommitdiff
path: root/app-shells/mpibash
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/mpibash
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/mpibash')
-rw-r--r--app-shells/mpibash/Manifest6
-rw-r--r--app-shells/mpibash/metadata.xml15
-rw-r--r--app-shells/mpibash/mpibash-1.2.ebuild42
-rw-r--r--app-shells/mpibash/mpibash-1.3.ebuild43
-rw-r--r--app-shells/mpibash/mpibash-9999.ebuild43
5 files changed, 149 insertions, 0 deletions
diff --git a/app-shells/mpibash/Manifest b/app-shells/mpibash/Manifest
new file mode 100644
index 000000000000..e18e37b2caca
--- /dev/null
+++ b/app-shells/mpibash/Manifest
@@ -0,0 +1,6 @@
+DIST mpibash-1.2.tar.gz 347083 BLAKE2B 75b79d8e1f418de8220ff502245bc094774984f4760d922297a2ad2fcdb7d87a4a5d28015fd2686fbc68939ac532551046f8a987166accaa8b96025cce9fc79e SHA512 db755dd2c6212a8d7dfd6cbff17d5dffcbc3b6a0286abdad4d2e21790453d2356e88c566abe4648da138d6964098fad581b8fd5beae1335f5787de92f4659104
+DIST mpibash-1.3.tar.gz 369803 BLAKE2B b1959deaa2d5b3bce1a66e5ef0ff41ad156093aec9cc1efcd12873b6d5814ad1586ff951d6fd7f37dab6a55040378774b435edc4e2c8892952480539864f91fa SHA512 4728565239aae80013322231a928fd1e9a59484614a92cf7e314d0cd5c090d3a47de395507ce52f71a6900245855089d659c6509f8c4df3bfd88e46fc2187749
+EBUILD mpibash-1.2.ebuild 1018 BLAKE2B 97e15e59ee643cbd1aee1f23bd6920add75e4cf29132df2aecbca07f000ffae35c04d2fa6f8d1b1ddbc3ebeb4f3b6e45db941cc6c1897a0787fbcc41d8a1f404 SHA512 ed96bc0db5a157c7c6698398ad49f310a1569a908530ee25ec434557be6e28fd2427e574e1559f73a88622428549bdd72a524457c21bd621702207883f376dc2
+EBUILD mpibash-1.3.ebuild 984 BLAKE2B 0d584b8c22c26c47a714582e7afa1a33a1b43a71121f5e9410046b5b484f9ade04b465fd6842e8deb647a1a20ccea3549c1e2f77efd7ff9cc083ff9de192759f SHA512 07f27042d47c45352d90d849d034c1ae6c850db03c36af8077d69b78315d81cc1755d0892aba55eafc9fa71c8b3964c9d9c683c5702903523395fad02c906abc
+EBUILD mpibash-9999.ebuild 984 BLAKE2B 0d584b8c22c26c47a714582e7afa1a33a1b43a71121f5e9410046b5b484f9ade04b465fd6842e8deb647a1a20ccea3549c1e2f77efd7ff9cc083ff9de192759f SHA512 07f27042d47c45352d90d849d034c1ae6c850db03c36af8077d69b78315d81cc1755d0892aba55eafc9fa71c8b3964c9d9c683c5702903523395fad02c906abc
+MISC metadata.xml 461 BLAKE2B 6bc032dcf773dc99625ddc538fff75f78d47d301645c1e5f2a6a6d037260519cad4c76aa4b1f6ff4fd4b90552a73307505008e4ae2a825685eb60c53d5f7027c SHA512 c859d865a24aa9ba99b293ce2ef438ae6060860faed308d358c173d83f3a17017a51f509e80e1e63347781fae2db0bcd7e4a03e8c16561d0f09210ccbdde0c64
diff --git a/app-shells/mpibash/metadata.xml b/app-shells/mpibash/metadata.xml
new file mode 100644
index 000000000000..1a4b981f1128
--- /dev/null
+++ b/app-shells/mpibash/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>junghans@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">lanl/MPI-Bash</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/mpibash/mpibash-1.2.ebuild b/app-shells/mpibash/mpibash-1.2.ebuild
new file mode 100644
index 000000000000..594ac6bc88cb
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools-utils multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+ AUTOTOOLS_AUTORECONF=1
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+ --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}
diff --git a/app-shells/mpibash/mpibash-1.3.ebuild b/app-shells/mpibash/mpibash-1.3.ebuild
new file mode 100644
index 000000000000..76bbce43cda2
--- /dev/null
+++ b/app-shells/mpibash/mpibash-1.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}
diff --git a/app-shells/mpibash/mpibash-9999.ebuild b/app-shells/mpibash/mpibash-9999.ebuild
new file mode 100644
index 000000000000..76bbce43cda2
--- /dev/null
+++ b/app-shells/mpibash/mpibash-9999.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools multilib
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://github.com/lanl/MPI-Bash.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/lanl/MPI-Bash/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="Parallel scripting right from the Bourne-Again Shell (Bash)"
+HOMEPAGE="https://github.com/lanl/MPI-Bash"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="examples"
+
+DEPEND="virtual/mpi
+ >=app-shells/bash-4.2[plugins]
+ sys-cluster/libcircle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
+
+src_configure() {
+ econf --with-plugindir="${EPREFIX}"/usr/$(get_libdir)/bash \
+ --with-bashdir="${EPREFIX}"/usr/include/bash-plugins
+}
+
+src_install() {
+ default
+ sed -i '/^export LD_LIBRARY_PATH/d' "${ED}/usr/bin/${PN}" || die
+ use examples || rm -r "${ED}/usr/share/doc/${PF}/examples" || die
+}