summaryrefslogtreecommitdiff
path: root/app-shells/pdsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-shells/pdsh
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-shells/pdsh')
-rw-r--r--app-shells/pdsh/Manifest3
-rw-r--r--app-shells/pdsh/metadata.xml29
-rw-r--r--app-shells/pdsh/pdsh-2.26-r1.ebuild55
3 files changed, 87 insertions, 0 deletions
diff --git a/app-shells/pdsh/Manifest b/app-shells/pdsh/Manifest
new file mode 100644
index 000000000000..9b8e39ef2b5d
--- /dev/null
+++ b/app-shells/pdsh/Manifest
@@ -0,0 +1,3 @@
+DIST pdsh-2.26.tar.bz2 490732 BLAKE2B 809a7ee0a1026e0cdaea8bf97c046a3a6e2994199dbbdb2cebe56de0393e8422a07e86f1ff60d6e750bf7279ccb43c03ea3aa4529b6fa6a34e3d77d90f0c3597 SHA512 3f15b3bb4fc2cff27a3b5d68de3e6cb74bb4001288a787763358a0641d0cc77c840b2c6641213ef31bc9d9d69cfe9531b25d7a9375630a5b008b1bcffbe95c0a
+EBUILD pdsh-2.26-r1.ebuild 1287 BLAKE2B 4acd78fedf0a8ec33a223502d0c93d0038d912ddea66fa0513a018f2e8ca3a437c17566feee8c63f3cd527a50c2b1968354c7940764bb3c1e49366f5411c266e SHA512 5af633bc908bb1176ffbe79c8ca69689807315aac079a0ba80cfedd08bce905ec7dbb2c97e2aab564db47db9a7139459fbfab995624e6b9780388407514ca20a
+MISC metadata.xml 1204 BLAKE2B db664f8622eaf0976ab1899583abab0268758d2edcdf0dd038ef59f54f1cf86c30956aa9cac35fa1a28a6760196050da01cfdbfcb56742aa233075aaa77a4eed SHA512 abaa972d578e11c47d16497fecbf7d72a07915b0b57c7f6458f82b0a36b55575b2d94a43f6f6a71a925a0e4ed56346056f9bc1d939a4190f2c899fcf58c9c752
diff --git a/app-shells/pdsh/metadata.xml b/app-shells/pdsh/metadata.xml
new file mode 100644
index 000000000000..2c51800069f5
--- /dev/null
+++ b/app-shells/pdsh/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>cluster@gentoo.org</email>
+ <name>Gentoo Cluster Project</name>
+ </maintainer>
+ <longdescription>
+ Pdsh is a high-performance, parallel remote shell utility. It has built-in,
+ thread-safe clients for Berkeley and Kerberos V4 rsh, and can call SSH
+ externally (though with reduced performance). Pdsh uses a "sliding window"
+ parallel algorithm to conserve socket resources on the initiating node and
+ to allow progress to continue while timeouts occur on some connections.
+ Pdsh is similar to DSH, part of the IBM PSSP software offering, but offers
+ improved performance and handling of error conditions. It runs on a variety
+ of platforms (including as a replacement for DSH on AIX/PSSP), but is
+ primarily developed on Linux.
+ </longdescription>
+ <use>
+ <flag name="rsh">
+ This allows the use of rsh (remote shell) and rcp
+ (remote copy) for authoring websites. sftp is a much more secure protocol
+ and is preferred.
+ </flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pdsh</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-shells/pdsh/pdsh-2.26-r1.ebuild b/app-shells/pdsh/pdsh-2.26-r1.ebuild
new file mode 100644
index 000000000000..cd2b214c3640
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.26-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A high-performance, parallel remote shell utility"
+HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="crypt readline rsh static-libs test"
+
+RDEPEND="
+ crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline:0= )"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+pkg_setup() {
+ PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
+ MODULE_CONFIG=""
+
+ local m
+ local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
+
+ for m in ${PDSH_MODULE_LIST}; do
+ if [[ "${valid_modules}" == *:${m}:* ]]; then
+ MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
+ fi
+ done
+
+ elog "Building ${PF} with the following modules:"
+ elog " ${PDSH_MODULE_LIST}"
+ elog "This list can be changed in /etc/portage/make.conf by setting"
+ elog "PDSH_MODULE_LIST=\"module1 module2...\""
+}
+
+src_configure() {
+ econf ${MODULE_CONFIG} \
+ --with-machines \
+ --enable-shared \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+}