summaryrefslogtreecommitdiff
path: root/app-shells/pdsh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-13 16:38:56 +0100
commitea31ad0ed5501d0bf92267c35beaf06ac016bad2 (patch)
tree2fdc433d571e3ead010876d43ce2646b7d783680 /app-shells/pdsh
parent88ebe56470c37b02a044e1091cad6b2df0f3be8f (diff)
gentoo resync : 13.05.2018
Diffstat (limited to 'app-shells/pdsh')
-rw-r--r--app-shells/pdsh/Manifest1
-rw-r--r--app-shells/pdsh/pdsh-2.26-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/app-shells/pdsh/Manifest b/app-shells/pdsh/Manifest
index f2d07d7f69da..3b6e767d40e8 100644
--- a/app-shells/pdsh/Manifest
+++ b/app-shells/pdsh/Manifest
@@ -2,5 +2,6 @@ AUX pdsh-2.18-unbundle-libtool.patch 1738 BLAKE2B dff39459032013b770cfab19407475
DIST pdsh-2.18.tar.bz2 453729 BLAKE2B 1907bd8a368d062a356b513ac50696f5f9fbe52253470005f9690d886ae3b93e76cb66f517a40a4c5f1aa01190624da078d132a82a5285b66b3e9bc8f528b5f4 SHA512 20cd9be5fc38add69f61620f528dd952296615ef099d6288be2ce908ab04cc7a9585387d93936462a1fb577aa6495789ae201f838131623d8f4f01bf904f7b5a
DIST pdsh-2.26.tar.bz2 490732 BLAKE2B 809a7ee0a1026e0cdaea8bf97c046a3a6e2994199dbbdb2cebe56de0393e8422a07e86f1ff60d6e750bf7279ccb43c03ea3aa4529b6fa6a34e3d77d90f0c3597 SHA512 3f15b3bb4fc2cff27a3b5d68de3e6cb74bb4001288a787763358a0641d0cc77c840b2c6641213ef31bc9d9d69cfe9531b25d7a9375630a5b008b1bcffbe95c0a
EBUILD pdsh-2.18-r1.ebuild 1609 BLAKE2B 5c5f0b9c57bae957a771330b3012e8e274ee7039ed8c691cefc197c81cf2318bee27813da5d71e769dc2774259a533fd0ff193689337500762c68be2db431501 SHA512 0c114901331e290ce61c60a7519672d62a572ee804573b702c2869a3972ad57842fbd5ac2ce12113aec1f8555346b21a8ae953f55cc3ae45ef58e9cbad64204c
+EBUILD pdsh-2.26-r1.ebuild 1289 BLAKE2B da484e8208f7f5ff2846f796e4594fc5080d46bef9b8acad5a044a173bc9cd0df98cc68a224baa2efdf28260f3631fe6d0d30dd6a931b2c3ba0e22edaa67091d SHA512 8bd15e08c9839a647311db418fbc2cdd47551bac3527fb42e7a63cb1ff8f681c45885c98f5c47341bf10c10bd6778c2e5877e51f1671b7c81e5c4eae7c264bc5
EBUILD pdsh-2.26.ebuild 1333 BLAKE2B 9a1895cd15d2d25f2d210883a5d40a0c70fdcb37f962a1b2d0817b0e123bfef5c4f0758e8a46133c3c1a84c030c14b37acc3daf370bb1fbcb12231411c37fc29 SHA512 3d22d6c74c7e505af153f0c44b92515f7d2f4fa1b21f436ddf97fbae599a61b9cdd3a891277a9a68216595a88de6b6547f616c33b9eac2456a03dd1f6c62b938
MISC metadata.xml 1204 BLAKE2B db664f8622eaf0976ab1899583abab0268758d2edcdf0dd038ef59f54f1cf86c30956aa9cac35fa1a28a6760196050da01cfdbfcb56742aa233075aaa77a4eed SHA512 abaa972d578e11c47d16497fecbf7d72a07915b0b57c7f6458f82b0a36b55575b2d94a43f6f6a71a925a0e4ed56346056f9bc1d939a4190f2c899fcf58c9c752
diff --git a/app-shells/pdsh/pdsh-2.26-r1.ebuild b/app-shells/pdsh/pdsh-2.26-r1.ebuild
new file mode 100644
index 000000000000..f9e973342634
--- /dev/null
+++ b/app-shells/pdsh/pdsh-2.26-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A high-performance, parallel remote shell utility"
+HOMEPAGE="https://computing.llnl.gov/linux/pdsh.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crypt readline rsh static-libs test"
+
+RDEPEND="
+ crypt? ( net-misc/openssh )
+ rsh? ( net-misc/netkit-rsh )
+ readline? ( sys-libs/readline:0= )"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/dejagnu )"
+
+pkg_setup() {
+ PDSH_MODULE_LIST="${PDSH_MODULE_LIST:-netgroup}"
+ MODULE_CONFIG=""
+
+ local m
+ local valid_modules=":xcpu:ssh:exec:qshell:genders:nodeupdown:mrsh:mqshell:dshgroups:netgroup:"
+
+ for m in ${PDSH_MODULE_LIST}; do
+ if [[ "${valid_modules}" == *:${m}:* ]]; then
+ MODULE_CONFIG="${MODULE_CONFIG} --with-${m}"
+ fi
+ done
+
+ elog "Building ${PF} with the following modules:"
+ elog " ${PDSH_MODULE_LIST}"
+ elog "This list can be changed in /etc/portage/make.conf by setting"
+ elog "PDSH_MODULE_LIST=\"module1 module2...\""
+}
+
+src_configure() {
+ econf ${MODULE_CONFIG} \
+ --with-machines \
+ --enable-shared \
+ $(use_with crypt ssh) \
+ $(use_with rsh) \
+ $(use_with readline) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+}