summaryrefslogtreecommitdiff
path: root/app-shells/posh-git/posh-git-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-07 18:01:02 +0100
commitf87d83ebb0d6ae5915c4775f762a0b5bceb9b2a5 (patch)
tree69b6db4e0c713061615ae368d69a16b0302e5bb9 /app-shells/posh-git/posh-git-1.1.0.ebuild
parenta519cf56a0e5e456006d39c06f68de5e11c2f7e9 (diff)
gentoo auto-resync : 07:10:2023 - 18:01:02
Diffstat (limited to 'app-shells/posh-git/posh-git-1.1.0.ebuild')
-rw-r--r--app-shells/posh-git/posh-git-1.1.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/posh-git/posh-git-1.1.0.ebuild b/app-shells/posh-git/posh-git-1.1.0.ebuild
new file mode 100644
index 000000000000..72a1c2f7cce4
--- /dev/null
+++ b/app-shells/posh-git/posh-git-1.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A PowerShell environment for Git"
+HOMEPAGE="http://dahlbyk.github.io/posh-git/
+ https://github.com/dahlbyk/posh-git/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/dahlbyk/${PN}.git"
+else
+ SRC_URI="https://github.com/dahlbyk/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="MIT"
+SLOT="${PV}"
+
+RDEPEND="
+ virtual/pwsh:*
+ dev-vcs/git
+"
+
+DOCS=( CHANGELOG.md ISSUE_TEMPLATE.md README.md profile.example.ps1 )
+
+src_install() {
+ insinto "/usr/share/GentooPowerShell/Modules/${PN}/${PV}"
+ doins -r src/.
+
+ einstalldocs
+}