summaryrefslogtreecommitdiff
path: root/app-shells/powerline/powerline-2.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-shells/powerline/powerline-2.7-r1.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-shells/powerline/powerline-2.7-r1.ebuild')
-rw-r--r--app-shells/powerline/powerline-2.7-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-shells/powerline/powerline-2.7-r1.ebuild b/app-shells/powerline/powerline-2.7-r1.ebuild
new file mode 100644
index 000000000000..623ac6d9568c
--- /dev/null
+++ b/app-shells/powerline/powerline-2.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="The ultimate statusline/prompt utility."
+HOMEPAGE="https://github.com/powerline/powerline"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/powerline/powerline"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}-status/${PN}-status-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+S="${WORKDIR}/${PN}-status-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=(
+ "${FILESDIR}"/2.7-ldflags.patch
+)