summaryrefslogtreecommitdiff
path: root/app-shells/push/push-2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-shells/push/push-2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-shells/push/push-2.0-r1.ebuild')
-rw-r--r--app-shells/push/push-2.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-shells/push/push-2.0-r1.ebuild b/app-shells/push/push-2.0-r1.ebuild
new file mode 100644
index 000000000000..d7818abffdee
--- /dev/null
+++ b/app-shells/push/push-2.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vcs-snapshot
+
+DESCRIPTION="A POSIX shell function to treat a variable like an array, quoting args"
+HOMEPAGE="https://github.com/vaeth/push/"
+SRC_URI="https://github.com/vaeth/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+IUSE=""
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins bin/push.sh
+ dodoc README
+}